Mach3 Pierce Delay Issue

A few people have observed that when pierce delay is set to less than 1 second, the actual dwell time in Mach3 is significantly less than 1 second. Anything equal to above 1 second is accurate. Some preliminary research suggests that this a bug within Mach3. Fortunately there is a suitable workaround.

In Mach3 open the general config tab and check the box for “G04 Dwell in ms”. This change forces Mach3 to interpret the pierce delay vales in milliseconds instead of seconds.

Make sure to use pierce delays expressed in milliseconds if you make this change. For example, if you need a .5 second pierce delay, enter 500 for the pierce delay in Fusion 360 Post Processing. Similarly if you need 1.5 seconds you would enter 1500.


I love you.

I love you.

I love you.

I actually saw the post that you created over on the FB page and figured I’d need to look into it. Thanks!

1 Like

Thank you!

Any idea if reinstalling Mach 3 has an effect? Not that it’s particularly difficult to just use milliseconds.

No it doesn’t unfortunately, appears to be a known issue with Mach3.

Thanks @langmuir-daniel… gonna try this tonight. it was super annoying! Made basically cutting anything with the hypertherm pierce delay setting useless!

Thanks for posting. I had a similar problem and I work around it by using a 1 second pierce delay on the initial cut and then adjust all subsequent cuts to 0.8s. If I don’t do this it tends to linger on every subsequent cut (after the first) and can often lead to the torch flaming/arcing out.

I also wondered if it had anything to do with the plasma cutter still running post flow on subsequent ignitions.

I might give the millisecond fix in Mach3 a try. Seems odd that which unit you use matters - but you did suggest it was a known bug.

Thanks again

Daniel, how did you change dwell in fusion 360 to post process in milliseconds vs seconds?

That does not answer how to change fusion only Mach3

There is no need to chane it because the dwell time in Fusion doesnt really have units. So if you need a 1 second dwell, write in 1000.

Thanks! Appreciate it

Oops. Sorry.

In the Post-Processor screen in Fusion where you enter the “Delay” setting just enter it in milliseconds. In Fusion you only have one place to do that & it controls for all of the delays/dwells.

Sheetcam users can specify the setting for each toolpath they define.

Awesome!! Thanks so much. I thought I was going crazy with this!

1 Like

I just got sheetcam and I set the pierce delay in ms for each tool but when I post process, it still comes out in fractions of a second instead of milliseconds…

Example: G04 P0.25 instead of G04 P250

Any fix for that?

I’ve noticed this very same thing. I only have the trial version and was wondering if that was the reason… I’ve changed the time in sheetcam to ms also but, when you look at the G-code, it’s showing up in seconds, not ms… Still using Fusion here but, would like to resolve in Sheetcam sooner than later if possible… :sunny:

No. I believe it’s the Sheetcam Mach3 Post that’s the issue. Their post-processor assumes seconds because that’s the standard Mach3 install.

So you either have to alter the post-processor so you have a ms version or trick it by entering ms in Sheetcam (but telling it those are seconds) and then telling Mach3 in the General Config G04 setting to be ms. Sheetcam will not do the math in the post processor to convert your entry to ms as it’s doing by default but it is ms and Mach3 will be happy. Clear as mud eh? :slightly_smiling_face:

Here’s what’s happening in Sheetcam using their Mach3 post processor.

Sheetcam set for seconds
Enter 1 second
GCode is “G04 P1”

Sheetcam set for ms
Enter 1000
GCode is “G04 P1” which is not what we want. But it’s doing that because the post processor is coded to output in seconds.

The hack:

Sheetcam set for secs
Enter 1000 (milliseconds)
GCode is “G04 P1000” which we do want because our implementations of Mach3 is going to treat these as milliseconds.

So that’s the quick & dirty of things. You would think that Sheetcam’s post would output stuff correctly since we tell Sheetcam if we’re using seconds or milliseconds. But the post doesn’t do that.

I think I have a millisecond based custom Sheetcam post processor but before I upload it so people can use it I’d prefer another set of eyes on it. If you’re a Sheetcam user and want to test my post processor, let me know.

What I’m doing in there is changing the G-Code generation step to take the numeric portion of the Sheetcam G04 output and multiplying by 1000 to offset what Sheetcam has done when you specify ms in your Sheetcam settings (it’s converting to seconds and sending that to the post processor - mine simply reverses that).

i’ll test it out for ya. i was messing with the code last night and adding/deleting a few different things but couldn’t make it show milliseconds. it would always show P0.

I’ll toss it over to you tonight after I get back home. It’s not a huge change but I don’t want to eff up someone’s material without someone else trying it out too.

Ok sounds good… I’ll try it the other way you mentioned too.