Mach3 Pierce Delay Issue

:slightly_smiling_face: Just remember to undo the hack when you try the new post processor or we’re going to be very confused :grin:

That sounds great guys… Very interested to see how this goes… The other thing that was getting me was entering ms type number for pierce delay when setting up a tool in sheetcam… Then run the simulator in sheetcam and sit there and wait for 400 actual seconds… Wasn’t making much sense to me.

I’m probably ok with the hack for now but, the simulation would still be wonky… Right?

Right. But you can slide the speed bar all the way to the right to get some of the time back :slightly_smiling_face:

1 Like

Right on!! Thanks James!

i just tried your “hack” and it seemed to work. I set time unit to seconds, restarted sheetcam, set the pierce delay in my tool to 300 s and post processed a simple file and when i opened the TAP file, the GCode line shows G04 P300

1 Like

Okay here’s the modified post for Sheetcam. Download it and delete the .dxf extension so it’s called “Mach3 plasma milliseconds.scpost” and copy it to your Program Files (x86) > Sheetcam TNG > Posts directory.

Then in Sheetcam, click on Options, Machine, Post Processor tab and in the middle click the down arrow and find the new Mach3 millisecond post processor. (ignore the blackout in the screen snip - it’s where I store my tap files and it’s got some network info that I’d rather keep obscured)

EDIT: Keep your Sheetcam using seconds for the pierce delay (in the tool setup screen) and the new post processor will convert to milliseconds. This one will come out as “G04 P500” which is 1/2 second or 500 milliseconds. Use ms in Sheetcam (like “500ms” to be 1/2s) and Mach3 will be happy with the tap file produced.


The post processor is attached as a fake dxf (since that’s what the forum allows) - you just need to strip off the .dxf so it’s a .scpost filetype.

Mach3 plasma milliseconds.scpost.dxf (4.1 KB)

Ok i’ll try it out. thanks!!

ok i imported it and set everything per your instructions and the tap file displays the G04 output to milliseconds, ie… P300 for example.

then, for shits and giggles, I went back to application options and set the TIME units to ms then edit my tools pierce delay to 300 ms instead of .30 and post processed using your modified post and it still output using milliseconds.

without actually running a live cut, i would say it works. I would keep the time units to MS in sheetcam to match mach3 and cut out the confusion.

Actually that makes sense the way I coded the post. Sheetcam sends a value to the post in seconds regardless of how you specify the units in your tool definition. My version of the post knows that and always outputs in ms.

So if you say “300ms” Sheetcam sends .3 to the post. If you say “.3s” it sends .3 to the post. I’m converting that to ms in the post (the default doesn’t - it just leaves .3 which is what Mach3 fails on if you’re doing seconds in Mach and if you had G04 milliseconds checked in Mach that would be treated as .3ms which is hugely wrong).

I’ll be using the new post to cut a couple of things for someone this weekend and will make sure it’s not doing anything bad. Then I’ll update this (probably start a new thread so it can be found more easily) with pictures & arrows and skip the “use seconds in Sheetcam” as you noted.

(I’ve updated the post above as well in case someone stumbles across this in the future.)

confused! lol. - but that’s easy for me. I need to do this conversion as I’m using sheet cam, mach3 and a finicky Everlast 60s

on a serious note, which set of instructions do I start to follow above? I’m gonna give this a run shortly.

If you’re going to use my updated post processor then you need to have Mach3 set to milliseconds. Then in Sheetcam specify your times as #ms in your torch definition. The tap file will work correctly for Mach3.

Found it, Thank you James.

James, I installed and tried your modification and it does what you say it does. Which post script did you start with for your mod? The post that yours is creating still has some z commands in it and I can’t tell if this is adding time to the pierce delay or just idle time.

I then applied your mod to the (Post processor: Mach3 plasma no X.scpost) and there is none of the Z axis commands in the gcode this time and it runs faster, When I get time to cut then I will compare both and see if the extra time is before or after the torch has fired.

Thank you for providing this.

I thought I did the “no z” but I modded a couple as I was trying things out so I may have done both. I would have thought I’d upload both though if I were providing options :slight_smile:

1 Like

James, I thank you for your modded post that you provided, I now have another tool in my toolbox thanks to you.

Safe cutting.

that might be true. I’ve used/tested his mod a few times and the pierce delays seem to run a bit long even when i change the values. thought is was just me. I’ll mod the original NO Z post and see if that changes anything.

Also, i don’t remember the Z axis values changing in mach3 when you start the Gcode when i was post processing in Fusion but they do when post processing from Sheetcam. I wonder if that’s fixed when using the No Z post also.

I believe it will and I just ran my line test file and did a post of James and then put his mod into the no z post and there was a noticeable difference and with my new screen with the firing timer you can see the difference and if you watch the display part of the screen then you will notice the arrow in the right actually moving down and this is happening after the torch fires. I like what James has done because it has made my life easier, for now I will use his mod in the no Z and later when I have the Z axis then I will use the one of his that I found.

The first screenshot is James original post mod and it takes 36 seconds with a total firing time of 26 seconds
The second sxreenshot is James mod put into the no Z post and it runs 29 seconds with a total firing time of 29 seconds.

Thank you James for this mod, he still gets all of the credit.

cool, i will have to try it out tonite.

I’m interested in what your cutting action settings look like - and how you defined your torch. I may have different settings that make the Z not execute even with the Z compatible post.

Yes sir, just let me know what you want to look at and I’ll get it for you. I already left the shop for tonight but I’ll be back tomorrow. I can upload my whole Mach3 file to dropbox if you want to look at that?
Just let me know, I’m just glad that you made the mod, without that I would still be doing it the hard way.

Are you talking about the timer that I have on my screen?

Thank you