Problem with THC not workin (SOLVED -broken wire)

Hi just tried to run my first part. Did a simple flange to get things working. There seems to be a problem with THC. When the torch fires it goes straight down to metal and burns a hole but does not move. If I do a dry run the torch moves around the design. Also the torch will not shut of from fire control most times I have to turn the cutter off. I have a new Everlast 62i wired to raw voltage and plugged into crossfire control box from PV port on the VM.
Any Idea’s on how to fix it?

Try to cut with THC turned off. You can turn it off @ FireControl. If it runs then you need to run the THC troubleshooting. I will edit this comment and add link.

From FireControl can you test fire the torch and turn it off?


Thanks. I have been working through some of that. So far every thing checks out but haven’t been through it all yet. Can fire torch manually.

1 Like

Possibly emi. Are you running off a laptop or a pc? Plugged in or running on battery? What version of fire control are you running. Will it run the program in dry run? Do you have any coiled up cables? Running a hand torch or machine torch? How is it mounted. Where is the cutter in relation to the control box? Have you checked the usb for continuity to the frame?

Have you tried running with The THC disabled?

Running PC plugged in. Latest ver FC. Machine torch mounted with langmuir machine torch mount. No usb continuity control box mounted when its supposed to be. There has to be a glitch some where I just have to find it. Tomorrow is another day have watched a few of D & N Custom Creations video’s very informative and will try some of his tactics.
Thanks you all

PC or laptop? I guess you already answered that it is not a laptop. If laptop, run on battery or use ground isolating plug (the one that covers a 3 prong plug to a 2 prong). May not be your issue but has sunk many ships in the past.

At this point, it might be fruitful to list your computer, operating system, plasma cutter and photos of the setup showing cables to/from enclosure/computer/plasma cutter. And the results from the THC trouble shooting.

1 Like

I have been doing electrical for 40 years. All wiring properly grounded straight to isolated ground dedicated circuit.

Just trying to help clarify. Sometimes EMI can easily corrupt the computer signal especially with the plasma energy.

It could be something with the THC module or a connection. You might remove the module and reinstall. How did the trouble shooting pan out?

The other issue is with the rabbit hole of chasing versions of windows not playing well with versions of FireControl. On the Langmuir download page, there is another download for the Fire Control connection. I will edit this with a link. Sometimes it is necessary to push this Driver.


Just to clarify the circuit your control box is connected to has its own ground rod separate from the circuit your computer is connected to?

1 Like

Are you running the raw voltage from the cpc port or are you connect raw from inside the everlast at the terminals?

Did Firecontrol throw a error pop up ?

If so what was the message?

Wow, that’s a long time.
What kind of electrician are you?

With all the cabling in place I normally make the test between the shield of the USB connector at the computer with the wire plugged in and one of the y rails when I’m checking for continuity. My touch screen was mounted in such a way once that when it was plugged in I would end up with continuity between the USB shield and the langmuirs table frame.


As usual @TinWhisperer is right on with his comments and questions.
I own a Pro table with the 62i Everlast also…so
take a picture of the front of your plasma with it turned on…let us see the settings there…

I also agree with Tin on the RAW voltage…I have found that the divided or raw pins on the back connection of everlasts work about 50% of the time with Langmuir systems…if you search the forum for everlast 62i there is a bunch of pictures of where best to connect for raw voltage if you have not done so already.


Hi Every one
Ran through all your suggestion and trouble shooting. The problem with the THC if I turn it off every thing works fine. Have updated driver and software. Worked through the trouble shooting guide every thing is good. When I turn it on I get pierce delay is too short or too long. When I change it up or down always get one of those error message. So for now I will run with off till I find a solution.
Thanks for all your suggestions and help


You have done an incredible amount of work on this. If you haven’t already done it, start a ticket with Langmuir. Sorry this is happening but when you get past this, you will feel like a winner. Don’t lose heart.

Are you using the USB cord that came with the enclosure? The reason I ask is you might try a different one. If you order a new one, make sure it has the ferrite coils on both ends. There is concern if you use a longer one (but I don’t want to complicate the issue with different cables.)

Others with more experience will give advice now that you have more information to share (@TinWhisperer @ds690 @72Pony)

1 Like

Thank you
Yep have been on this for days. I did open a ticket with Langmuir support. Lets see what they say. I think its some thing in one of the control boards. I may uninstall Fire Control and wipe from computer. No not using USB cable got a new one like you suggested, one of the first things I did.

1 Like

You might try their cable just to see if that works. The only thing wrong with their cable is the length.

1 Like

Explain your isolated ground system.
Has your table passed the ohm test?
Is your computer and your control box hooked up to the same ground system?
You my have created a ground loop.
Try using a non grounding plug adapter on your control box. Have also seen a monitor being plugged into the ground system create a ground loop.


so things also to look for when you have “cooled down”…lol…is put a ferrite choke on the USB cable…make sure usb cable is not near any coiled lines…
also have to tried running the syatem with the computer with an isolated ground…


Thanks every one for your suggestions. Honestly I have exhausted all the tests and trouble shooting that has been told to me as well as tech support. My feelings are it’s a bad board on the THC. My shop has all the lighting and plugs run through the grounding system on our main panel as required by the electric code. Then I have 125 feet of 1/2" conductor buried in the bottom the the foundation of the shop. This ground is not connected to the other ground and that is what my machines are connected to. I have tried the USB cable that comes with the unit I have purchased 2 longer cables shielded with ferrite coils on both ends. I am waiting to hear from Langmuir support about what they think. This has been a bad lesson in plasma cutting. There is not much more that I am capable of doing. I am starting to wonder if it’s really worth having crossfire table or not. I guess you have to go to electrical engineering school to figure out how trouble shoot and fix their systems. After reading many posts seems like there are a lot of problems.

1 Like

You might be right.

One of the problems that happen here (perhaps in other forums as well) is that many people ask for help and whether that help resolves it or not, they disappear. Those of us that tried to help are left not knowing the outcome. Even when asked, many fail to respond. Several months later, they reappear with another question so they obviously got their problem resolved: We just don’t get it SOLVED on the thread. It is frustrating for people looking for solutions and for those who tried to help.

It sounds like your grounding system is set up very similar to how I have heard it explained by others so you are right: That may not be the issue.

I was happy that you responded today. I thought you might vanish. Keep in mind, we are all just trying to help and none of us are reimbursed except the Langmuir crew. We are all learning and sharing along with you. I hope that you report with how your situation resolves. That helps everyone. Trust me: once you are past this, you will be glad you stuck with it.