Been running good. Now I'm having issues

Ive been running my Pro table with no issues lately and cutting good. Today I started cutting and on some of the pierces the torch would go down real slow for IHS. It wouldnt do it on every pierce but id say about 10% of them. Then I ran my next program and lost arc. It came up to report the error. I clicked that and the whole program froze and would not let me “Run from here”.

Just restarted and ran again. It cut the whole program this time but put a random pierce in one of my pieces. WTH!

The second problem sounds like a USB/interference issue.

There could be an error in the generated gcode for the IHS issues, if you turn off the torch and disable THC, does the program run ‘normally’, or do you get the same IHS issues? Make sure to have a sheet on the table. If you get the same IHS issues in the exact same places, that would point to gcode. If you still get random slow IHS sounds like you may have a ground issue causing interference, that is unrelated to the plasma. Check for a ground loop between the table and the USB connection as shown here:
Any changes to wiring/laptop position?

Ive gone through all of this in the past weeks. Everything was fine until today. Nothing has changed

Are you 100% sure that pierce point isn’t in the gcode?

By chance did your other problems (in first post) occur after running the table for extended period of time, may jobs over many hours? If yes I could see it being a software issue, which is why rebooting helped. The random pierce I can’t explain.

Slow IHS issue definitely sounds like the following:

The torch touches down on the plate as normal, just goes down slow. I have done 2 cut files since and it has not done it. I just thought it was odd it did it. It worked fine just slow on some IHS readings.

Watch the first pierce in this video

The IHS issue was my first cut of the day. The other issues were the 2nd and 3rd. Program was only on for a few minutes

Your video looks like the description 2 from the link provided @langmuirsystems:

Randomly, the torch will drive down for IHS at an extremely slow rate. It touches down on the plate as normal but takes much more time to get there.

By chance were the cuts that this happened near an extreme end of travel? Or an area of the table you haven’t used much? That would point to the slack in the torch/motor cables. Although they look OK in the video. Otherwise you might want to look at the preload adjustments given in that link.

You can see the slack in the video. That’s not an issue. I’ll recheck the eccentric nuts tomorrow but I just adjusted those a couple weeks back due to excessive slack. My biggest issue is it was working good then the slow IHS, then the Torch losing arc and crashing the program, then a random pierce in my piece. Seems too coincidental.

The random pierce is really strange. 100% sure it doesn’t show up in the gcode?

Nothing in code. It was layed out in sheetcam and only happened on one piece not all 4

Anything in the log? cut n paste this into a File explorer:

then open firecontrol.log

Although mine has failed to capture any reported errors. Maybe you’ll get lucky.

The lock up and random pierce could be a software problem or an interference problem. I would lean to software bug because I would expect it to be more consistent with torch firing if it were interference. But that’s just a guess. When it did the random pierce did you see it? Did it go through the whole process of IHS before firing?

Anyway I would open up a support ticket and send them your gcode. There maybe something that triggers it.

1 Like

recorded something

2020-05-19 18:19:51:266 ERROR MailSender:291 - Failed to send email:
fromRecipient=Recipient{name=‘FireControl Reports’, address=‘’, type=null},

On May 19, 2020 at 6:19 PM ( Eastern Standard Time ), user joanna sent the following crash report:

System Information

Operating System Microsoft Windows 10 (Home) build 18363
Processor Intel® Core™ i5-7200U CPU @ 2.50GHz
1 physical CPU package(s)
2 physical CPU core(s)
4 logical CPU(s)
Identifier: Intel64 Family 6 Model 142 Stepping 9
ProcessorID: BFEBFBFF000806E9
Architecture 64-bit
Memory (available) 6.2 GiB
Memory (total) 11.9 GiB
Disk C:</td>
Available space 64.2 GiB
Total space 230.0 GiB
Java version 13.0.1-BellSoft+9
Java vendor BellSoft

Stack Trace

org.awaitility.core.ConditionTimeoutException: Condition with lambda expression in com.langmuir.cnc.desktop.viewmodel.firecontrol.ArcVoltageLostViewModel that uses com.langmuir.cnc.core.pojos.MachineStatus was not fulfilled within 10 seconds.
at org.awaitility.core.ConditionAwaiter.await(
at org.awaitility.core.CallableCondition.await(
at org.awaitility.core.CallableCondition.await(
at org.awaitility.core.ConditionFactory.until(
at org.awaitility.core.ConditionFactory.until(
at com.langmuir.cnc.desktop.viewmodel.firecontrol.ArcVoltageLostViewModel.runFromHere(
at com.langmuir.cnc.desktop.view.firecontrol.ArcVoltageLostView.showAlert(
at com.langmuir.cnc.desktop.view.firecontrol.ArcVoltageLostView.lambda$initialize$0(
at javafx.base/com.sun.javafx.binding.ExpressionHelper$SingleChange.fireValueChangedEvent(Unknown Source)
at javafx.base/com.sun.javafx.binding.ExpressionHelper.fireValueChangedEvent(Unknown Source)
at javafx.base/ Source)
at javafx.base/ Source)
at javafx.base/ Source)
at com.langmuir.cnc.desktop.viewmodel.firecontrol.ArcVoltageLostViewModel.lambda$configureObserver$0(
at de.saxsys.mvvmfx.utils.notifications.DefaultNotificationCenter.publish(
at de.saxsys.mvvmfx.utils.notifications.DefaultNotificationCenter.publish(
at com.langmuir.cnc.desktop.viewmodel.common.ProgramViewModel.lambda$executeActionsForProgramPaused$9(
at$runLater$10(Unknown Source)
at java.base/ Source)
at$runLater$11(Unknown Source)
at$ Source)
at Method)
at$runLoop$3(Unknown Source)
at java.base/ Source)
subject=‘joanna’s crash report’,
recipients=[Recipient{name=‘null’, address=‘’, type=To}]

I had the slow lowering issue last weekend after no problems for many weeks. I didn’t see how to easily adjust the friction so I decided to add a drop of oil to the 2 sides and lead screw and have had zero problems since.

1 Like

I have no tension issues. Everything is well lubricated and adjusted. It seems more software to me than hardware

I can’t say what the weird extra pierce thing is for or why FireControl randomly froze when commanded to run from here (@langmuirsystems will look into it). But the only thing I’ve ever seen cause the slow IHS move is if the lower eccentric bearing is too tight. I’d loosen the lower eccentric slightly and see if the issue persists.


I will try this today and double check to see how tight it is

Sounds good- we had a meeting today about this topic and we’re looking into adding some debounce in software to better alleviate this issue. That will take a few weeks to develop but we’re on it.