2 weeks, Razorweld cut45 Tech dept tested plasma, still won't fire torch on table, user error at it's finest (SOLVED)

Link to the previous thread that was in the introductions section.

Took delivery of my new Pro w/Cut45 today in Central Oregon

I thought I had this problem figured. I drove my brand new Razorweld Cut45 to Jasic’s warranty repair tech and spoke with him about the problem i was having. He told me it needed a motherboard and he usually has some in stock but was out, however he had 5 on order that would be here in 3-4 days. Cool, left the machine with him, drove home. Today, 5 days later he calls and tells me I can come pick up the plasma and that there is nothing wrong with it.

He installed his hand test torch and it fired right off, he put my machine torch lead back on it and used it to cut a piece of 1/2" plate without a hitch. He also said there was a small air leak inside that he fixed and that the air pressure setting on the machines internal regulator was set to low, he adjusted it up 12-15 psi to have 75-80 psi cut air with the torch cutting. I laughed because I knew exactly what was fixing to happen. I drove back to pick up the plasma and talked with him again, a nice older fellow I didn’t want to ruffle up but I explained again it would not fire with me jumping the connection on the front of the plasma, multiple times. He offered to unbox the machine and go show me, I said it wasn’t necessary if he was that confident. We went over the wiring to the control box and what i had connected where and that the front connections on the plasma were wired correctly. This is the way. So, off I went. Back at the shop, 220V measured at the receptacle, 90 psi air pressure at the rear plasma, shows 90 psi on the front gauge, pull the wiring apart to be positive the correct wires are connected to the right ports in the front of the plasma. Inner port closest to the torch lead connected to on/off port in control box, outside port 50:1 wire connected to DIV input, DIV output connected to THC on control box, ground to work piece, did not touch the torch head and installed it as lightly as i could on the Z axis only clamping on the metal part of the handle, run Z axis and torch down to touch the table then off table 1/8" using the jog, THC shows green and connected, IHC is setup, home the table, run out to work piece, zero axis, torch still 1/8" off work piece, enable manual torch fire and click fire torch, I hear the relay click, air starts coming out the torch tip and drum roll please…the torch doesn’t fire, again, for the 100th time. Run the torch closer and higher, no fire.

Next step, open the THC troubleshooting guide, step 1 connected with Langmuir cable, yes, step 2 Have you verifed that your
plasma cuter is wired up
correctly for THC by performing
the test checks outlined in the

Scroll down to voltage check guide at bottom of page.

The very first thing it says is:
1.) Verify that your plasma cutter’s 50:1 voltage divider port is functioning properly while cutting.
If your plasma cutter is equipped with a 50:1 voltage divider in the CNC port (called a CPC port on
Hypertherm), we will use your Digital Multimeter (DMM) to measure the DC Voltage across the two pins of this port WHILE THE PLASMA IS CUTTING.


Some more history if you don’t want to read the post linked at the begging.

I have a Hypertherm Powermax 30 that i wired into the control box on/off port that works fine with the table. I downloaded 4 or 5 programs from Fireshare and cut them with the Hypertherm connected to the table. IHC worked, I did not have THC enabled to do this.

Tuesday will be 2 weeks trying to get this #$%^ machine to fire. The excitement has ran dry. Langmuir support says it’s the torch, the torch warranty guy says Langmuir always blames the torch and most the time the problem is in their wiring connectors. He also expressed to me that they have a new digital cut45 plasma that Arclight Dynamics is now using in place of the Hypertherm on their units. He also let me know that Arclight is going to be releasing a new plasma table with the digital Cut45 plasma to directly compete against the Langmuir Crossfire Pro in the next month give or take.


Jumping the leads in the front of the plasma won’t fire the torch, I don’t have a hand torch for it to try and see if that works, Hypertherm hooks up and works still. I don’t know what else to do but take it apart and return it then buy an Arclight.

You guys are my customer support i guess so anyone have any ideas what to do now?

So how did he fire the machine torch you had to cut the 1/2 metal?

Have you tried to fire machine torch without mounting it in machine torch holder, just hang onto the torch body by hand pointing away from you and fire it? You might be overnighting clamps on torch when mounting to holder. Why only 90 psi air supply to machine ,110-120 air supply to the machine is usually the recommendations on plasma machines?

1 Like

So the Hypertherm powermax works with the table.

And the Razorweld does not work with the table.

It this your scenario ?

Being the table is functioning and firing the table in one of the scenario makes me think the Langmuir is able to make a torch fire on the table.

1 Like

The Langmuir electronic pulls in the relay, pulling in the trigger and the plasma is obviously seeing the contact close and starting its firing sequence but then fails(air on). Does sound like the Langmuir did its part in the sequence of operations .

the torch crush enough to not let the plugger move sounds like a good place to look.


1 Like

“Read this before mounting torch”


He had a toggle switch wired into the front of the plasma.

Yes, multiple times.

I’m not overtightening the torch. If i mount it any looser it’ll fall thru the holder.

My Hpertherm has worked flawlessly for 10 years on 90 psi. The Tech for Razorweld told me it is supposed to be set at 75 psi so I’m putting in more than needed. 90 psi is the air pressure standard for almost all machines.

Yes, but THC isn’t functional when the Hypertherm is connected.

This is why I repeatedly asked the tech if he was sure he tested the right machine and told him my Hypertherm worked on it and I couldn’t make the Razorweld fire with jumping the connector in the front of it. He repeated that he fired it with a hand torch and my machine torch.

1 Like

Make sure the plunger inside the torch head is not jammed. Take off the cap and you should be able to push up on the electrode and have it snap back. If the plunger is stuck it will never fire.

1 Like

It won’t hurt to run the air pressure up and see how it does. Every brand machine is different

1 Like

Well, i feel like an idiot. It’s always the little stupid stuff that gets you. With 120 psi going into the plasma the gauge was showing 80 psi on the front of the machine. The one thing i didn’t do was look at the gauge when the torch was turned on. There’s a problem with my new 5 micron water separator. It is rated at 120 psi pressure. There wasn’t a cfm rating on the box when i bought it, as you have probably guessed by now the flow rate thru the filter is cut in half and if i would have been paying attention sooner i would have noticed the pressure on the plasma gauge drops from 80 psi to 40 psi when triggered on.


Drum roll…for user error. I knew it would be something stupid. Turns out the idiot is behind the keyboard.

I was sitting here eliminating things one at a time that were different between the Hypertherm and Razorweld when attached to the table. the only difference was I had the Hypertherm hooked to another shop air line.

I’m here all day if someone needs advise on how to introduce yourself to the community in epic fashion. Pardon me while i go pull my head out of my @$$.


Glad you got it worked out. There are a lot of variables in this process. Anyway welcome to the hood…


Ended up finding a 1" long piece of Teflon tape in the airline stuck inside the air fitting on the back of the plasma.


That would do it… Glad you got this ironed out. Happy cutting. Post some pictures of your projects.


Great news now you can make sparks fly… we are always learning new things. It’s when we stop learning we are in trouble.


Now I am glad you found it , But I gave you the answer on the other thread on post 50 and again on post 66 but you never checked the air flow or you would have seen it then.

1 Like

I misinterpreted your posts as what the pressure needed at the machine was. “air coming out the torch” went right through my head and didn’t jog the idea to be looking at the gauge while it was triggered. Just to verify the pressure was present when connected. I was pretty irritated at the time.

1 Like

Yea, some time we don’t stop and think about what we are reading.


Glad you got it resolved! Thanks for having the courage to post what the problem was! And don’t feel bad we have all done something similar at some time or other. It’s not the mistakes you make… there will be many… it’s how you react that will determine how successful you will be.

Again congrats on getting through it and looking forward to what you will create!