Troubleshooting: Loss of motion when torch fires

The purpose of this unlisted thread is to discuss and identify a solution for the following issue:
-After mach 3 fires the torch, USB communication is interrupted and the machine freezes. Typically an error is populated in Mach 3 and the reset button has to be pressed in order to regain jogging ability after the torch is turned off

So far, there are 4 customers** that we know of that are experiencing this issue. Their usernames and the plasma cutter being used are:
@Freetocut - Thermal Dynamics 60i
@motoracer450 - Lotos Supreme Cut60D
@Austin34471 -Harbor Freight 40A
@jerrittcat - Lotos Supreme Cut60D

**If others experience this issue, I will add there usernames to the list so that they can view this thread.

Below is a list of our initial comments/thoughts/observations:

  • There are over 200 CrossFires delivered to customers now. There are customers that are running each of the plasma cutters listed above without any problems.

  • We have run a variety of different plasma cutters in our factory (Hypertherm Powermax 1000, both Razorwelds, Longevity, Everlast) and have not seen this issue. Since learning of the issue, we have been unsuccessful in replicating it in our factory so far. However, we have not tested any of the plasma cutters listed above.

  • Every electronics box is tested in our factory to make sure each one properly spins motors and can fire a torch (our test fixture uses a lightbulb to simulate torch firing).

We currently have a few theories for what could be causing the problem, but we are asking for your help in order to nail down root cause. When you have time, please answer the following questions:

  1. What computer are you using. Is it a desktop or laptop? If using a laptop, do you have it plugged into a wall outlet when cutting?
  2. Do you have any extra programs running when attempting to cut? Are there any programs that are unknowingly running in the background?
  3. Where are you clamping your plasma cutters work cable? To the material, a slat, water table drain plug, etc?
  4. Where is your plasma cutter located relative to the machine? How close is it to the electronics box? How close is it to your laptop/desktop?
  5. Do you have your laptop/desktop on a laptop stand or on a desk nearby. Are you using the supplied USB cable?
  6. Is the torch cable/hose secured to the cable support tube with the velcro straps?

When you have a chance, please perform the following tests:

  1. With the plasma cutter turned off, verify that it can successful complete a dry run of a cutting program. Make sure your cutting program has at least one instance of the torch being commanded to turn on and then off.
  2. Turn on your plasma cutter but disconnect the work cable. Raise the torch so its sitting an inch or so off the slat bed. Connect the torch fire cable and fire the torch with mach 3. Keep the torch on for 1/2 second and then turn it off with mach 3. Did you get any errors in mach 3?
  3. Load the program that was used in step 1 above. With no material loaded on the machine and with the work clamp not connected, press cycle start. The pilot arc should fire and then the machine should start moving. After the machine begins moving, hit the torch off button. Did you get any errors in mach 3?
  4. Load a piece of material onto the slat bed for cutting and attach the work cable. Disconnect the torch fire cable. Press cycle start and when the torch jogs to the pierce point, manually squeeze the trigger to fire the torch. Your torch should start cutting.Did your machine freeze as soon as the torch began cutting?

I think once we have feedback on the answers to the questions and the results from these tests, we will have root cause nailed down and can begin working on the solution.

Thanks for your help!

Langmuir Support:

1 Like

Q1. I am using an HP Pavilion dv6 laptop plugged into an wall outlet
Q2. Only programs running are Mach 3 and Google Chrome
Q3. Plasma cutter work cable clamped to metal slat on Crossfire
Q4. Plasma cutter is approx. 18 inched from machine electronics box. Laptop approx. 24 inches from electronics box
Q5. Laptop is located nearby in a chair connected to the supplied USB cable
Q6. Yes the torch cable is secured to the support tube using the velcro straps

@Freetocut got back with us today and his setup is now working properly. We believe his issue was something involving mach 3 specifically and not the same issue that the remaining three people are encountering.

Austin reached out to us separately and told us that test point #3 was successfully executed (meaning that the machine would not freeze when only the pilot arc was initiated in the plasma cutter). However, test point #4 failed. When the trigger was pulled, the machine motion froze.

Ultimately this means that electrical noise/RF interference is playing a role. More research needs to be done before we can start working a solution. But knowing the cause is half the battle.

Also, @jerrittcat reached a solution with his set up. See this thread for more information: Cutter stops and starts travel when cutting only

I ran the 4 test that you asked. Here are the test results:
Test 1 - Successful
Test 2 - No errors in Marh 3
Test 3 - No errors in Marh 3
Test 4 - Fail. The machine froze as soon as the torch was lit. Once the torch trigger was released the machine continued to move. I pressed the trigger a second time and the machine froze again. I ran this test twice and got the same result - machine freezes when torch is lit.

I spoke with Austin on the phone last night; he ran through the tests and arrived at the same conclusions. It’s clear now that there are some RF/electrical interference issues going on. These types of issues can be pretty challenging to track down. We don’t think its an issue with the electronics box, and we are pretty confident that if we sent a new one, that the same phenomenon would occur. Although we can do that to rule things out. Have you checked to make your 220V source has a good ground?

My advice would be to try the tests again, but with the following changes:

  1. Move your plasma cutter as far away from the laptop and the electronics box as possible.
  2. Make sure that your torch cable is not coiled up on the ground. Keep the excess cable as far from the electronics/laptop as possible.
  3. Clamp the work cable directly to the material. Also make sure that the work cable is not coiled.

If none of these changes work, then i believe the only solution is going to be to ground your machine. This typically involves installing a grounding rod directly under where you plan to run your machine, and then attaching a exposed braided wire ground strap between it and the frame of the CrossFire. The other option would be to go with a different plasma cutter (an unfortunate solution).


I’m providing another update on this issue and also making this thread public for others in the community to see.

@Austin34471 now has his machine running. After trying a lot of different things, he removed the cover from his harbor freight plasma cutter and found that one of the ground connections was faulty. After fixing the connection, his CrossFire now cuts without issue.

I spoke with @motoracer450 and his machine is also up and running with his Lotos Sumpreme Cut 60D. The only way that he was able to solve the issue was by installing a temporary grounding rod (2’ long steel stake) outside of his shop and running a ground cable to it from his CrossFire. He has plans to install a permanent 8’ copper rod in the near future.

1 Like

I am having the same issues with an APH Alpha Cut 60.
1 - it is an hp elitebook laptop and yes plugged in to a grounded wall outlet
2 - no programs running
3- I have tried clamping to, the drain plug, work piece, water tray, metal slat.
4 - the plasma cutter is 4 feet from the control box and 8 ft from the laptop
5 - yes laptop is on a metal desk or my lap, yes using the supplied cables
6 - yes it is secure.

I performed the above test:
1 - Passed
2 - passed
3 - Passed
4 - failed.
It appears that the pilot arc is not the problem. I have troubleshooted the following possible solutions with no success.
1 - plugged laptop into grounded outlet
2 - made sure the APH plasma cutter 220v outlet was correctly grounded.
3 - Opened the case on the APH plasma cutter to look for loose grounding wires, found none.
4 - Ran a grounding wire from the Crossfire frame to my Home grounding bar in the breaker box.
4 - Removed the control box off the Crossfire frame and ran it isolated from the frame
5 - moved the plasma cutter and laptop physically as far from each other as possible. a span of approx 8 ft
6 - drove a 2ft steel rod into the ground outside the house into wet soil (it was raining), grounded the cross fire frame, then the control box, then the APH plasma cutter frame.
All of the above attempts yielded no improvements. I am running the program now and hand firing the torch and every time it looses connection.

After you drove in the 2ft grounding rod, did you still have it grounded to the house ground?

I’m going to add to this

do NOT use an extension cord for your plasma cutter when running on 110v. They do not like it. You may be able to get away with a 8/3 or 10/3 220v extension cord on a dual voltage plasma, but running 110v input and extension cord = voltage drop. Plasma may fire once and quit or not at all.

1 Like

I will add to this also. I had some problems before that I thought were corrected and they came back. My fix seems to be running the laptop on battery only while cutting. I haven’t figured out exactly why, I’m still looking into it. If the laptop is plugged in to the power outlet while the torch is firing, all motion stops and the torch just keeps firing till I unplug the cable. If I run the laptop on battery only, it all works perfectly.

1 Like

Hi @Worksbyahurst,

Following up from our phone conversation, I wanted to recommend a few more test points to try:

  1. Turn the CrossFire electronics off but keep the USB cable attached. Run a program so the there is movement in the graphic window. With it running, manually squeeze the torch trigger. Does Mach 3 freeze? Do you get any errors?
  2. Do the same thing as step 1 but disconnect the USB cable and also remover the CrossFire motion control plugin beforehand. Doing so should allow you to run a program in Mach 3 without the USB cable hooked up.
  3. Put the motion control plugin back in the correct folder and reconnect the USB cable. Turn the CrossFire electronics on. Remove the torch from the torch mount and set up a test piece to cut by hand off of but in close proximity to the machine. Before cutting by handing, make sure to have fhe machine running through a program. When the torch fires do you lose motion?
  4. If step 3 is succesful. Try handcutting a piece of material on the machine. If step 3 was unsiccesful, how far away must you be cutting for the machine to run through the program without issue.

Bonus Steps:

  1. Do you have a different USB cable you can try? Preferably a shielded type with ferrite chokes which can be helpful to prevent EMI.
  2. Do you have a different laptop you can test?

Sounds like interference. Do you have a choke on the power cord? (It’s a small round black block/cylinder that surrounds the cord near one end.)

1 Like

We have been working with @worksbyahurst quite a bit over the phone and he was able to get it running by doing the following:

  1. Plasma cutter power supply moved approximately 13 feet from the machine. Laptop approximately 16 feet from the plasma cutter.
  2. One end of a copper wire attached to a 4’ deep grounding rod; other end secured to one of the machine’s frame bolts.

From this result I believe we can conclude that the plasma cutter power supply is the source of the RF noise that is interfering with the laptop. We initially believed the source was the plasma arc itself, but we no longer hold this belief.

I have a phone call set up for tomorrow morning with @Worksbyahurst to discuss the option of supplying him with a loaner plasma cuter (45A Razorweld) so that we can get our hands on his AHP 60A unit. We are hoping that some strategic grounding of the plasma power supply can be implemented so that it doesn’t need to be so far away from the machine in order to cut properly.

1 Like

from reading all of the things that are fixing the rf noise issues. it seems like the shop/house wiring needs to be upgraded or replaced. maybe this is due to bad connections to ground in the fuse panel?

They advertise that ahp as a blow back start but I think it’s more HF start with a blow back torch. All Plamsa out of the factory that makes the ahp is HF that I have seen.

I agree. I was telling Jason that my friends ahp cutter will turn off the shop TV or change channels while its cutting. Only if he is nearby though.
While earth ground integrity is absolutely important it is not a fix for broadcasted rf.

Yesterday we had @Worksbyahurst (Jason) connect a wire straight from the ground lug inside of his plasma cutter to his dedicated grounding rod. Unfortunately it did not appear to help.

We thankfully struck a deal with Jason to get his AHP unit in our shop so that we can better troubleshoot things. Once we have it here, we will definetly keep the community updated on our findings.


Maybe needs a faraday cage. Loose scr connections or even dry loose connections on power transformers inside a device can cause noise. Lots to look at.