Troubleshooting: Loss of motion when torch fires

Another customer encountered this issue and found that the extension cord he was using to supply power to the CrossFire electronics had a bad ground connection. He fixed it and the problem went away.

1 Like

I’ll say this again so everyone can see

Do NOT use an extension cord. Especially on a 110v plasma. You WILL have issues.

1 Like

mine is doing the same thing, Torch has to be about 7 feet away from the table in order for program to keep running. if ground clamp is attached to the slate table then it does not matter how far away i am. program stops. Also removed the control box off of the table. same issue.

Which plasma cutter are you using?

lotos LTP5000D plasma cutter

Unfortunately the Lotos LTP500D uses high frequency start and is not an approved plasma cutter (see here:

There is a difference between RF ground and a electrical ground. If all fails, try using the laptop on battery and placing it in a faraday cage (old microwave oven) and see if that does not fix the problem.

You can also use ferrite chokes especially on the USB cable as a lot of laptops USB connectors are not “grounded”. There is a wikipedia article here:
And you can buy ferrite chokes at Amazon among other places.

1 Like

Same issue here. Runnning it with a lotos cut60d, microsoft surface running on battery.
I also made sure the extension cord to the crossfire system ground was functioning correct. Everything else works great until the torch is fired, then mach3 locks up and windows pops up an error for unrecognized usb device.

Also tried with manually firing the torch and it will stop everytime the torch is fired, then when arc stops it will continue

Cut parts! So after checking everything, trying a different laptop (also running off battery) I moved the laptop off the surface of the steel welding table to an amazon box giving it approx 8-10 inches of clearance. When i did this i also had to reroute the torch firing wire, but it performed great on both laptops once this was complete.

1 Like

Something worth knowing about the Surface Pro 3: It does’t have a ground wire. The power adapter is a 2 prong power. They use a very large resister to simulate a ground / create a reference point for 0V. So, yeah I can see that it would be a bad idea to have the computer on the welding table itself. I was going to be using a Surface Pro 3 to control my table, but I may rethink that, or if nothing else I’ll do something to isolate it better. I do have a docking station that I was going to put it on.

1 Like

I was planning on using a thick rubber pad for it to rest on. not sure if that will help at all.


Worth a try. Interesting idea.

Add me to the list. Cutmaster 38 manually moves without torch fired… while firing it freezes several times during the cut and I have to click in the jog window several times to get it to move forward. I don’t have time to test so I will try moving the plasma away from everything.

me as well
Thermal Dynamic cutmaster 38

freezes once torch fires and
torch stays on until USB is unplugged from pc

i tried to start program further away from plasma and haven’t had same problem

i was able to restart with laptop in my hands and it worked
but its completly random when its stop

Been a while since we have seen someone have this issue. Generally these are the steps that you’ll want to take:

  1. Make sure that the 240V supply has a good ground. Check all of the ground connections inside of your plasma cutter. 75% percent of people that had this issue found loose ground connections inside their plasma cutter power supply, or inside the 240V outlet.

  2. Keep the laptop as far from the plasma cutter as possible.

  3. Attach the work clamp directly to the workpiece.

  4. If none of the above works, consider using a shielded USB cable. If that doesn’t work, then a grounding rod may be necessary.

Theres probably around 150 CrossFires running the cutmaster 38, so having this happen to two customers at the same time is definetely concerning. Would you guys mind posting pictures of your plasma cutters.

will do

im pretty sure it was my fault by setting the pc on the cutter

ill post up pic on my lunch brake

I am using a Lotos LTP 6000 which is High Frequency start, and had major issues at first - motion worked until torch fired. Sometimes motion would stop and Mach3 would freeze up right when the torch starts, sometimes after a few seconds.

Now I have the machine working great. I added braided shielding around the entire torch cable, both stepper cables, and the plasma trigger cable. Then I hammered a 8’ 5/8" copper grounding rod into the ground ($13 from HD), and ran a 10’ thick cable from the rod to the table. Luckily it had just rained so the rod went right in with a bit of elbow grease. My guess is that the shielding on the steppers and trigger cable were not needed. The grounding rod and the shielding on the torch cable would have probably done the trick.

Here are links to some great info I found, credit to Jim Colt at Hypertherm, everywhere I found solid info that guys name was posted right next to it:

Explanation of HF start (post #5):

Tips to ground/shield a HF plasma for a CNC (post #5):
More tips (post 20):

Good luck!

  • Casey

I thought Langmuir said high frequency start machines could damage the Crossfire control box.