Razorweld x45 torch wont fire overnight (Solved)

I have read through other torch fire issue threads and have not found a cure. I got ahold of the xr machine in October and have had good luck and no issues so far. Yesterday table was cutting fine. This morning I can’t get the machine torch to fire. Have gone through all connection points, reset machine multiple times, new consumables, updated the THC and firmware for fire control, nothing. Anyone else have an idea? yes, ground and air are connected…

Welcome to the forum, many great people on board that are willing to assist, and surely others will chime in.
I do not have an XR and you did not state which plasma cutter you’re using, but my immediate thoughts, since you’ve said that you verified all connection points and this suddenly occurred from a previously fine machine:

  1. Torch fire relay in control box or plasma cutter loose, can you hear them click??
  2. Torch fire relay in control box or plasma cutter defective, can you hear them click?
  3. Any way to try and fire the torch manually to verify?

Razorweld cut x45 is the plasma cutter with machine torch. In firecontrol you can manually fire the torch yes, there is no click when prompted to fire.

Ah ha, check for a loose relay in the control box or maybe the relay is defective. I’m not sure how the XR control box is setup. Maybe @langmuir-daniel or some other wizard can shed more light.

1 Like

Appreciate it, real weird because nothing out of the ordinary has happened. Shut program down, fired back up this morning and nothing. Tried different cut files also to ensure my file wasn’t flawed…

Where would that relay be located on the xr machines?

On the circuit board inside here, I would imagine.
If you do open it up, please take a pic, I would like to see the internals.


Took cover off and did not see any sort of fuse/relay box in there. I’m stumped. Is there a way to test output on the razor weld 45 while it’s not hooked up to the table? If the torch had the manual trigger that would be simple to test, but since it’s machine torch barrel I don’t believe there’s another way to fire the torch aside from through fire control?

I believe if you jump the circuit at the trigger
Port connection on the razorweld cut45 it should fire the torch.

Someone else please second that first.

Make sure that torch area is clear before doing this.

Okay, torch fired when I jumped the plug. What does that mean now?

There is a port that the torch firing wire plugs into on the control box. Follow the wires from that port, inside the box, and it should lead you to the relay.

On the Pro, it looks like this.


The two wires marked with the red line come from the torch on off plug. The only relay looking piece I see is on this board.

This maybe the relay on the crossfire.

Does it click when you activate the torch in fire control? you can leave your plasma in the torch off while you try it.

One of this series.

1 Like

Ok thats the OG board looks like. I want to believe that relay may be shot. Is mach 3 the control software, if so it may be a configuration issue.
Software fire the torch (Mach3) and check the diagnostics screen for this yellow block to illuminat

It’s not an OG board. It’s a newer version of the Firecontrol board than @ds690 posted.

OG board doesn’t have a Nano on it… :smirk:

I’m using fusion 360, there is no click when I try and fire the torch through fire control

Ahh, triggering when plasma trigger shorted, not firing from software. Then im thinking a funky relay, on the hardware side at least.

No click means a bad or unplugged relay.

The relay on the board seems so tight I don’t want to break anything trying to pull it off. Tighter than any relay I’ve pulled before…