Miller 625 Xtreme Loss of Pilot Arc (and repair)

Having fun today cutting some metal, and getting towards end of my cuts when the torch quit firing. I’m using a machine torch XT40M with the CNC kit. Was running fine all day, but I did just try some 1/2 in plate and it was struggling thru that (mostly due to my too short pierce delay settings)…

I tried a few more cuts - nothing. Time to start troubleshooting…

First - checked work lead - made sure it had good connection.

Checked the tip, ring, electrode - made sure everything was ok. Went ahead and replaced the electrode and tip. Wont fire.

Front panel is all green - no error conditions - air is good, cup sensor is good, power is good.

Checked all wires to LS control box. Reseated CNC connection RJ45. Turned off / back on. Test fire - nothing.

I did the manual torch fire, and I can hear the relay clicking when I tell it to fire, but nothing happens on torch.

So I have a hand torch as well (XT40). Hook that up. Pull trigger - nothing. Release trigger, post flow kicks on and air comes out for a few seconds. Pull trigger again - nothing, post flow comes on when I release.

Tried this a few more times, but no errors on the front panel, and no pilot arc. Wondering that I may have done something vs it just being a random failure. It’s rated up to 5/8 plate, and I was running at 22 ipm - it was not liking the pierces, but it did work, but then decided it was done.

In any case, system is under warranty and will be going in for service tomorrow. Will try and report back what the issue is, but in meantime, if anyone has any ideas to do some more trouble shooting…all ears…


Sorry to hear about your unit getting the coronavirus :cry: but it will all be ok after the they do a transplant :partying_face::joy:

1 Like

Think it may have been a heart(capacitor)-attack!

Check fuse…
Open case and check all bolts…connections…

1 Like

May have been as you were pushing the little guy hard :rofl::rofl::rofl:

The little guy knows there’s a Hypertherm just waiting to fill his boots…probably just got scared. if he does this again, that’s it - he’s on craigslist! lol…

Thanks! - If it wasn’t under warranty, I would start probing under the covers…but want to keep the trouble shooting simple at this point. They’ll probably just give it a whole new circuit board and call it a day if they just don’t just outright replace it. About to find out (and document) how good (or bad) the warranty really is…

Dropped off at the Airgas (Miller Authorized) repair facility this am. Repair tech confirmed the issue by hooking up machine and trying to light torch. Opened a case and said hopefully ready to go by Thursday depending on parts shipping.

sorry to hear…hope it feels better soon…

1 Like

Update: replaced a board, but still not working. Apparently replacing another board. The boards are shipped 2 day air. ETA Monday (1 week)…

Wow…serious intensive care on that one…our prayers are with you…?

1 Like

Thanks, it’s been tough without the little guy, but we think he’s turned the corner.

Well, it’s Monday - machine has been at repair facility for a full week. Ready to get machine back and do some more cutting. Got a call this morning from the repair guy - they think the CNC board is at issue and needs to be replaced. I think they’ve already tried 2 boards last week - not sure which ones. Said Miller no longer sells the CNC board, and they’ll have to ‘make’ one. It will be about another week and a half to get that in. :clown_face:

Told the guy I could buy one online for $150 (oops…$350) and have it here tomorrow. Obviously don’t want to do that due to warranty covering the cost, but point was to tell Miller to hurry up. It’s looking like my turn around will be 2 1/2 weeks. Disappointed :roll_eyes: but not terribly surprised. Will update as I get more info…

1 Like

Wish you well with this. Well it sounds like the “repair guy” is just a parts replacer. Also Miller is not going to make a new CNC board. They may send it out to a repair/rebuild shop to get fixed. Also even if the CNC board was bad it would still pilot arc with the hand torch.

1 Like

Pretty much, it seems.

I was thinking the same thing after I got off the phone with them. Seems strange…perhaps they are going to have something repaired and needed the time.

I ran across this post a while back that got me thinking maybe something else is going on…

I’m 1 year into a 3 yr warranty.

When I had pilot arc issues in the past it had me stumped until I swapped out my USB printer cable then all was well and has been ever since

Do you have the CNC kit for the 625? Mine was factory installed. When you say USB cable - you’re referring to the USB cable from computer to Langmuir Controller? What kind of pilot arc issues have you had? Just trying to get some more info in the thread for future travelers…

1 Like

No I don’t have the CNC kit i spliced into mines you can see what I did here

Sometimes it would fire then stop mid cut, sometimes would fire at all, at first I though it was my crimp connections but in the end that wasnt the problem cause it still did it every so often and was frustrating me…so finally I was the printer going from the LANGMUIR controller box to my laptop with a new one and my problem was solved.

1 Like

Nice - thanks. I remember reading thru that thread when I was getting going a while back…didn’t make as much sense then as it does now…I’m going to look into that and I’m going to work on the the controller board modification for the USB interference issue with the pro controller boards…I’ve not done that yet as I didn’t think that was causing me any issues, but maybe it has been playing a role in some issues I’ve had.

I’m still stumped by the same problem with the hand torch though when it’s in stand alone mode and no CNC / langmuir hookup.

When I couldn’t get it to fire through MACH3 I could always manual pull the trigger and make it fire also, I think you stated that some where as well, whats the USB interference thing I have never opened my controller box