Everlast Raw Voltage Wiring- Still Not Working!

Hello everyone,

I have the Crossfire Pro with a Everlast 82i plasma cutter and I am having problems with the THC wiring. First of all it seems like this is nothing new, Everlast units are known to have problems with their CNC port.

First way I had it was using the CNC port. I figured I would try it this way, even though it is known issue, as I ordered my Everlast unit when it was on back order. So this machine is fresh off the boat and figured maybe this issue was fixed. Nope. I could get a torch speed reading, but THC live was reading 0v. So I went through the troubleshooting guide, did some forum reading and decided Raw voltage hookup was the only way.

Here’s what I did…

Imgur

This is the board you work with inside the Everlast unit. Connections on the right go to your CNC plug. Connections on your left are the “Raw” connections.

Step 1 is I wired the torch On/Off. This is labeled start/stop in my Everlast manual and is pins 1 and 2. I did wire these using the right side of the board connections and this is what the two wires look like…

Imgur

I put these on connectors to be able to unplug them if needed like so. This goes to the Torch On/Off connector which goes into the Langmuir electronics unit.

Imgur

Next are the Raw voltage connections. I used the required Raw voltage banana connectors and wired them into the 2 wires off of the left side of the board like so. Red banana connector is positive Raw voltage and goes to clamp which is the red wire inside the Everlast unit. Black banana connector is negative Raw voltage and goes to the torch which is the black wire inside the Everlast unit.

Imgur

.

Imgur

Now to confirm the wiring, I did a continuity test from the black banana connector (torch) to the actual torch connector on the front of the Everlast unit and results came back successful.

Imgur

I then connected the output cable to PV Output.

SO, all that being said and done, I do have torch speed and I can get an arc when running a file, but it stops after 1 inch and says lost arc. When I watch the THC live voltage I get 0 and it does not change. Can anybody see what I might have wrong?

Thanks,

-Jacob

I have the 62i and went directly to the actual power feeds to the torch to get my raw voltage.
Then I had similar problems andcrefkased my thc.
Try running without thc and see if it works. That will help everyone sort it out withyou

You may want to recheck your banana plug, I think red is neg and black is pos.

And may I ask why you took the unit apart and wired it like that when you have a plug right their to use? I just don’t get why people do this. You do know that can void your warranty.

Ok I will try it without the THC tonight. Thanks

When using the divided voltage red is negative and black is positive. With raw voltage it is opposite. You have to wire Everlast units this way as they have problems with the CNC plug from the manufacture.

Like I said check your banana cable some are wired red pos and black neg and some are red neg and black pos.

Fire the torch and see what voltage you get directly out of the banana plugs. That should be 120-150 volts. If that checks out, measure the voltage out of the THC plug that normally plugs into the Electronics box. That should be around 1.7 to 2.2 volts or thereabouts.

If that voltage looks good, then you can rule out everything that is external to the electronics box.

Are you running a laptop with that charger that uses a third prong? Or a desktop?

Ok I will try that when I get off from work tonight and see what I get. I am running it off a laptop with a 3 prong charger.

So I finally got back to it, I am only getting 1.8v when firing the torch manually and that is at the banana plugs. So that tells me I have it connected to raw voltage incorrectly?

I then tried running the same code with the THC unplugged and still received the “Lost arc…” error code.

Yes you are only seeing 1.8v, then you aren’t tied into raw voltage correctly.

Why is the cnc port board so poor?

We just bought a new 82i and are struggling bad to set it up. E04 with machine blowback torch head on…? Are we not wired right on the cnc port?

Everlast does not provide true voltage readings from the CNC port.
I have an Everlast and went right to the actual torch main connections to get actual voltages…works so much better.
search around

3 Likes

I had very similar issues with the PrimeWeld CUT60 and the THC3T. Turns out there’s 100k series resistance network within the CUT60 between the torch connector and the CNC port, and there’s also 100k series resistance network in the front-end of the THC3T divider board. Since this was additive resistance and resulting in 100:1 voltage attenuation, my solution was to eliminate one of the 100k resistance networks and decided it would be easier and safer to bypass the 100k series resistor network within the THC3T. Works a peach after that.
Not familiar with the Everlast and Crossfire Pro but I suspect it may be a similar arrangement.
Hope this helps!

thank so mutch to all of you for your help, I am a beginner an I have a new Everlast 82i , that a problem to install the LS-THC

I have the 62i with both hand torch and machine torch…you have a serious plasma machine there with the 82…

open up your Plasma case and connect the voltage leads right to the terminals for the torch and the clamp…do not trust or use the divided voltage output on the everlast…they are not accurate.

mine runs great when I did it that way

1 Like

I have two questions :
about THC:
If we use pins 5 and 7 on CNC port output pins for raw voltage witch color
wire(black or red ) to connect to each pin .

about ITC : on this same output port you connect on pins 1 and 2 a pigtail cable, to
the on/off outlet port on machine elctronic unit, does this pigtail come with the
machine or THC kit or I need to find this model plug on electronic store and
make the cable .

                                 thanks for your help

do not use the pins or the divided voltage from the PCB board it goes through…it is not accurate voltage.
you will have problems trying to use the supplied divided voltage on the Everlast units.
use the cables and the box provided by Langmuir.
let me know and I will open up my box tonight and take some photos

open up the machine…and tie into the clamp terminal and to the terminal for the cutter.

I order a thc kit from (electronic box) from longmire last week I hope will recive soon and I do the same as you and for the ITC (on/off ) how you install that ? If you will have the time some day this week or next week to give me more information it’ will be super. I am just a beginner and this stuff so i have a lot thing to learn an all help I can have i take for now. I will thank you so mutch for everything again thank so mutch P.S I am sorry if you see some funy word english is my second language an i am not to good so have a nice

your English is great for a second language…congratulations.
I will try to post some pictures tonight for you

I just setup my 62i the same way and im also getting zero volt reading in firecontrol. I havent opened up my plasma again yet to double check my wiring but it should be fine. It seems to run fine with THC turned off. Im confused because it seems multiple people have done it this way with great results.