Cannot connect to Fire Control anymore

Hi all,
I put together the machine and I was able to install Fire Control on Mac.
I was able to connect and jog.
A few days later I turned on the machine but I cannot connect anymore:
electronics box is up, I see the green light in the usb port, but not auto-connect or manual connect.

I forgot if I upgraded to 11.0.1 after the first connection or before. Can be that?
I tried: reboot the laptop, re-download and re-install Fire Control.

What to do?

Unfortunately the IOS updated has created compatibility issues that we are currently working on. The only workaround currently is to run Windows OS on a parallel.

It must be 2020: I waited more than 3 months to get this thing, I put it together and the very same night Apple releases an update that kills Fire Control connection :grimacing:
I guess it’s angle grinder time again :sweat_smile:

1 Like

And whats the estimated time for a fix to be released?..

It has been almost 3 weeks. We are talking about one of the most used OS/Hardware, not Ubuntu…
Do you have any update on this?

ONE MORE WEEK without Mac Support. Any news?

have you sent an email to the support email?

I did… But there is no answer to the issue from them

any update on this?? really need to get my machine working again on the new computer

have you tried to manually download the driver…?

Are you trying to run it on a Mac computer? What problem are you having? I went with a mini PC to run the table, because I don’t want my expensive laptop destroyed by the metal dust created by the table.

I’m trying to operate on a new Mac (Big Sur). Just talked to Langmuir and apparently its a software AND hardware issue with the new Macs… hopefully they’ll get it resolved soon

I’m now battling this where I didn’t have this issue till now…

What mac are you using? What year and OS version? I have to run the 20.6 version of Firecontrol on one of my Macs. I’m not sure what the status of a fix for this is. @langmuir-aksel

1 Like

2020 Macbook Pro with Big Sur. I rolled back to 20.6 last night and got it to connect. However that is one of the ver. that keep crashing but at least I’m connecting now.

I’m running Monterey 12.4. 20.6 works good on that.

Does anyone know if the newest Mac update works with fire control. Last time I updated the Big Sur fire control would not connect. Ive been holding off on an update until I know it will work. any help would be greatly appreciated.

I mentioned in another thread the possibility that Langmuir’s support for what is now one of their “opening acts” is likely to go sour since they are obviously much more focused on their new shiny offerings.
Fair enough. I’m not sure I’d do any better. But this sure seems like a perfect example illustration of my prediction. Several months have passed just on this issue and… no solution in sight? Their actual solution is to “just run it on a Windows PC instead”? Really?

It might be a really good time for Langmuir to just release their source code as open-source and let more interested parties (we the customers) just dig in and solve the problems ourselves (which also solves it for them!)

As a side note, if they simply lived up to the promise of a Linux port, the breaking updates issue could likely be solved once and for all, as in an actual dedicated machine controller.
Installing a machine control on a general-public Mac or Windows system is like trying to grab a bullet train with your good arm. There will be problems.

@Spicerkyle Here is a post discussing that update from a couple days ago.


Has anyone had this problem of Fire Control not connecting to a Dell. I used my Pro a few weeks ago and it worked fine and has been working for several months. Today I connected my laptop to the Pro and the screen never changed to say connected. The green light is on at the USB port on the table. The motors hiss but does not connect. I uninstalled all programs and re-installed them. Checked the port and it is coming up. I changed USB cable. Same thing. I am at a lost of what to try next or how to trouble shoot.