Cannot connect to Fire Control anymore

What version of windows are you using?

Windows 10

have you tried to load the drivers manually?
This page has troubleshooting if you have not seen it. CUT with FireControl | Langmuir Systems

The part I think that applies to you is as follows:

Plug in your CrossFire machine via USB directly (without any USB extensions or Hubs) to your computer, open the FireControl application, and wait for FireControl to Auto-connect to your machine.

  1. If FireControl fully connects you will see ‘CrossFire’ and the Firmware version (such as v1.2ls) in the Machine Connection window. You are now fully connected.
  2. If FireControl does not fully connect and the ‘CrossFire’ text is slightly greyed out without listing the Firmware version:
  3. Wait 10 seconds with FireControl open for the Connection Help button to appear. Click this button and select the option to re-flash the firmware. Occaisonally firmware and EEPROM memory can become corrupted on the boards and needs to be reset. You may need to restart FireControl after this operation.
  4. Open Windows Device Manager. You can search the Start menu for ‘Device Manager’ to locate this application.
  5. The expected devices are shown in the image below. Note: COM Port numbers will be different on your computer but the Device Names should be the same. The CrossFire Motion Control Board will be shown as ‘USB Serial Device’ and the LS-THC module will be shown as ‘USB-SERIAL CH340’

USB Devices in Windows 10

  1. If there isn’t ‘USB Serial Device’ or you see a ‘Device Descriptor Failed’ message on a connected USB Serial Device in Device Manager, try using:
    * A different printer-style (USB-A Male to USB-B Male) USB cable
    * A different USB port on the same computer
    * A different computerIf none of these changes connect with the appropriate devices shown above, please contact Langmuir Systems Support.
1 Like

Thanks Scott for your help. I tried again to re-install everything with no results. When I plug the Pro in it does come up as the correct USB CH340 in Ports but still will not show connected in Fire Control. I did use a different cord from the Pro but that did change anything.

1 Like

I have the same problem any solution ?

I am starting to believe Dell and FCtrl just don’t play well together. I have had several types of freeze up issues since day one. I’ve taken every countermeasure step I’ve seen in this forum to isolate my laptop from EMI, except aux table ground rod.

I will say mine has never failed to connect though, so our issues may be different.

FYI I use this same laptop for Fusion 360, which demands much more of the machine. Not ideal, but works okay for amateur. FC should be a piece of cake resource wise.

Dell Latitude

I use a similar dell not sure on the specs right now. I have never had a freeze with this laptop.

1 Like

Well it could be due to my 1st gen Primeweld Cut 60, but I have it about 10-12 feet away and down at floor level, in the shadow of the table on a wooden HF moving dolly. I feel that is likely far enough/positioned right to rule it out, but maybe not. I may try re-positioning it a bit more.

I need a new laptop anyway, so I am shopping around now.

1 Like

It may not be you. I am using a Dell Vostro and I have the same issues. Crap shoot if it will link with Fire Control or THC, or even keep it for multiple files.

Computer and table control on one power supply, the plasma on another (welder/generator). Computer on a separate stand not touching the table. All using grounded cords and outlets.