PSA - FireControl on Mac

[UPDATE 8/2/22]: Apple recently released another MacOS update, Monterey 12.5. Based on our in-house testing, this update seems to have cleared up the connectivity issue with Intel-based Mac devices.

If you reverted to FireControl v20.6.2, you can now update to Monterey 12.5 and use FireControl v21.1.5. Alternatively, if you reverted your Mac back to Monterey 12.3 or below - or simply avoided updating to Monterey 12.4 - you can now update to Monterey 12.5 and continue using FireControl v21.1 and above. The compatibility list in this post will be updated to reflect this.

We are unaware if this MacOS update affected the apparent M1 compatibility that was introduced in Monterey 12.4.


Hey everyone, we have important information regarding the most recent MacOS update, Monterey 12.4.

We have been receiving reports of FireControl on Intel-based Mac devices being unable to connect to the CrossFire after updating to Monterey 12.4. Thus far, we have found a workaround for most users by reverting to FireControl v20.6.2 on affected devices, but this has not necessarily resolved the problem for everyone. If you wish to continue using the latest version of FireControl, we recommend staying on your current version of MacOS, or not exceeding Monterey 12.3.1. Alternatively, if you do update to Monterey 12.4, you can find FireControl v20.6.2 on our Downloads Page.

That being said, we have also been receiving reports of FireControl v21.1.5 (the latest release) connecting successfully on Mac devices with M1 processors running Monterey 12.4. While FireControl is still officially incompatible with M1 processors, updating to the most recent version of MacOS and installing the latest release of FireControl may or may not work for you. Because this is entirely due to a MacOS update, we cannot guarantee that this change is permanent or stable.

To summarize:

  • [UPDATE 8/2/22] For Intel-based Mac devices running MacOS Monterey 12.5, use FireControl v21.x
  • For Intel-based Mac devices running MacOS Monterey 12.4, use FireControl v20.6.2.
  • For Intel-based Mac devices running MacOS Monterey 12.3.1 or lower, you should be able to use any version of FireControl.
  • For M1-based Mac devices running MacOS Monterey 12.4, use FireControl v21.1.5 (unofficially).
  • For M1-based Mac devices running MacOS Monterey 12.3.1 or lower, FireControl is incompatible (to our knowledge).

This is a relatively new issue, one that is difficult for us to recreate due to the computers we have available for testing. If you run into this issue on an Intel-based Mac or have success running the most recent version of FireControl on an M1 device, we’d appreciate hearing about it here, or via email at support@langmuirsystems.com.

As always, we will continue to work hard to bring FireControl compatibility to as many users as possible!

2 Likes

I can report that it does fix my intel Mac connection issues! Thanks! @langmuirsystems