Z Axis Height Does Not Match Programmed Height - SOLVED DIP Switch Error

Crossfire XL with THC
PrimeWeld CUT60 (latest generation)
PTM-60 torch
Fusion 360 for CAD/CAM

Rather unique one, and the only person I can think of adding to this is @AultFab since he had a similar issue.

@toolboy Since he and I are on the same page about this and maybe he can chime in.

Backstory - Ever since my bad VIM, I switched to raw voltage on my plasma cutter. I had gone through measuring voltage, pulling off my torch, etc. when I was troubleshooting. This is relevant as you read on below

I know how to set my correct programmed torch height, as I did so when I first set up my table in Dec/Jan. To achieve an actual cut height of .06" my programmed height for post processing needed to be at .0545" and that gave me no beveling and smooth cuts.

With that said, I have a new UPM-105 coming in tomorrow to replace my PTM-60. Just for kicks today, I decided to just run some test pieces in anticipation of doing so tomorrow on the new torch.

That and because I never confirmed my cut height after reassembly from my VIM issue, I thought I’d play around today.

How is it that my cut height is .020" whether my programmed cut height was .0545", as well as .0745", and even .1"?

This tells me something isn’t “changing” whether it’s in Firecontrol or Fusion.

My Fusion 360 defaults have not changed at all the entire year and I’m referring to springback, and other items not messed with. Only thing I ever change are pierce delays based on thickness material.

In Firecontrol as my g-code runs, it will state in the command list the ‘programmed’ cut heights I’ve used as stated above. Smart voltage is on and reads at like 87-88v when it was cutting 10 gauge during my testing.

My torch however, cuts without issue whether I have THC enabled or disabled. So it’s not a firing issue, air pressure issue, nothing like that.

My cut height simply does not change based on programming changes.

Oh and just for kicks, it’s not running out of travel, the torch is mounted correctly (as it has been this entire year) and I use feeler gauges I removed from the set for accuracy.

Results were simply the .020" gauge being the only one fitting between the torch and base work piece after pausing a cut.

Just a dumb question? Why the torch and consumables change? That should have nothing to do with the trouble your having and will limit you on consumable to 45 or 70 amp tips.

Not a dumb question at all!

Just to “see what the fuss is about”

The one common thing I’ve read (with all other things being equal) is throughout the life of the consumables, cut quality is more consistent.

I am aware of the “being stuck to” certain consumables but thought I’d try it.

What sucks is certain people on Facebook group don’t even post pictures of their work (as I requested) so it has made me hesitate for a bit. That was until I found this -


He posts pictures doing some thorough testing with both the PTM-60 and UPM-105.

I have achieved good results with my PTM-60, and I am aware of moisture and other factors being the biggest contributors towards a successful cut.

Again, just seeing what the ‘fuss is about’

Regarding the other member I tagged, his thread mentioned getting rid of IHS spring back and going lower on his cut height but this was mentioned as a band-aid fix.

We’ll see what others have to say, or if my table tomorrow suddenly starts “working as intended” again.

1 Like

I had the same occurrence with the change of cut height earlier this year. I noticed the terrible bevel and dross on both sides (top and bottom) of the cut. I had not changed anything…or at least I don’t think so.

In May of this year is when I got very aggressive on figuring it out. I had a big delay with access to my machine when my laptop stopped working. Now there is minimal to no dross but noticing extra bevel (could be the nozzle) so not too worried.

As for my springback, I use “-0.22 inches”

The only other reason I am chiming in is that I have noticed that sometimes I check “Use machine configuration” and in the random fashion I may have “Autodesk” or “Langmuir” in there. Other times I uncheck the box. I always put FireControl in the “Post” box. So what I am saying is that I really need to get consistent and figure what I am picking and how or if it changes things.

1 Like

I never mess with that, as mentioned I only ever mess with pierce delay (for material thickness) and that box is always checked.

What I cannot confirm with you at the moment however is, what is displayed in the dialog box.

So tomorrow I will cut yet again, varying in cut height, and make sure the box has the same item within it.

But yes the box was always checked by default; should I uncheck it?

Also to add; the laptop used for post processing has nothing more other than Fusion for CAD/CAM and Firecontrol. Nothing more.

1 Like

Have no idea?

95% true for me. 100% on the laptop that died.

As far as the height remaining the same, does changing your pierce height reflect correctly at the torch?

Have you tried cleaning ihs switch and z lead screw? Coupling slipping maybe?

1 Like

I have not cut yet today, I can try this and report back.

I do periodic cleaning, no binding or slipping.

I do make sure that wire/screw is always secure but what switch exactly? The metal contact when IHS does it’s thing and comes down, then bumps back up?

If so, yeah that’s clean before I posted.

1 Like

I have a feeling my solution is something stupid simple, but I can’t figure out what.

This was me cutting some hangers real quick out of 1/4" some 3 days ago and at the 41 second mark, you can see the Z coupler turn slightly as THC is working as intended (I’m assuming).

Like I said maybe it’s a fluke and if I cut today and it starts working, I’ll report back.

My UPM-105 is set to arrive today.

Speaking of…


Here are my post process settings; mind you I’ve never changed anything before or after with the exception of pierce delays.

And correction, I guess I never had that box checked. It asks for some machine library so it’s unchecked and I guess it always has been unchecked.

Here I ran .06 cut height on purpose -

The actual cut height -

The results of cutting -

Then I ran it at .1 cut height -

And same results -

I can literally stack both parts and they’re the same -

Going from .06" to .1" cut height made no physical changes as they both netted to .02".

Anything wrong in my post process? Odd because again, I change nothing at all other than pierce delays this entire year I’ve run my table.

1 Like

Are you using smart voltage or writing in a voltage? if using smart try writing in a voltage. Note what it is running and increase a few to see if it changes.
Have you run one of the torch heights programs to see how it cycles?

Yep, mentioned above smart voltage.

Reads consistently between 87-88v and I’m running raw voltage.

  1. What parameters would I be using if I disabled smart voltage?

  2. Why would smart voltage be an issue now? Is it because I’m running raw? I used to run divided before my voltage input module burned out a resistor. Using the same module though but I was told divided and raw circuits are separate.

  3. How do I disable smart voltage? I’m only aware of disabling THC via Firecontrol and unchecking THC in post processing.

It may not be a issue just a way to eliminate a hardware problem… 80ish so volts sounds low my setup runs in the 120 range cutting 14ga not a lot higher for .250

In fire control you can click setting in the THC section. There you can write in a voltage you desire…

Goes back to my question; what voltage do I enter?

I have notes for myself for cutting speeds at different thicknesses, not to mention amperage and air pressure settings.

Now I need to have a list for voltages? How do I figure this out?

Only thing I can think of since you mentioned my voltage is low is the port I added. The wiring run is actually a hair shorter but I added a “port” for my raw voltage for a clean install.

I will do this tomorrow -

  1. I will use my brand new VIM that Langmuir sent, even though the only thing wrong with my current one is the divided voltage circuit.

  2. I will open up my plasma cutter (again) and rewire to bypass the port mod I have in place.

If this does not change my voltage, which I’m 99% sure I had around 87-88 volts before I ever did the mod, what else could possibly be the issue?

The IHS sets the initial height. Then the torch fires and the THC records the voltage for the first second or so of the cut. The THC uses this value “smart voltage” as its baseline and commands the torch up or down to maintain the voltage it recorded.

If you want to write in a voltage you would need to turn off the thc. set the cut height with the IHS and verify the IHS set the correct height… then do a cut …8-10 inches and record the average voltage recorded by fire control during the cut. You would then add that voltage in place of the smart voltage. Hypertherm users have a leg up on us PW users as they have the voltage in their cut charts. I suppose its possible your mod has changed the resistance some… but I have no idea.


Man, that sounds like something I’d have to find time for :grimacing:

I don’t necessarily want to write in voltages and the sort but I may have to do this when possible.

On the otherhand, I would rather troubleshoot and fix versus band aid so I will swap out the VIM with the new one and note any changes.

If none, I will open up my plasma cutter once more and wire directly and bypass the port. Again I am 99% certain 87-88 is what I’ve read as I remember seeing that number when I first went raw voltage.

I ran raw voltage for 2-3 weeks before adding the port but the issue is, I never did my cut height measurement even after the whole VIM ordeal.