X axis locking up

Hey everyone,

Until today my Crossfire was running great but I went to cut something today and it was “locking up” or “freezing” mid rapid. I was jogging the machine around getting my origin set when it happened. After I got frustrated and left it alone for a while I came back and was able to cut something. But then on part number 2 the problem started happening again.

I have uploaded a video to youtube so you can see what I’m talking about.

Thanks for any help and suggestions.


Considering that it was running ok, i would suggest starting with lubricating the lead screw to see if the issue improves. If that doesn’t work theres a few other things to try.

Mine did that and messed up a sign i was cutting.My fix was to blow out the bearing carriers and the rail and i sprayed wd40 on the bearings.No issue since.

1 Like

Thanks guys, I will give that a try tomorrow

Just to follow up, a little lubricant on the lead screws seems to do the trick. I cut several parts today without a hiccup.


1 Like

Well I Got everything assembled and ran the Breakin program without a hitch. Next day I went down and got everything powered up and went to jog the gantry out of the way and the X Axis stalled out, then would move a bit and stall out every time I hit jog, the Y is fine. I made sure the lead screw was greased and tried again and it still did it, removed the torch thinking it is making it bind, but still did it. I unbolted the lead screw nut and it spins freely on the lead screw and the carriage moves without any binding on the X axis Beam, bolted everything up and it ran the breakin program clear through with no stalling. Set up and cut an F-Bomb bottle opener (a must) and it cut fine, then set up to make my first major cut and it started stalling again. I am starting to think it might be the stepper motor stalling out or a bad lead screw nut. There is a person that is posting on one of the Langmuir Facebook pages that is having the exact same problem and it is only his X Axis like mine. It keep happening so randomly I hate to start cutting any more stuff.

Hi, can you break loose the two cap screws that secure the lead nut mounting tab to the torch carriage and see if that fixes it? It is possible that the bracket shifted during shipping and is no longer square. Loosen those bolts and see if it jogs properly.

1 Like

I finally got time to check it again today. I ran the carriage about 2/3 the way in the X+ and when I loosened the 2 cap screws I did see the bracket move a bit. I do believe it was in a slight bind. I also wiped the lead screw down and lubed it with wd40 for now until it wears in a little. This ones a little easier to work on than my last CNC machine! :joy:

Yeah so that mount either shifted during shipping, or the guys misused the alignment fixture (non poke yoke fixture design, i take the blame there). In any case i will let the guys know tomorrow morning to watch out for that.

No worry’s, thanks for the help.

Hi, I finally got to cut a couple things out sunday. Tonight i cut 2 projects out fine. The third one had a circle around it and when it started cutting it ,it went half around and the Y axis stuck. Now it will jog one half a turn on the lead screw in the possative direction at one time. In the Negative it will go perfectly smooth. I greases the lead screw sunday. Tonight i loosened up the lead screw . Made sure everything looked ok . Including the carrier thing with the 4 bolts that the lead screw runs in. I loosened the allen screws that put the tension on the roller bearings. Does the same thing with everything tension free. Any Ideas? Thanks Jim

Ok when i unbolt the 4 cap screws on the thing that the lead screw pushes/pulls with I can barley hold it when jogging machine.( it went on very hard when assembling) I greased it real well and held it with pliers and went back and forth. I have it jogging now . My only concern is the pitch of the sound is real low compared to the X axis motor. Is the sound difference normal because one is moving alot more weight? Looks like it is even running slower. I dont want to burn up the motor. Not sure if its the lead screw or the threaded holder that is making it real tight. Everything was clean. I need to know if I need to just run it that way or replace a lead screw and threaded peice . Thanks Jim

Hi Jim,

Sounds like your lead nut is defective. Was it hard to scrww on?

1 Like

Yes Sir, I thought it would wear in with use but i feel its getting worse.

Is the black part of the nut exposed? When you screwed it on the lead screw did you pull the white collar back against the spring so the black fingers protruded a bit? They’re split so they’ll open up around the lead screw and the white collar springs back around to give it some pressure but not too tight.

If you don’t pull the collar back against the spring you can get it on the lead screw but it’s anywhere from wicked tight to OMG I need a wrench on the lead screw to turn it tight :slight_smile:

If it’s on right, you can pull the white collar back against the spring even when it’s screwed onto the lead screw. If it’s not on right (like if the collar wasn’t pulled back when you screwed it on) then you likely can’t move the collar back.

Here are a couple of pictures. One with how it should look at rest and the other shows how the collar can be pulled back and you can see the way the black part extends out.

1 Like

Yep did it on the first one after i figure that out it stil went on alot harder than the first. put leather gloves on when puttin it on lead screw was chewin my hands up. thought it would wear in. and the spring works fine. just like the other one. and Thanks for the reply.

Hi Jim,
We’ll get a new one sent out to you today.

Ok Thank you for being such a stand up business. We all do Appricate you all at Ls.

1 Like

I am having this same issue with the x axis binding. I have followed all the different steps and no matter what I do all of a sudden there is random binding it just seems to move to different sections of the x axis as i loosen or tighten different components.

1 Like

I would also add that my x axis motor is always warm no matter if its moving or not. Is this normal. I have never felt any heat whatsoever from the y axis motor. However after removing the x axis stepper motor it doesnt seem to have any issues and there are definitely dry spots turning the lead screw.