X-stepper driver not working properly after replacement

I recently purchased my crossfire and unfortunately during shipping the electronics enclosure was crushed. I contacted support and they quickly shipped out a new wiring harness and a new x axis driver . I got the package last night and replaced the damaged components .

When i jog the torch around the cutting table the y axis is smooth and predictable , the x axis however only moves about 1 cm when i press the arrow key then stops and makes a higher pitch sound than when it is moving and absolutely sounds higher than than the y-axis motor. It sounds like it is getting stuck however when i go to run a program for testing , it moves around the table and does not sound like it is binding up . When i go to return to 0 however it does not return to the same position , y axis returns to the correct potion but the x axis is off.

I have verified all the settings and connections as described in

I have reset all settings in mach 3 , reinstalled and re setup.

i have verified that the only dip set on the new driver is dip 6 all other positions are off.
I have cross referenced my connections and wiring with other pictures and the original configuration before i installed the new driver

I have made sure the x axis lead nut is properly tightened
I have verified that all parts that need to be lubed are lubed with grease.

Here is the current wiring configuration with the new components installed

in addition here is a video of the situation .

Just a thought. Loosen the 4 nuts/bolts holding you lead screw nut. Just enough you can slightly move it around and try jogging with it .

great idea , i tried that already it dont seem to be a binding issue :frowning:

I cant reallly see the motor . Is the motor spinning in the couple on the lead screw? Its not likley but… And try jogging it while helping it with your hand and see if it goes past that spot if you havnt.

so here is a better video , if i press the jog button down for x axis only it seems to just “step” then make the high pitch sound and stop , If i press the key again it will advance another cm and do the exact same thing . it will move the entire length of the axis but only 1 cm at a time aka i have to just keep pressing the arrow key and it will move. When i run a program it has the same behavior , If it is to move total of say 5 cm for a cut it will only advance 1 cm then stop until the next command is sent . Here is a better video highlighting the components

You should be able to turn the lead screw by hand fairly easy. If you cant its most likley your lead screw nut. When you put it on the lead screw did it go on easy? Did you compress the spring when you put it on? Can you try pushing the lead screw nut in and try jogging at the same time? By that i mean the spring on the lead nut.

manually trying to move it while pressing the jog button does not seem to make any difference , its like the motor locks up and wont advance anymore . i verified the lead nut screw has the same tension and rotational ability similar to the y-axis.

Well the only things i would check now is … does the torch carrier move freely with the lead nut removed from it. And with that unhooked does the motor turn the lead screw fine . If that all goes well next I would contact sapport and have them read this thread and see your vids. I had a bad lead screw nut . And it did just like your vids.

thank you , i am trying now . I appreciate your response and help

Your welcome. You will geit it a goin soon

here is the detached the lead nut and it the torch carrier moves freely. the motor is still stalling and having the same behavior . Here is another video showing what is happening with all other variables removed.

I agree the motor is stalling out. can you turn the lead screw now by hand? Only other thing is the bearing at the end of the lead screw. Or the motor.

yes the lead nut moves no problem by hand and so does the torch carriage

does the actual lead screw turn easy by hand also?

I guess the bearing on the end of the leadscrew could be bad.

have you tried cranking down on the motor couple set screw? make sure the set screw is sitting on the flat part on the motor shaft. and really tighten both set screws.

one thing i noticed on the new wiring harness is different than the old one. the black thing (no idea what it is) is much larger than the original and it is something that is inline on the x-axis

yes , i even disconnected it , the motor seems to just stall now with the new driver installed.

sounds like the gears are binding inside the motor or there is debris inside.

I would absolutely agree with that assessment but I have never actually been able to use this machine yet . Prior to swapping out the x driver and the wiring harness the x axis performed correctly but there was a short somewhere causing the plasma cutter to stay on continuously which is why I was sent replacement parts . Now the torch will fire when told to but the x axis is not moving correctly with the new parts installed .