Torch will not stay down with THC turned on (solved)

So I installed the THC Z-axis upgrade on my crossfire machine using a Primeweld Cut 60 plasma (this Cut 60 has the CNC port at upper right on rear of machine) I manually tested all of the divided voltages. Voltage coming out of plasma is 1.7 - 1.8 voltage after VIM box is 1.1 - 1.2 and then ran the THC health check in the control panel all test passed. With all that said when I turn the THC on and run a cut the torch pierces starts cutting and the Z-axis starts going up until it hits its top limit.
Did I wire something wrong? or is this a programming issue? All of the THS setting are default.

Watch the screen and see if the IHS light turns green when it’s rising.

As a safety feature, Firecontrol will raise the torch by .060" if the IHS circuit opens during a cut. It does this because the switch being open usually indicates that the torch is in contact with the metal. It will keep raising the torch until the light goes off or it runs out of travel.

1 Like

The THC control panel shows the voltage and the travel speed when it starts cutting but none of the lights (down, up, active, ok) lights come on.

so l et us go through some basics…

  • is the clamp from the plasma on the metal you are cutting?
  • is your USB mixed in or tangled with the plasma lines?
  • is your laptop plugged into power?..needs to run on battery or have an isloated ground.
  • do you have a ferrite choke on the USB cable?

check all those first…

Ground isclamped on the metal,
USB is not next to the plasma cables
Laptop is running on battery
Yes, the usb does have a ferrite choke.

Not those lights. The IHS(initial height sensing) light that comes on if you lift up on the torch.

The fact that the THC is not commanding an up movement is another indicator that this is an IHS issue.

Note: if that IHS light is always green, that means the IHS switch is open or the wires are not connected.


No, the IHS light is not on when the torch starts to rise.

1 Like

Alright after testing voltage and going thru the Lamuir THC troubleshooting guide several time with no success I started reading all the post about THC issues and found one that mentioned pulling the THC module and reinstalling it was one thing he had done before the system started working.

So I pulled my THC module and reinstalled it and l’ll be a SOB it works.

I would suggest to any one having issues with their torch rising or dropping out of control to pull and reinstall the THC module first before chasing your tail.

Thank everyone for their suggestions.


so would you call this completed?

As of right now yes.

I have marked it SOLVED for now…

1 Like

You should delete this and start a new post being this is marked “Solved”