THC Troubleshooting

ive went through the guide and the torch just dives into the material no matter what voltage i set it at, 100, 150, 200, 250 etc. or 0 for smart…

on smart its saying ~4.5V while its dragging the head around on the metal…

i dont get it…

welll…we are all here to help…
did it ever work?
or is this recent?

I have THC and it works fine.

what plasma machine are you using?
what software for design and post processing

what concerns me is that the head should not drag…do you have IHS turned on?
Initial Height Sensing…
it will stop the head from banging down…it touches then raises up .06…THC holds the .06

It’s never worked correctly. I don’t use the table much but am starting to get back to it. It’s always given me trouble in the past. And I just end up turning it off to get my cuts done.

It’s wired into the hypertherm 30air, using raw voltage, according to the other thread. It reads that it’s there and is functioning.

IHs is on and working, head will come down, tap the plate, run up and then slowly come down to spec.

also using mastercam or inkscape, then using sheetcam for post processor

sounds like you’re on a later version of firecontrol. the latest only touches down once.

Is your computer plugged in while cutting? You will get interference if using a grounded plug.

Update all your firmware and post processor and what not.


im on firecontrol 20.4, ill update that. i remember i updated something a while ago and it made everything act goofy and nothing worked right.

ill look into the sheetcam update and update that and see what happens

yes, i keep it plugged in while using it. ill try unplugging it

Ground direct to your material. And update to FC 20.6 , Sheetcam Post Processor v1.6, and the new FC will update your firmware for your tables control box.

1 Like

I have had issues with my THC since I got my table. Been very lazy looking into why, been running it with the THC turned off with great results.i thought I would finally complete the trouble shooting guide, ends up my unit is faulty and Langmuir are sending a new unit. I would recommend contacting Langmuir customer support they have been very helpful.


They have already replaced the THC module on the mother board.
The first one completely went out and wouldn’t even be recognized by the computer.

Ah ! That isn’t good. Have you got back in contact with Langmuir? Faulty VIM box as well ?

everything is up to date and its still just ramming the head into the metal and dragging it around…

according to the THC test its says its reading 95.4V, so i went and set the voltage to that and its still just ramming the head into the metal and dragging it around

have you tried it with THC off to rule that out? IHS should still work.

yes, when i turn the THC off, it runs just fine.

i dont get it…

Can you post a pic of how you have the THC box connected?

i have it wired up like this thread.
when i said it works (in that thread), i meant it didnt conflict with anything. its never really worked right.

the red wire from the VIM box goes to the ground clamp lug inside the machine.
the black wire from the VIM box goes to the torch leads inside the box.

i tried to upload pic but its saying theyre too large

nvm got it to upload finally