THC not detecting voltage

Went to cut a project tonight and originally thought my plasma cutter wasn’t working. Trouble shot that until I realized my THC is detecting 0 voltage.

I ran the THC test and it confirmed it’s getting no voltage.

I need some help, I’m kinda wondering if the box is dead. I did about all I could think of including checking the wiring into my plasma cutter and into the control box and everything’s correct.

I need some help.

1 Like

What plasma cutter do you have?

Can you fire the torch though Firecontrol or use the straight cut function?

Could you post your G-Code file?

How is it the wies hooked up on the VIM? (voltage input module) the small black box

1 Like

Primeweld Cut60

Yes, the torch fires off the trigger. The torch fires and completed the entire job after disabling the THC function and starting the cut.

And yes the box is plugged in both to the plasma cutter, THC box and crossfire control box which is also connected to the PC.

I also ran the THC test function and it said it does not detect voltage.

And you’re using the divided voltage?

Can you verify all the cable connections between your plasma cutter and the langmuir electronics enclosure. That have to do with the torch height control

how old is the cutter?

is the cnc port located on the top right or bottom right?

are you running divided or RAW voltage?

I’m not sure what divided or non divided voltage is.

I’m just using what was told from the assembly instructions n the crossfire pro assembly PDF.

And yes all the pins and wires are still connected.

I did notice the output plug was out one test run after I was moving it around but after plugging it back in there was no change.

I’m not sure of the difference or how to use either or. I just use default THC settings and how the assembly instructions of both the Cut60 and Crossfire pro instructions described to assemble and wire.

Edit: Machine and table are roughly 6 months old if not less.

Where on your primeweld are the wires hooked up for the torch height control.

Is it from the inside of the unit or the CPC port back of the unit?

From there does it use the black and red connectors into the vim (the small black box voltage input module) on the top face.

Then PV output to your electronics enclosure?


Does it go from the CPC port on the back of the Prime weld.

To the DV input on the vim.

Then from the DV output on the vim to the langmuir electronics enclosure.

They lay out several different ways of going about it in the assembly PDF depending on your application. Depending on the age of your Prime weld and whether you hooked up to raw or divided voltage there may be issues.

Both the prime weld and the table are roughly 3-6 month old.

And it does not use the red and black top ports on the THC box. They are connected with black wires to the side of the box that needed to be spliced in.

IIRC I remember seeing something in the instructions stating my machine needed it the way I wired it. Because originally I was going to use the red and black wires but read to not and had to cut n splice the other connectors instead.

As well as in the prime weld manual stated something that was used in the prime weld manual that stated to use those wires and pin layouts.

I would double check CPC pin locations

It sounds like you’re using the divided voltage.

After looking in my manual for the instructions I used on my prime weld.

Yes I’m using the DVI with pins 4 and 6… Which worked fine for the last few months until this weekend.

So I am using divided.

Manual here (page 29)

PrimeWeld Cut 60 Manual

I didn’t realize that you had been using the THC successfully in the past.

I seen you were just talking about the plasma unit itself that you had been using.

I would check for loose electrical connections.

And then I would check for voltage after the vim. Or really anywhere along that line

It’s about finding out where the electrical buck stops.

Have you gone thru the THC troubleshooting guide? Should help you pinpoint the problem.

Other than that, did you maybe unplug the cables from the VIM box for whatever reason and connected them back in the wrong ports? Since you’re using divided voltage, you should be using the DV IN/OUT ports on the box. Cutter → DV IN / DV OUT → control box.

I’ve tried the wire pull test, I’ve checked all connection points. Removed and reseated plug connections, I ran the THC test option on FireControl, and checked plug in connections and it’s all correct.

I haven’t busted out my multi meter yet.

Was wondering if you fixed your problem with voltage on thc?

No I was not.

I get 20v into the barrel connector into the Div THC box on firing. And 0 out of the THC box. So my power is stopping at the box.

And I also get 14.5v constant into the IHC from the machine.

I’m starting to believe my THC box is dead.

It is a possibility.

I know some of the older PW Cut 60s were somewhat unreliable with the voltage divider at the CNC port. Langmuir mentioned that in one of their PSA’s. After I saw that I switched mine to the raw voltage. Try chasing it with your multimeter. Perhaps you could wire to your raw voltage and see if it works. There are a couple of different threads that show how to do it on here. It is pretty easy… hardest part is they use what seems like 100 screws to hold everything together.

If you are getting 20v at the DIV input, your plasma cutter is not set up for 50:1 divided voltage. The LS THC troubleshooting guide specifies between 1.2 and 3 volts. I don’t know how much it can handle, but 20v might have fried the VIM internals.

If you are getting 14.5v resting voltage, something is definitely wrong with the wiring or something is bridging the contacts in the IHS system.


Not sure how.

I ran Pin 4 and Pin 6 to the THC as instructed which is the 1:50 div.

And ON/OFF to Pin 1 and Pin 2 which as per instructions are both right.

Checked connections on both sides of the pins. Correct.

And there is no way of bridging being each individual pin solder has its own heat shrink, as well as each wire, as well as the entire wire bundle. That’s 6 heat shrink connections in total with no exposed connections or wiring.

Page 29 of the CNC connection in the Primeweld manual