Table glitch Motors, whining, and getting a mind of its own

Went to use my table today, cutting some gussets with octagon pattern in them.
I cut too no problem then I did the pattern in fire control to cut and the table started glitching crashed fire control a couple times then got the message got disconnected and randomly. It would be mid cut of an octagon and then start cutting some random other shape.
Also, the servo motors would start winding really loud a couple times I tried to hold it. It would get stuck at home.
Never had this problem before! One time it was mid table motor was whining like crazy like he got stuck between steps
I shut everything off, started over from scratch when I powered back up the table. It ran no problem. Did that first time it ran for a little bit when I powered it back up and started having the same problems shut it off turn it back on I was able to cut the last one without a problem.

Two things come to mind:

  1. The lead screws could have gotten some crude, corrosion (z-axis) and need lubrication. I kept having really incredible loud sounds and since the gantry was stopping, I assumed an issue with the x or y lead screws. I kept spraying them with more and more lubrication. Sometimes it seemed to help, other times it made it worse. Turned out it was not connected to what I was doing. It was the z-axis. A little squirt of WD-40 and everything was happy again.

  2. If you haven’t used it for awhile you might have things set up a bit different than before: there could be a possibility of having some EMI issues. I would check the torch cable, work lead and the USB cable from the computer to the enclosure for loops and near-influence with each other. Uncoil the cables. If using a laptop, run off the battery if possible.

If you have recently gotten a different computer or even if it is the same one, look and see if the processor has this:

1 Like

I clean the rails and lead screws when I’m done
I haven’t changed anything from how I normally do things I have the laptop running off battery and it’s on a table not connected to it no loops in the usb cable.
I set it to nest two parts in fire Controle when it did it the first time I tryed running a couple times, it kept screwing up then I flipped it over and tryed running it to fit the steel I had and it messed up .

I don’t know if that has anything to do with it or if it’s a coincidence.

1 Like

Then I would check the power supply in the enclosure. It should measure 36v. There is a pot you can adjust if it is not measuring 36v but in my mind, if that changed then the power supply is getting ready to give up the ghost. Or one of the motors is getting ready to fail.

I would be surprised if that caused the issues. You would have gotten some notifications from FireControl if it didn’t like something rather than misbehaving.

1 Like

I will check the power supply tomorrow.


I checked the power supply it’s putting out 36.29 V I ran the pattern probably took 30 minutes back to back and it never dropped so now the only variable is, I was not running the Plasma cutter. Maybe it is high frequency interference.
I’ve never had that problem before, but I was looking online one guy suggest on soldering a chip off the board don’t know if I really wanna do that.

1 Like


…Hopefully others may give you some other things to check. The EMI thing can really be a bag of worms because it can be intermittent. Have you opened a ticket with Langmuir?

Does the USB cable from your computer have the ferrite coils? If not, you might consider something like this:
I have had this on my table for about 24 months and no issues (related to the cable).

We have had people report that they have EMI issues because of the clothes dryer running. It could be something totally out of sight.

1 Like

I just ordered that cable. I’m just using the one that comes with it.
I dont think it’s anything in the shop the table is in the middle of a 50x80 shop that’s all concrete and rebar it’s a faraday cage its itself
I all do unplug all my equipment when not using them to avoid lightning strikes taking out stuff like vfds.
I have not called Langmeyer last time I tryed to call them to get a price on a thc for the table no one would pick up I finally left a message and steel to this day no one called me back.

I have heard they have and are doing a considerable effort with hiring so that may have changed. I understand your reluctance: once bitten twice shy.

do an email support request…that is the best way to reach them…

Hey @mark.johnson310 I was just about to ask you to email support when I saw your name in my inbox. We’ll get this resolved together!

The addition of a ferrite choke is a good recommendation- however, there is a reason that the USB cable is the specific lengths that we provide. The longer a USB cable is, the more susceptible it is to EMI interference. Our USB cable is just long enough to reach from the CNC electronics enclosure to the laptop stand mounting area, with enough slack that a set of additional ferrite chokes can be added if necessary. If a longer USB cable is used, even if it has ferrite chokes, then disconnection between FireControl and the machine is possible when the plamsa cutter fires an arc.


Totally agree. I usually say:
“Don’t start swapping out things until you have your machine up and running correctly. Then if you have the notion of making a change, only make one change at a time.”

But I got sloppy with that graphic and my comment. I have put myself in the ‘time-out’ chair. :face_with_open_eyes_and_hand_over_mouth: