Symptoms of a motor coupler slip but it's not

My table has been cutting fine for years but all of a sudden it’s not cutting right. It seems to have an issue similar to a motor slipping but the couplers on the x and y are tight. Some of the cuts don’t even complete because the torch appears to shift during the cut and by the time it gets to the end of the cut it’s off so it doesn’t end at the start of the cut . Also, when I sent the torch to zero it moved the torch back to the correct spot. I marked the couplers and shafts and then ran the x and y the full travel both ways several times and no slippage. Ran the break in program and did not notice any issues. Moved very smoothly. Any idea what would be causing this?

Assume you oil lead screws? you may check the bolts that hold the lead screw nut brackets on.


It sure looks like a coupler slipping. Did you mark them with a marker to check?

1 Like

Check the two bolts that hold the X axis lead nut. If they are loose, you will lose motion on direction changes in X.

Edit: I forgot to specify the two bolts that hold the bracket that the lead nut bolts into.


Looking at the sawtooth pattern I would suspect that the x-axis lead nut itself may be worn to the point its starting to slip. That would show that type of slip-catch, slip-catch, slip-catch pattern as the teeth of the nut jump from one thread to the next on the lead screw.

Also if it were to slip the same number of threads traveling in the negative x direction as it did in the positive direction since the beginning of the move it could wind up back in the correct x-axis zero position.

1 Like

All is oiled and tight on the lead screws

1 Like

Yes, couplers and motor shafts are marked

1 Like

It’s tight

1 Like

I just edited my comment. I forgot to specify that it’s the two bolts that hold the lead nut bracket onto the carriage.

That makes sense. Probably need to change the x-axis lead nut. I contacted Langmuir and waiting to hear back.

I’m thinking it’s the lead nut on the x axis

Ok so I thought it could be the lead nut on the x axis but now I don’t think so. I ran the dry run several times and watched the lead nut on the x axis and runs smooth. I don’t see it jump teeth at all and I know what it looks like as I had a defected lead nut when I first built the table and replacing it fixed it but when it jumps a tooth it’s very noticeable. Sounds like it’s the controller port. I mentioned this to Langmuir but they ignored the question and said it’s slipping couplers. I know for sure it’s not that. Also, after each dry run, I send the torch back to zero and it goes right back to the original spot. I start the dry run again and it starts off running right and gradually shifts to the left half way through the program. I repeated this process several times with the same result.

I checked the x axis DB9 port and pins are good. Both male and female ends look good. I set the torch to zero on the x and y axis and ran it across and measurements are dead on. Moved the torch in increments of 5 inches and took measurements and measurements match what is says on Firecontrol. The only thing I can think of that it might me is the controller itself is bad or the main board. Anyone know if this can cause this problem?

Another thing to check is the bearings. It may be possible a bearing could be sticking.

When you say “controller” Are you referring to the main control board or motor drivers? The “controller” is a group of parts. You could try swapping the X axis motor driver with one of the Y Drivers and see if the problem switches to the Y axis. I believe those are the same I don’t recall if the Z driver is the same as the others but if it is you could swap that one in. Check to make sure the dip switches are positioned as they should be. Make notes of original positions.

I checked them all and all are good

I’ll have to try this later but I’ve run a dry run and watched it many times now and it does the same thing. It cuts perfectly the first 1/3 of the program then suddenly at the same spot it starts to drift. What would cause this. I thought maybe the program was corrupt but. I reloaded a saved copy from another drive and it’s still repeating this same problem. Could it be Firecontrol? Would removing it and reinstalling it fix this?

How do I get in touch with Langmuir? They responded one time and now crickets.

If it is the same spot all the time check your rails for splatter. You could remove the lead screw and make sure everything slides easy.

Have you tried a completely different file?

1 Like

Rails and everything is clean. I’ve run another file with no issues but it was a small bottle opener file. I’m going to run another file later in the same spot where the problem happens with the large file and see what happens.

1 Like