SOLVED- Torch will not fire (I've read the threads)

My torch will not fire when attached to control unit.

I’ve reseated the THC chip and the white relay.
I’ve confirmed continuity in the torch fire cable. I can fire by shorting the terminals in the back of the connector in the control box.

With the plasma off I can hear the relay click when I hit the manual fire button. With the plasma on, torch will not manual fire from the Fire Control software.

I can cut just fine with standard hand held torch when not attached to cross fire.

before this happened It was cutting kind of crappy for the past two days a little bit. I was diagnosing THC issues. I changed from divided voltage hookup to full voltage and of course changed the appropriate plug positions. I cut a bit with full voltage and it seemed to be ok. Then it just stopped midway through a pierce and I spent hours trying to diagnose. Couldn’t complete the file. Loaded other known good files and no luck. Went back to divided voltage and no luck.

Cutter is Everlast PowerPlasma 60s. Again, it seems to be working fine on its own. I’ve read every thread I can find on torch not firing.

I’ve sent in a help ticket, but haven’t heard back yet (just over the weekend, so that’s to be expected). But I have a paying gig for an art show and I need to get it resolved.
Thanks for your help!


do you get continuity in the control box connector when you select manual fire in firecontrol and hear the relay click?

Hmm… interestingly I get continuity with the manual fire button on OR off.

1st make sure the torch is in 2T…not 4T setting
Pilot Arc set to normal
make sure you get 90PSi steady at the back regulator…

next…your voltage take off…is it from the pins on the back (CNC plug) or direct off the lug terminals inside the Plasma cutter?

everlast have been known to have voltage issues off the cnc pins…

I have a 62i and I only use the cnc plug for trigger on and off and then have gone right to the lugs inside for the raw voltage…

1 Like

I have the trigger coming off the CNC port, but THC voltage comes off the torch and work clamp terminals at the front of the unit (I think I may have gotten that idea from you, toolboy). It is set for 2t and pilot arc is set to normal. Tried cutting at 35 and 45 amps.

i hate to think we are going back over things…but bear with us…we will get you back up and running

were you ever cutting without a problem?
or have you had this from the start?

Like many, I’ve had misfires and what seemed to be THC issues, but I’ve been able to cut. I was cutting yesterday morning OK, but then it just stopped. Hours of troubleshooting and no go. Thanks all for you help!

If you short the end of your torch fire cable with a paper clip, does the torch fire?

Yes it will fire my handheld torch if I short the cable.

Just as background…I just discovered that there is a problem with my machine torch that is unrelated to the issue described above. George went above and beyond to help with that issue. I still have all the same issues with the hand torch.

And on another maybe related note…my THC voltage is zero no matter which method I use to hook up the THC.

If shorting the cable fires your torch thats good. I recommend using a voltmeter to measure continuity between the contacts of the torch fire port on your box when you click manual torch fire in FireControl. If you aren’t getting continuity there but you do hear the relay click, then there’s an issue with the torch fire port itself.

After you get your torch firing from software, let me know and I’ll help you to get your THC working.

Hi Daniel, I can get my torch to fire from software now.

you might want to elaborate what you did to fix the torch on/off issue for others to see in case they have the same issue.

1 Like

Well, I think that I have two problems. 1. I know that my machine torch had an issue. It was wired for a different plasma cutter. With my handheld in place, it seems to work fine at the moment.

  1. I think there is an intermittent issue with the Crossfire. For example, sometimes when I manually fire the hand torch, I get continuity across the trigger terminals even when I’ve manually hit the torch stop button.

For now the manual torch seems to be working, but I haven’t moved any connectors, etc since I got it working.

Do you have your plasma cutter set to 2t cutting mode?

Now that’s it’s cutting, are you getting healthy voltage from your THC? Should be between 100 and 140 when cutting.

If you are not there’s a few things you can check. The most common cause of no/low live voltage is using a 3 prong charger on your laptop or using a PC with a 3 prong power plug.

If neither of those affect you, I recommend removing the electronics box from the leg of the machining and attempting a straight cut to see if you get proper voltage.

If neither of those work, then you’ll need to use a multimeter to measure the voltage going into the VIM and then going into the THC port from the VIM. The latter should be 2-3v when cutting and the former should be about 100-140v when cutting.

If all of your voltage out of your plasma is bad, it’s a wiring issue.

If the voltage out of your VIM is bad, it’s a VIM failure.

If both of those voltages are good, then 99% chance it’s a either a bad THC card or MCB.


I just got my Crossfire Pro in Sept,Just getting it going now. Right away,I found the Instructions for the table,showed the Control connections on the Razorweld with 50:1 on Left,and a piece of paper in with the machine showed it on the Right,Contacted Langmuir Support,they said connect as the tag in the cutter-pkg showed,not as the table-instructions showed,is this correct? I also have No Torch Firing,or THC. Checked the Relay,its tight,as is the board connection. On the THC-Board,the Green and Red lites are on,there is another Yellow light flickering,is this normal,or an indicator of an issue? We just updated FireControl last night as well. Everything else is up to date,as far as I know. Im going to run more diag on it tomr.Just trying to make sure these few things arent an issue.Thanks,Mike.

Real simple. unplug both connectors from front of cutter. Plug in one connector to either port on cutter and the other end of that connector to the torch on/off port on the control box. open firecontrol, enable manual torch fire and press the fire button. if it fires then good. if it doesn’t fire then unplug connector from cutter and plug it into the other port. if it fires then the other port is for the THC cable.

also, if you’re not getting a green thc enabled indicator in firecontrol, then unplug the control box from the computer, download the manual thc drivers and install them (doesn’t matter is it says for windows 7/8), reboot, connect control box to computer and open firecontrol and it should show green now.

1 Like

Im getting the Green light,also,there are 2-more lites on the Thc board(D1,D2) that flash together,quickly).Also has Red light,and another Red turns on/off when torch relay cycles When torch is manually triggered by the program,its showing voltage,but no fire at the torch(have tried different torch heights as well,just to see). Jumped Torch cable to control,like mfg specified,and it fired,Ive thinking the small control box is the issue,waiting on response from Langmuir.Thanks for the info/help.

Yeah don’t worry about what the lights on the control box are doing or anything to do with the THC… the first thing is figuring out why the torch doesn’t fire. so if it’s firing when you short out the barrel connector, it could be a loose relay…

Have you tried unplugging and re-installing the relay on the main board?

Does it click when you do a manual torch fire from firecontrol?


Checked relay,unplugged,replugged. Relay clicks when called from laptop. Langmuir sent me a list of tests to run,all passed,so im waiting for a response from them. My gut says the Small control box is the issue. They had me do tests on cutter,and main control box,all passed.

If you mean the small plastic VIM box for the THC, that has nothing to do with the torch firing. That only feeds cutting voltage to the control box for THC control.

NicaDd already gave you the probable solution. The Razorwelds have been known to have the torch firing and divided voltage ports switched (hence the conflicting tag and instructions).

If the relay is clicking and the torch fires by shorting the cable, the most likely problem is the cable is plugged into the wrong port. Switch the cables on the front of the plasma and try again. It won’t hurt anything to have them switched, it just won’t work if they are wrong.

Its also possible that you don’t have the cables hooked up correctly. I’ve seen some people that hooked the torch firing wire to the VIM box instead of to the control box where it says “torch on/off”.