[Solved] Baseplate surfacing issue

Hey guys,
having an issue surfacing my baseplate. im getting an alarm that the machine cant travel far enough, i double checked all of my switches and travel distances and have almost an inch over the entire program. Has anyone had this issue yet? im using the 3/8 Em program.

Update, No issues with the 1/2 inch Program. seems to work fine


@Jpersons44 we’ll check the 3/8" program on Monday…could be an error in the code; if so we’ll fix and reupload. Glad you were able to get the 1/2" program running!

Cool thanks guys i looked throught the G code and everything looks good! but i must be missing something, super stoked on my machine although i may be needing to sand some epoxy out :frowning:

When it’s covered in chips and coolant, you can hardly notice imperfections

You sure that got checked out? I tried doing the facing op tonight with the 3/8" post and it fails with a Machine Alarm that the G code motion target exceeds machine travel. Opened the 1/2" post and it runs fine from the same G54.

Well take a look, thanks!

We’re somewhat of a skeleton crew this week since many have taken the opportunity to enjoy some much needed time with family, etc. We’ve admittedly fallen a bit behind on tech support stuff. Back to normal next week!


Had this same problem, program worked after turning off soft limits. 3/8 program.

Was this ever addressed by Langmuir?
I tried running the 3/8 program today and got the same error. Don’t have a 1/2" collet so need this one to work!

@Drydoid I took a look at the 3/8" gcode and there’s a very small positive Y movement at the start of the code that is causing the issue for folks. This + movement is what throws the error because this program is ran from the machine zero position and no additional positive Y movements are allowed from machine zero. It works for some with soft-limits disabled since the movement is really small and isn’t enough to hit the limit switches in the +Y direction.

I’ve highlighted the code below that is causing the issue. It’s a simple fix, simply add a (-) symbol where shown with your favorite text editor of choice and it should run fine:

 (T1  D=0.375 CR=0 - ZMIN=0 - flat end mill)
 G90 G94

 S7500 M3
 G0 X0 Y0.0319  <--- add a "-" in front of this y coordinate (Y-0.0319)
 G1 Z0 F65
 G17 G2 X21.819 Y-0.3003 I0 J-0.1661

Hope that helps!

PS. Edited for clarity and grammar


Thanks so much for posting this!

did anyone try the code adjustment? I am about to do the facing for .375.

can always run the Z high and do a dry run but it should be fine.

@bestduckingfarm Did it work ok for you? Another tool I use for gcode sanity checks is

Gcode Viewer Simulator

Just copy and paste your code, or a section of it, into the window and get a quick simulation on the right. Works well for modifying Gcode to run from certain operations, etc.

1 Like

got an error when i tried to fix the program. has anybody had luck running the 3/8? i just ordered a 1/2 and will try that when it gets here.