PRO THC Not working

Setting up a new Pro. The THC during test only shows voltage sometimes. Sometimes it gives a error code. Also, during the test, the fire button in firecontrol doesn’t always work correctly, sometimes it tells the machine to fire sporadically. Finally freezing firecontrol and causing and needed reboot.

If I remove the THC module in the controller the machine runs flawlessly. I have went through the troubleshooting guide and done everything aside from attaching the raw leads. Voltage of about 1.5-2.0 at the divided ports and cables all the way to the controller …even to the white PCB inside.

any help here? Thanks.

I’m also having THC issues. I see voltage all the way to the control box but the THC module is reading 0.0v. I’ve called and send support requests for 4 days now with no response from Langmuir. Very disappointed. :frowning:

Did you figure anything out?

Have you gone through the THC trouble shooting flow chart?

What plasma unit do you have?

Are you using RAW or divided voltage?

Try switching the polarity? swap red for black on the THC.

@langmuirsystems @langmuir-daniel @langmuir-reilly

1 Like

RazorCUT 45 CNC purchased as “plug and play”.
There is no way of swapping polarity unless I do it within the LS control box. Maybe that is the issue seeing I had another manufacturing issue that I had to resolve.
First problem was wouldn’t fire. After taking it apart, I found out the ports were swapped from what the instructions and manual showed.
Do you have any pictures/schematics for how it “should” be wired?

If you have the razerweld from langmuir then it is unlikely polarity is a issue.

if the torch is firing then you likely have it right.

is the THC board seated correctly?

How far have you made it through the THC troubleshooting PDF?

It’s firing fine and I’m running it with just IHC. So at least I’m not dead in the water.

Yes. Lights blinking and everything. FireControl shows it connected and communicating.

All the way. Scoured for ANYTHING that might help. It’s reading torch speed fine. I’ve tried unseating and reseating, power cycling whole machine, waiting a day with power off and trying again, and more. I can read voltage in the wire that plugs into the port on the LS Control Box.

What should I be reading for resting voltage? Running voltage?

80-150v depending on your operation .

Where are you clamping the work clamp? on the material?

did you get to here on the chart?

what is your message during the THC test? can you screen shot it and post it.

My apologies. :disappointed: I have not yet seen this flowchart. I went through the sections on this page LS-THC User Guide | Langmuir Systems (with some interruptions). I had printed to PDF so didn’t see the link for another PDF (flowchart).
I’m going through this flowchart right now. Thank you for this and I’ll report back.

1 Like

Right on good luck.

Keep us posted so we can update this topic in case someone runs into this in the future.

Ok. So I got to here:

How do I test the voltage to make sure it is matching the VIM Box if I have the ground disconnected from the work piece and the power is unplugged from the Control Box. I can’t “fire” the torch. Stumped.


I notated three main speed bumps I faced during initial setup and run. Non were of my own or environmental but all due to poor info and poor QC.
(Speed bumps - Setup issues found (and fixed))

I initially had overcome my problem by identifying a bad THC module. Langmuir had sent a new one to replace the faulty one.

Fast forward to changing to a Miller 2050 with a custom X45 machine torch. I now am using Raw Voltage into the divider. Firecontrol is showing voltage on the THC portion of the software and shows good voltages during test. However, Firecontrol is not controlling the voltage. None of the lights for OK, UP, Down, etc. are illuminating, verifying that the control is seeing voltage, but not acting to control it.

Is the program you’re running have the THC option selected in post?

Has this machine ever worked with the torch height control?

What kind of voltage does it display during the THC test? Can you screenshot and post that test result?

I’m not familiar with the Miller 2050 but I’ll take a read through the manual.