Primeweld Cut60 will not cut on Crossfire Table (Solved)

I have a weird one, and it’s probably a mistake I made, but it hasn’t dawned on me yet, so I’m asking about it. My Cut60 will not cut on the plasma table. If I connect the ground to a piece of scrap on the floor the Cut60 cuts just fine. If I take that same scrap and set it on the plasma table the Cut60 no longer does anything when the trigger is pulled. The ground is still connected to the scrap in the same place. If I unplug the control unit for the plasma table from the wall, the Cut60 will work when the scrap is sitting on the plasma table. If I plug in the plasma table control unit, but don’t even turn it on, the Cut60 no longer works with the scrap sitting on the plasma table. I figure this is some kind of ground issue, but am not sure where to look next. The 220 socket for the Cut60 is wired to ground, but has no neutral wire. The socket for the control unit is a standard 110 outlet. The control wire between the control unit and the Cut60 is never connected in this scenario.

The Plasma table is a Longmuir Crossfire, an early one, as it uses a Mach3 Control unit.

So the scenario is:

WORKS-I have a Primeweld cut 60 which works when cutting on the floor (work clamp on material, manual trigger fire)

WORKS-When I place the same material on to the table with the Langmuir electronics OFF/unplugged and try to cut it it works ( work clamp on material, manual trigger fire)

NOT WORKIE-When I place the same material on to the table with the langmuir electronics OFF/plugged in and try to cut it does NOT work ( work clamp on material, manual trigger fire)

Yes that’s weird


Good, this 50 amp socket should have 2 legs of hot . L1 and L2 and a ground. neutral is not necessary.

your work clamp is not a ground in the same way as the ground for the 220v .

I am going to ponder this for awhile.

half a thought… somehow potential is lost across the relay when plugged in?.. but why.
is the “ground” material clamp of the plasma somehow tie to the ground of the workshop AC??

1 Like

…some more half baked thoughts:

  1. Do you have the table itself tied to earth ground? IT SHOULD NOT BE
  2. Is the control cabinet electrically ISOLATED from the table? IT SHOULD BE

Going back into my dark little corner to do some more thinking on this! :nerd_face: :crazy_face:

1 Like

…Searching back through my build notes, if the table is tied to earth potential, i had issues of torch failing to fire, or sometimes it will fire and not shut off. Isolating the table from ground (mounting my control box via delrin standoffs cured that bit of the problem). This leads me to think that your table / control cabinet are either tied together or somehow your table is at or near ground potential (remember the work clamp is at DC+ potential with respect to the torch), why the relay gets tripped up, is the “black-magic” part.
Please keep us informed on your progress.


The table, and I did not assemble this unit, seems to be flush with the leg. I bought it from someone who purchased and assembled it, but never used it, so it is “new”.


That is strange.

Check and see if you have a plastic spacer between the electronics box and the table leg.

I think the OG machines did not have this and it was added later? I think that is what @Cletus is referring to?

1 Like

There should be rubber grommets between the leg and the control box. I would think you could just take the box off the leg and test it again. you will need to remove the cover of the box to remove it from the leg.

Correct mine is an OG machine, came without any isolation between table and box. I added it after. Then I built my own controller (and THC) using a fiberglass enclosure, yada, yada.
Ok, so remove the box from being mounted to the table and rest it on some supporting stool or something, isolating it from the table and fire it up again.


Let me see if I can relate all of the weird behaviors this setup is exhibiting. Sometimes just touching the work piece starts the air flow but not the torch. I can see a small spark when it touches the work piece. That seems to have stopped now, after restarting the Cut60.
Worried about the ground issue, I disconnected the control box from the plasma table and set it beside the table. The Mach3 software began complaining with the error “RNR motion card not found”. After several reboots of the computer and control unit, it seemed to have stopped with the error. I connected the trigger wire and attempted a cut, control box still air gapped, and while the air started, no arc. No arc when I pull the trigger manually. I pulled the torch from the holder and try again, nothing but air. Restarted the Cut 60. Now I have arc and air when pulling the trigger, but it does not stop for several seconds after I release the trigger. I immediately check the switch, it’s on 2T.
I then try it several more times. After 2 more times, I think, the trigger starts working properly and the arc stops when I release the trigger. I try it several times and it works as expected each time, now. I put the torch back into the holder, reconnect the trigger wire, and, still air gapped with the control unit, I run the program (Scorpion.tap, included with Mach3 software). It moved a little and starts the arc, and just sits there. I hear relays switching in the Cut60 but the arc is still going. It just sits with pilot arc going until, I guess, it times out and the arc stops. The program on Mach3 software is stuck at line 5 of the program and Mach3 still thinks the torch is on (yellow bar blinking). I hit emergency stop/reset twice to stop the program and reset, and now the “RNR motion card not found” error is back.

All ideas welcome.

A few things that we should know to help us help you is. Original crossfire or pro? How do you have the Primeweld wired to the control box? Are you using a laptop? Is it plugged in/charging when your trying to cut? Did you check for continuity between the table and plasma cutter case, table and control box, plasma cutter and control box, etc? Are you sure the 240 volt receptacle is wired correctly?

Original Crossfire, and early generation, because it uses Mach3 control. I connect with a 2.1mm x 5.5mm DC power cord, plugged into sockets on both ends. The notebook was plugged into AC outlet when I attempted cutting today. I have not checked continuity between the plasma cutter and the table as they are 10ft away from each other. The control box is air gapped from the table now, per someone else’s suggestion. The Air-gap does allow the arc to start. When control box is bolted to the table, I get no arc, but I do get air. Yes, I am sure the 220 is wired correctly. Two legs and a ground, no neutral.
What else can I tell you? I have a video of the behavior, but don’t see any way to post it here.


If you’re up for it I’d like to add the information from your Primeweld to this list. Take a read of this post and see what you think.

1 Like

even if he has the older cutter, the original 2x2 didn’t have the problems that the Pro did with it.

1 Like

I will get my SN for you tomorrow. I can tell you the purchase date, through Amazon, was 9-5-2020.
I may have found some useful info, at least on the “RNR Motion Card Not Found” error. See this vid:

I am thinking this may fix that problem, as I was able to reset the USB on my notebook by unplugging and replugging the USB cable. That action has not always worked, sometimes a reboot was necessary, but it seem like the symptoms are pretty similar.


1 Like

Sometimes those USB ports get bad too. I have some on my laptop out in the shop that you have to hold your mouth the right way for the data signal to be a constant stream. Seems to sometimes be good power and corrupt data.

I can certainly try another port. I think this cheap little notebook has one on the other side.


I didn’t notice if you’ve isolated your system box yet or not. However, if you haven’t DO THAT before you mess around with other USB ports. If you are having a ground problem there’s no point in blowing out any other ports.

1 Like

The control box is air gapped from the table, as I mentioned above. The only electrical path between the control box and the plasma cutter is the trigger wire.


Did you put an ohm meter between the ground on the USB cable and the table? From what I gather you should not have continuity there.

I have not done that yet. I can do it this afternoon.