NOn profit for teen welding lab needs HELP! (solved)

Hey all. My name is Neil and I am the director of a smallish non profit that works with severely at risk teens. We recently bought the crossfire pro table as an addition to our welding program and thinks its going to be amazing. We have a teacher that knows hwo to design parts very well and infact we have a contract with a local company to actually make parts for them.

PROBLEM… none of us have any cnc experience. sort of. the main issue we are having atm is that we have a very simple part… an 8th inch thick square stainless steel plate with various holes to cut out of it.

the program looks great and we have had luck cutting it in 1/8 inch mild steel. but all of the sudden the program will not cut! it either fails to ignote the torch … or it lights and fails to move… it states each time that our pierce delay time is either to long… or to short.

I have set up many saved files with varying lengths of delay from zero to a full second with no luck. We have a the pro table with the razorweld 45 kit that comes from langmuir.

running 60 to 70psi clean dry air, at about 40 amps I believe.

We are at risk of losing our only customer if we cant get these cut this week. pls consider helping! I am open to emails, calls and even paying someone to help create the file!!

So you have been cutting the file successfully and now you are getting errors?

What do your consumables look like?


I know this sounds remedial but jut in case, is there an error light on your Plasma cutter? I had that happen the other day, Torch would not fire but I had unscrewed the nozzle and forgot to turn it off and it triggered an error which would not let the torch fire. I turned off the machine and back on again and error gone, hope you are this lucky.

1 Like

Where is the work clamp attached? To the table or directly to the work piece? Can you post pictures of your set up? Can you post a video of the cut failing? You will need to put it on youtube and provide the link.

1 Like

I think they look ok. They have only cut about 4 pieces of this part so far from new. I just replaced them after reading your response to test. I did a live test on the cutter to check the response and this is what I got…

PAss the first part of the test… fail this part… see picture

no error I can see

work clamp is on the work piece I will do a quick video now. and try and get it uploaded asap

Check the THC wire between the VIM and the control box. Has the wire been stepped on or pulled out? I have seen people talk about these getting broken. You are not getting a signal to the control box from the vim for voltage.

1 Like

How about if you turn off torch height control and see if it runs through the cut.

I do have a good amount of welding experience and some knowledge of using a plasma cutter. its the combination of the software I am not familiar with and the table doing the work that is messing with me. keep the suggestions coming!!

post a pic of the vim (little back box on the side of the plasma cutter)

1 Like

I will try that now as well. Forgot I could do that. How high should I set the torch?

I don’t think you’re drawing is the problem if it worked on mild steel. I think something else changed in the set up by accident. What are yoou using for a computer? If a laptop are you using it unplugged fro the charger while cutting?


As @ScottNH said check your connections at the VIM box and make sure they are plugged into the right location.

I would try .060 to test it to begin with. I’ll check back in an hour or so.

use a 1/16" shim to set the height

1 Like

Do you have a multimeter you can check continuity of your THC signal wires going into and coming out of the VIM

I am using a very good desk top pc that is about 10 ft from the table and 6 ft from the plasma cutter

I just shut the THC off and its CUTTING!!! so what causes that?

ok so with thc off its cutting how do I fix that issue? I would like to use THC if possible

video of it not working