No way to connect support real time [Solved]

just ignore most of what i said here i had just ruined a piece and spent a bunch of time trying to figure it out. not my best manners here. i apologize.

readers digest version. unit was totally hung would not respond. turning off limits solved that. axis hanging was getting caught on water table i think. for searches on this topic.

My machine is down and I have orders to ship and it seems you are not allowed to call support and can only send an email. Well I need a stepper motor and I don’t have time. Looking to upgrade and not sure if this type of support will work for me. What are the spec on the Y stepper motor. This is not a user problem this is defective hardware. Sure would be nice if there was a way to actually reach someone for support and get this ordered today. Bad timing for Langmuir as I am getting ready to upgrade to a larger table and this is a big strike against them. I can’t even order the unit until someone calls me back. meanwhile I am just sitting here waiting and have already lost another day. This sucks.

I am sure ls is like a lot of other places. Finding someone reliable to work is dang near impossible. If you need them in a hurry I believe you can source on Amazon you will just have to change the plug.

Is it the Y stepper motor from your issue last week.

I believe they are a NEMA 23 motor?

The XR comes with a phone in tech support line, The PRO and OG does not . This is by design and is built right into the pricing structure of these units so they can be cost effective.


If you have a 2x2 Crossfire, then the Y Stepper is driven to 4Amps (so you need something rated at least this - probably ~4.5Amps), and, as @TinWhisperer points out, it’s a NEMA 23 motor. You’ll have to tie into the existing motor cable at the Motor since the DB 9 Connector & Cable are not commonly available.


Yeah all the amazon ones seem to be raw ends
I did find a link for a NEMA 23 with different lengths of wire and a db9 connector pre installed.


Have you confirmed that it’s a bad stepper motor and not the driver?

Switch the X and Y connectors at the control box. If the Y motor works when connected to the X driver, the driver is bad.

1 Like

Thanks, I did just that. it still says Y error, the whole thing is unresponsive and the only indication is the red alarm on the bottom. i have tried two different computers as well.

I was assuming it was the stepper motor as I was having issues with it hanging and if I pushed it it would go. Maybe the driver then? No movement on any axis.

Aslo The motor on mine is considerably larger than that one.

I also guess I should have some spare parts on hand, I just wish they had recommended that but there are no spare parts listed on the site, might be a good idea on their part to have a “repair kit” to buy to have spares.

I’ve had my CrossFire since 2019 and haven’t needed a replacement part yet. What would you recommend?


No movement on any axis indicates a bad power supply.

There is a DC power supply inside the control box. It’s probably silver with a bunch of holes in the cover. It needs to be putting out 36v DC across the + and - DC output contacts.

Well I solved one of the problems. the unit was locked up, only error message was the red light on Y1. nothing would unlock it. tried two different computers. Then I went to the settings and disabled the limit switches. Boom, that unlocked it. there was not an error on the screen but one of the wires had come undone when I was looking at the stepper motor on my original problem. I also did reboots of the software but nothing would communicate until I turned off the limit switches, Probably a bug which is understandable. I did notice that Firecontrol seems to use Java, that may have something to do with it as well, is that correct? Don’t want to start a rumor.

So Firecontrol unresponsive, locked up, etc, try turning off limit switches then back on. for the search engine.

The table seems to work on the y axis for about two thirds of the travel, always hangs in the same spot, cleaned and oiled and cleaned and oiled , nothing binding. That was why I was on the stepper motor hunt, Still not 100" sure on which one to get. there are also different steps and many different degrees so probably need that as well. They are cheap enough to have a spare hanging around anyway. Im less freaked out now. Sorry.


Clean your rails and the bearings. I’ve had the y axis bind up from a small bit of something stuck and stopping a bearing from rolling over it.

I have done that countless times. not the problem.

Have you checked the motor plug connections? You could have a prong burnt. I bumped one of mine the other day and it would stall. It was one of the plugs loose.

@Gogo, this is a good idea. Since you are not getting an error it makes it difficult to pinpoint the issue.

I realize it is anecdotal, but I was having the X/Y travel abruptly interrupted, but in varying locations, based on trying different designs. On the same design, it would stop at the same location.
The problem: It was the Z-axis that was hanging up. When the torch was given the signal to either lift of descend, that is when the system would notice a problem and stop all movement. No error message was given.
The solution: A bit of lubrication on the z-axis and all was corrected.

And yes, disable the limit switches until you get this all working consistently.

This is another good idea to check. Wires and connectors do break so a continuity check and wiggle the connections to see if something is awry. You might also clean the contacts on the IHS/z-axis with an electronic cleaner spray.

Good luck to you. You seem to be going at this systematically.

Don’t ask how I know but if you wiggle the plugs. Make sure the power is off on the control box… unless you like the smell of hot plastic.:grimacing:


thanks again to all. yes i tried wiggling the plugs and seating them. nothing burned it discolored. it isn’t the bearings or a burr or anything on or around the rails. it stops on jogs as well within a few inches. . i have scrubbed the rail with copper wool and very fine steel wool. smooth as a baby’s bottom i flooded the bearings with light oil to flush anything g out. i have checked the support beam for square or twist. there is none. it’s gotta be the motor or driver. i can’t find anything else. i’ve have the machine for a year and have had few problems that were not solvable by myself or reading the forum. little issues with thc but got theses sorted on my own or with help here. this is by first big issue and i’m pretty sure i’m not the cause this time.

A stepper motor is not going to just STOP due to binding. It will chatter if it’s being driven. If you don’t hear anything from the motor, the problem is electrical or software.


oh it chatters like mad.