New thc problem after months of good running

I have been running my table nonstop, cutting several hours a day, four days a week without a hiccup.

I ordered and installed a new pt60p machine torch with the original torch mount that came with the table, and cut 700-800 pierces and an hour of torch time with no trouble. LS machine torch mount finally arrived yesterday so i installed that, and let sheetcam install its upgrade, and now my thc is suddenly going nuts. I broke my own rule and changed a few things in the same week. smdh.

watching the torch, i can see it touch off the metal, raise up, fire, and move down when it starts to travel.
in the middle of the cut, torch sometimes goes down and drags on the metal hard enough to move a 33x48 peice of 1/8 plate, sometimes raises up to where the torch looses arc.

sometimes when trying to restart a cut it fires, then tells me it has no voltage even though i see it fire… I move it to a different part of the line, sometimes it works, sometimes more no voltage errors.

I tryed doing the THC control tests in fire control, and sometimes I get a pass, and sometimes i get a fail.

I have checked:
changed tips 3 times trying both .9 and 1.0 tips
ground clamp is on the work, with clamp contacts cleaned. and cable looks undamaged.
cleaned IHS contacts on z axis
cutter mounted on wall above the table, has not been moved.
wires to THC look good, and appear to have good connection,
checked tool settings in sheetcam,
pierce hieght .125,
cut height .06,
86 ipm,
plung rate 50.9ipm,
kerf .045
pierce delay .08

same settings i have been using for months, except a lower speed for thicker steel.

I am trying to cut 1/8 plate with a program i have used many times on 14 gauge, but changed sheetcam tool settings for the thicker cut.

using primeweld cut60, .9 tips, 40 amps, 60psi.

at a loss for where to start. machine torch was working, so i don’t think the problem is there, and i don’t know how to go back to the previous version of sheetcam, without doing a restore point on the computer, and losing a bunch of art work i recently finished working on.

any ideas?

Are you using the CNC port for the THC or are you wired direct inside the plasma cutter? Are you charging the laptop when your trying to cut?

laptop is running on batt, not plugged in, also on a rubber isolator on the stand.
THC has been wired into the cnc port since i started running the table last november.

Check the wiring. If it is all ok you might want to take the cover off and wire it direct inside the plasma cutter for RAV.

ok, still testing.
went back in my cut files and found another peice to cut using old sheetcam settings for 14ga, and it cut fine. had to hit the speed down -10 in firecontrol to account for the 1/8 plate, but it worked. torch height did what its supposed to do.

took same dxf version of that file back into sheetcam and set it up with new tap file, saved as different name, using same settings as before, and i have a bunch of incomplete cuts like the torch head was moving up and down…

is there a way to remove the update that just installed in sheet cam???
I don’t know why, but that seems to be the common factor.

Post your program. its likely that either the THC commands have been left out, or the cutting feed rates are less than the program speed (in parentheses at the bottom).

Goose raling insert.tap (617.3 KB)

I admit, i know little to nothing about g-code.
sheetcam, and the awsome upgrades to firecontrol over the last 9 months have made it to where i really didn’t need to.

If this is the problem, how do i fix it, so i can start making new tap files that work again?

On complex equipment, ALWAYS change one thing at a time! :nerd_face:


totally agree. I knew this rule. and i broke it, now I am paying for it.

Business has been really good to me these first few months, and I was excited to start upgrading to make my life easier. now I am wishing I would have just started with the table drains.

Great to that business is good! bills get paid and toys a plenty! …same here :rofl:

I just reviewed your program and it looks fine. Its got the appropriate program speed and also has the THC commands in it correctly. I believe that the symptoms are coincidental to updating sheetcam.

Can you take a video of your firecontrol screen when the behavior is happening?

1 Like

Thank you for looking at this, still seems weird to me that an older tap file seemed to run ok, but
i will try to get video. i will have to nest up a new job in sheetcam and try again on some scrap metal later tonight.

Ok, it seems that trying to take a video of it, fixed it. SMDH. I now have 2 1/2 hours of video of the table doing exactly what it is supposed to do.

I have no idea of what was happening, or why it is not happening now, but I am relieved that I was able to get my orders cut last night so they can go out on time.

The only bad thing about this is, I did not get to learn anything.

I am happy that I was wrong about the sheetcam update, and I am glad it seems to be running smooth again. It is supposed to be really nice weather this weekend which means the markets will be busy, and I will probably have a bunch of new orders to cut again next week.

Thank you, langmuir support for all your help AGAIN.
It is great doing business with a company that always has your back. If I can figure out a way to fit it in my shop, maybe next year I can get in line for the XR.


it is the same ghost that sits in your car…it makes a noise when you drive…and when you go to the mechanic…it leaves…

you did learn something…how to try and diagnose…how to trouble shoot…


Ok, problems are back.

During a run the torch starts to raise up in the middle of a cut, I look at the screen, my live voltage has dropped to 32ish and the arc goes out. On restart I see the acr light and watch it say 100 or so volts for a split second then faults out. Can not get it to restart.

I follow the guide and remove my box from the table leg even though I have the plastic isolators, and can finally get the torch to fire, but volts jumps around.

After all this I get video of it faulting out a couple of times and video of it not starting. But do not get video of the torch raising up during the cut.

I really need a path forward on this.

How do I upload a video to this thread? I took it with my phone but I don’t know what kind of file that is, and it says it is unsupported…

Also how do I loop langmuur systems back into this thread?

If you just manually move up your z-axis in fire control slowly all the way up and back down doesn’t move freely the entire time?

When your torch makes contact with material to trigger the IHS approximately how much travel is left on the z-axis all the way down (I know you can’t move it all the way down because the torch is bottomed out already but just eyeball what’s left between the bottom of the bearing and the frame is the axis)
And also do the same between the top bearing and the top frame of the z-axis how much room is left there?

Try to clamp your torch in at a slightly different.

Are you manually entering your voltage or using smartvoltage?

1 Like

I am using smart voltage,
Torch moves up and down freely.

When torch is touching workpiece the nut is about halfway down the z screw, when torch is all the way up, there is 1 3/4" between the tip and the workpiece. Ill try adjusting the torch holder a little higher up, so the torch can raise a bit more, but it has been set like it is and working great for months… not sure how that affects z axis raising in the middle of a cut, or causes torch to go out with a no or low voltage detected warning, but at this point i will try anything.

I had an issue once when my z-axis was dragging a little bit and sticking .it caused my torch height to do weird rising effects.

1 Like

Might seem weird but check the VIM box for a burnt electrical odor around the ports. If it smells burnt, open it up to make sure the resistors on the DIV side weren’t fried…

1 Like

Moved torch holder, same issue.

Warning box says torch started to move before voltage was sensed.

Verified pierce delay is set to .8

Table has always run good between .6 and .8 but tried 8t again overriding the delay in fire control by +10 and no joy.

Turned off torch height control and she runs.

Thank you for the explanation. It’s good to know in the future.

Just got done doing more troubleshooting. Put the hand torch on the cutter and cut scraps on the bench just fine, so probably not the cutter, then I hooked cutter back up to the machine torch on the table and turned off the THC. Table ran good with no THC. Turned it back on and faulted out right away.

I might be missing something, but to me that tells me that it is probably something in the wires, or the little box that goes to the cnc port on the cutter. I keep checking all my plugs, and have no signs of corrosion or looseness, so I guess next step is figure out where the heck my voltmeter is.