LS-THC No Connection - SOLVED

Windows 10 PC. Yesterday I downloaded firecontrol. Plugged in as instructions, It updated drivers and such. Pictures show what I have . There is a double light toward the top of the board blinking yellow that I cant get a picture of where it shows up

Did you update the THC firmware?

There’s a sticky post here with instructions.

1 Like

Well James I was testing you. I guess i didnt, I read and read then PC went to crap and ordered a new one and forgot I guess. And Thank you again. I will check into that .

Looks like FireControl is not seeing your USB Serial device for THC.

Is this a new Windows 10 PC?
Is there a CH340 USB Serial device in your Device Manager?

You may have to manually install the driver for it even though it is Windows 10 (although this is something we haven’t seen before). Try the driver installation instructions listed for Windows 7/8 and the LS-THC driver on the Downloads page.

To be clear, if you are not seeing a possible connection in the dropdown or an attempted auto-connect (after 3 sec) then your device is not being recognized.

Its new . I received it yesterday. There is no drop down for the height control box. It said it sucessfully downloaded drivers.

When you go to Control Panel|Device Manager and click on the Ports entry do you see 2 serial ports defined (one with something like CH340)? Those are the THC connections.

1 Like

I will go out to the shop and get it and check. I appriciate all the help .From all of you.

We lifers have to stick together :slight_smile:

You’ll need the USB connected to the control box to have the serial ports show up in Device Manager.

2 Likes

ok. back out to the shop i go.

No just usb serial device com3

Are you using the supplied USB cable?

Can you take a screen shot of your device manager? It’s possible it could be showing up as a different device name. A better way to do this would be to take a look at the device manager with the THC board un-installed and then again with it re-installed to find what changed.

Yes the USB cable that came with it. Nothing left when i unplugged the USB I downloaded the 7-8 drivers, when i get to the part to go to where they are at, Wich was downloads, they are not there. The table jogs every direction. And THC goes up and down so Im thinking USB cable is ok.

looks like it’s not seeing the TCH. the USB2.0 in “other devices” above the PORTS section is probably it.

I think i had that same issue with mine. i believe I did what Danny said and took out the THC module (with everything turned off and unplugged) then plugged in the usb cable to laptop and controller and heard the ding. Then unplugged the USB cable again, re-installed the THC module, then re-attached the USB cable on both ends and you should here a few dings or notifications stating if found a new port.

If that doesn’t work, try another cable. you don’t need to power up the whole control box, you’ll get power to the control board via the USB cable from the laptop.

2 Likes

When i unplug the USB cable shouldnt it go away if its the THC? And thanks for the info that may be it, I dont know but will try it.

i would think it should have gone away. Since it’s a new laptop, have you downloaded all the current windows 10 updates? could be that it just needs the latest updates as well.

1 Like

Yes I did the updates yesterday. I think beens im off work tomorrow i will delete firecontrol and start over. Thanks for helping me try to figure it out.

I believe that’s correct. I had the same thing happen to me. I tried updating the driver, using MS to update the driver, rebooted the laptop several times, etc. I think it fixed when I did some combination of plugging the USB in either with or without the control box turned on & with or without FireControl on. I don’t recall which but after a half hour of futzing around it cleared up.

A systematic approach of testing the combinations of the order of connecting the USB and control box power & FireControl status should narrow it down. I think it’s only 8 combinations but I can’t test it myself because mine is now working.

:man_shrugging:

2 Likes

@jimt At this point I would recommend downloading/unzipping the manual driver and following the on-screen installation prompts: https://assets.langmuirsystems.com/firecontrol/drivers/LS-THC_Driver_V3.4.zip

Also, that USB2.0-Serial is likely your THC device. If the above method doesn’t work, can you right click this item in Device Manager and click Properties. Then click the Details tab and set the property in the Drop-Down to Hardware IDs and please post a screenshot of what you get for this. This will help us determine if your THC unit is malfunctioning so that we can send you a new one or if it’s still a driver issue.

Thanks!

1 Like

Lastnight unplugging th USB didnt change anything, today it removes adds the USB2.0 I downloaded the manual driver, Followed onscreen promps to the Driver ( I did unzip it) when i get to it in the instructions it does nothing. This is my first windows 10 PC. Its somewhat different than im used to. And my head hurts from this.