Losing Arc voltage issue all of a sudden (over night) solved!

SO Pro has been running perfect for last month, I try to cut something every other day after work.

Last week I cut a 10 x 36 yard sign for a customer no issue turned out great. Next night same routine went to cut a 24 x 36 turtle, it moved to start point and pierced and 3 seconds later lost arc, tried a few more times and same scenario.

Over the course of last few days, swapped computers since fire control wouldn’t open due apparently to an out of date version of windows.

Got computer swapped and messed with it for a few hours last night, I have tried a bunch of things and no luck.

changed consumables out

Razorweld 45 @ 35 amps–>proven

115 # at compressor and 70/75 at plasma–>proven

.2 pierce have used for weeks on 14 ga–>proven

4 proven .taps tried out–same results about 3 seconds of program run = lost arc voltage

3 different materials = no change

BUT I recorded 2 last night, and reviewed this morning

last nights video
I know crappy video.

Notice THC says connected, but none of the 4 buttons are lit, and voltage seems weird and smart just says smart, never noticed start button flash before either and it moved down touched off, moved up and pierced, so what is my next step? This happened literally over night

Thanks and mods move this were appropriate


I cut mainly 14 gauge and use a .5 pierce. Seems too short to be at .2 . Also check your retaining cap. They need to be snug NOT tight. I notice whenever I get the voltage issue it is mostly caused by my cap being too tight. Also check and make sure the contact pins for the retaining cap are clean

Solved!!! 99.99% sure,

Will update with videos and need to get with LS for a part…may be morning

So notice 1st video was showing 12/14V while cutting? Thats not good.
1st vid

Well decided to check out setup tonight, 1st thing the whole continuity between ground…nope.
Next I noticed resting V was 12/14, like when I tried to cut…:thinking:
So, I unhooked everything and saw a change???
2nd vid

So I began to wiggle unhook etc



I put a hook on the wire and pc of weight on it to get it to read zero V, and said … let’s do this!!
ooops…too small of material material was 1/2 inch short so it lost arc, oops

So grabbed a bigger pc of material…

Changed material and walla


So I need a new cable…

Maybe I missed something! Which cable?

oops, may not of hit “save” on the edit.

The 50:1 divider cable is ultra loose, I posted video of it moving and changing V reading.

“Next” video

Everything seems to work video wise on my phone…

New cable on the way! Thanks LS :us: :beer: :hamburger: