FireControl not connecting to Mac

Im on a MacBook with the latest big sir os, just updated today and when I launch fire control the application does not connect to the brand new crossfire 2x2. I can see that the Mac sees the connection. I’ve done all the usual restarts, unplug and plug both power and usb a few times. any advice?

I read there was a issue with macOS and the latest version of firecontrol, there was another post recently, I don’t believe they got it working.

1 Like

I got it working with an older (different partition i had luckily) OS X, high sierra. Apparently Apple doesn’t like that FireControl wants to capture and send back information about the user including “keystrokes” used on their machine. I opted out of that and FC wouldn’t connect to the table. Mac could see it and it was def communicating on the mac side but would not connect through FC. Could be another issue which I’m not aware of but thats the best that i can decipher. Still a bit strange that FC was asking for this persimmon. I know, as a software developer that asking clients/customers for permission is a norm but there was no opt in/opt out from FC just apple letting me know.

Hey is anyone still reading this? I just got my table and trying to connect. I just bought a MacBook just for this! I did see that warning about the keystrokes. I “think” I just closed it but no matter what I try I can not connect to the table. Any help would be greatly appreciated, thanks joe

I use my MacBook Pro with Big Sur 11.6 on it as a backup for my Windows laptop and have no problems connecting but it is an older model. No drivers need to be installed. I usually power up the table before plugging in the USB connector. Any more info you can give about your set up?

Oh and I did accept the initial security allowances. Can’t remember what they were but that might be it.

Also it did say in the Langmuir Firecontrol docs when I first set up my laptop that Big Sur was not supported but I figured what the heck and tried it anyway. Has worked fine for me.

You might want to try installing the new Beta Release of Firecontrol and see if that connects

FireControl 21.1 Beta Release

Thanks bob! My MacBook is running Big Sur also.
Do you know anything about the pop up about fire control wanting to follow keystrokes on any app? I closed it because I’m not giving permission to follow my keystrokes on any app. I’m not super techy but that don’t sound right. Is this my problem? I will download the new Mac download you posted.

I just tried my toshiba laptop running windows 10 and still can’t connect to the table. Do I need to download the drivers too? It looked like for windows 8 and earlier. I have read everything I can find, uninstalled, re installed…but nothing helps.

Not sure. That could be the problem. Just checked and it looks like in the 21.1 version it doesn’t need to monitor keyboard input.

You may have to download the drivers for your W10 laptop. I run W10 and the drivers didn’t install as they should have so did the manual driver install and everything was fine after that.

Thank you I will try that in the morning and see what happens.

Same here… Go for it Joe… She runs like a top now!!

:+1: Let us know how it works out for you.

Hey bob nothing worked! I sent a message to the guys/gals at the help desk and waiting for an answer.

Hello Bill, what did you need to do to get them installed correctly?

Sorry to hear that. Yep. Definitely a good call if downloading and installing the Win drivers didn’t help either. Support is usually pretty quick to answer and super helpful. The other thing might be hardware - USB related ( Probably cable since you can’t get it to connect to either laptop).

Let me know what you find out.

:+1: thanks I will

Hey Joe… I just went through the steps as listed on the downloads page and all was well… Bob may be on to something with the thought about the USB…! Hope it works out soon!! Please do let us know…

1 Like

thanks Bill my Toshiba laptop will not connect. the program will open but it is SOOOOO slow. so I’m going to concentrate on getting the new MacBook hooked up. I still have not heard back from the help desk.

Bob can explain what you said about, “MacBook Pro with Big Sur 11.6 on it as a backup for my Windows laptop”
I have never heard of this! so are you using the MacBook to connect to the table?

I did install the drivers in the Toshiba and still nothing, the FC did open but it is SOOOO slow that laptop is not going to work so my only option is the new MacBook.

I wonder if I can try another cord I have here from the table control box to the MacBook. the only thing is it does not 2 of those round filter things, it only has 1!

as you can tell I’m not to tech savvy :rofl:

any thoughts? thanks Joe

Sure thing!

I have FireControl on both my MacBook and my Windows laptop but I keep the Windows laptop out in the shop connected to my table for regular day to day use and use my MacBook with the table when I do Windows updates but still want to do some cutting. The Windows laptop is one I got from my son so I don’t mind keeping it in the shop and I only have sheetcam and Firecontrol on it. The MacBook is my day to day use laptop.

I would say if you have a spare USB cable (A/B printer cable style) give it a try. Doesn’t have to be exactly the same. It’s not going to hurt anything. I actually use a 15 foot USB cable because I have my laptop over by my workbench and I’m pretty sure it doesn’t have any filters on it but works fine.

Are you getting a green light on the control box like the one in the pic I’ve attached?

You may not be tech savvy right now, but you will be soon :grinning: :+1:

I get it now!

Yes I’m getting all the lights to light up. Even the two inside the control box.

I do have a printer usb cord I will try tomorrow.

I did hear back from the help desk and they said I needed to use the windows laptop because their is an issue with the new macs!

I have an old iMac running high seria and I’m going to take it out and try it too!

You don’t use fusion! Is sheet cam easier?

My wife is the one trying to figure all this out for me, it’s a case of “old dog new tricks”

Thanks, joe

For sure give your older iMac a try Joe. Doesn’t hurt to try all options. :grinning:

I use Fusion for drawing any dimensional parts I want to cut and for drawing any “arty” stuff I use inkscape and Affinity Designer but for setting up the cut paths and post processing I didn’t really like Fusion so switched to Sheetcam on Windows for that.

So what I do is draw my stuff with my Mac and then transfer the files and do the post processing and run Fire control on the Windows box.

I’m a retired IT guy so I have all my files networked and accessible to both my Mac and Windows machines but I can also just transfer the files with a USB key if needed.

1 Like