FireControl Major issues- SOLVED

Just set up the Pro table, its my 3rd table but first pro. Firecontrol is all the sudden just freezing, won’t load file. My Z axis was going nuts, was stuck on UP and wouldn’t stop, had to shut down power. My joggin if it even worked at all was on super delay. So having major major issues with the whole program.
I run windows 10 on a laptop, I use mach 3 constantly with no issues. So I don’t see it really being the laptop. I was able to load one file and run a test with no torch and it went fine, once i reloaded the program (bc firecontrol doesn’t seem to restart the program like mach 3 does once it finishes) right after that the program just crashed. I restarted it like 4 times, no avail. Gave up. I just downloaded it and I just downloaded the THC driver (I had THC connected and linked up). But made zero cuts so far. Today was a complete nightmare using this already. That is why I still have my other table setup, had a feeling I’d have alot of issues with this unfortunately that is already the case.

Did you try deleting the .firecontrol file?

are you saying firecontrol doesn’t open at all or just doesn’t load a tap file? If it’s not opening at all the follow the thread above. if it’s not loading a tap file then make sure you’re using the right post processor for fusion or sheetcam.

It opens but now won’t really control the machine, its on super delay and also the z axis went crazy and just kept trying to go up and was stuck trying to move up just humming on the motor. I had to turn the pwr off. When I go to load tap file now it just says “Validating Program Please Wait” and just sits there froze. So I close the program reopen it and it will open the program but now won’t load files. It worked fine at first, I had it setup joggin machine then was able to run one program as a test run. After that its all a mess. I’ll try uninstalling program and restarting cpu.

do you have the latest versions of firecontrol and TCH installed?

Hi there, can you tell me which version of FireControl and THC firmware you have installed? I strongly recommend updating to FireControl 20.4 and THC v1.09 if not already done.

Your machine may have been one of the last ones to not get the L1 inductor repair on the motion control board. Here is a link to the process: FIX: Interference From Plasma Cutter Freezing FireControl. If this isn’t already done I strongly recommend doing this as well.

Are you using the appropriate post processor from our downloads page?

Lastly, it would be great to see a video of these issues so we can see exactly what’s going on.


Yes 20.4 version and the THC folder says V3.4 ( I just got DL these the other day). Yes using the appropriate Sheetcam bc without it Firecontrol won’t even open up my old files. So… now I gotta reprogram boat loads of files! I’ll be trying this tomo and I’ll get some footage.

I use my crossfire for cutting about 12-18hrs a week at my one shop, then I fab and run the rest of my business 6-7 days a week. My time is beyond scarce. Not to mention my material is very critical to my order stream, so if some gets messed up it throws off my orders. that is why I been so hesitant to go with the THC. I know it will be worth it in the long run and I gotta get through some hickups. I have over 2 months worth of orders so my time is just slim. thanks for the input guys. The forum is a great customer service tool. there is alot I really appreciate this brand, that is why I ultimately gave them another go on my 3rd machine.

Yes I can definitely appreciate the scarcity of time. I recommend doing two things right off the bat. One, check to make sure your motion control board has the L1 inductor mod

Two, turn off THC until you have verified everything else is working. Only once the machine is cutting well without the THC should you turn it on, that way you can isolate issues if they exist.

1 Like

How will I know if I need to make the L1 mod by looking at the board? Or what do the revised boards look like? I’m going to my shop today and will open it up. Its hard for me to trouble shoot bc my shop is miles from home and I have no internet there.

I was dry running the file, I didn’t hook up the plasma but yet I still had the THC indicator as on. I will just disconnect it and eliminate that variable for now. I think my biggest issue is just getting firecontrol to open and load a file. Also during the test run I did get that arc signal lost error 2 times, I just thought it was bc I didn’t actually have the plasma turned on.

Correct me if Im wrong. The program run speed only shows up in Firecontrol under the THC tab? But if you turn off TCH then how do you see what speed the program is running at?

Also I really wish you can load a file without the control box plugged in. I was not able to do that as I wanted to see at home if I could open Firecontrol and load a file without it freezing.

If you try to use the forum search it’s actually pretty helpful, and there are also the most common issues stickied to the top of this forum. Here it is to save you time:

There is a picture guide, and man crafting also has a video if you scroll down or search YouTube. That would only be necessary if you have to do the rework yourself.

Yes you must have the plasma cutter on and wired for THC during program execution. Otherwise FireControl will throw an error every time since it is looking for a voltage that isn’t there. I recommend toggling off THC to dry run the program.

Fun Fact- we are rolling out 20.5 here shortly and it has a dry run mode that allows you to test your program without firing the torch or making any Z moves including IHS.


Thanks all. Ok some pros and cons today. My machine does have the L1 soldered already!

I opened up my laptop, opened up Firecontrol, turned off THC, jogged everything just fine.
Then hooked up the Plasma and ran my test sheet which is 12x24 and has about 100 pierces. Normal
program run time was about 9 minutes or so. 1/8" steel at 160 IPM. I was able to run this and cut pretty ok two times in a row.

Here is where problem occurred today. After I cut two files with virtually no issue, I waited a few minutes bc I was checking on my lead screws. Jogged the machine over to the other half of table zeroed it out, ran the same file again and it froze on the first cut. So I had to close Firecontrol, reopen it. It didn’t quite line back up so I kinda messed up a piece, but was able to run it with no issues.

So overall Im happy I got some cuts in but man this is frustrating and not very professional, atleast for me. Having the program completely freeze without even running THC is not building my confidence.
I also get misfires on my HYP xp 65 on the regular, so I had two today and I couldnt figure out how to “run from here” mode. Here are my pros and cons.

Pros, really like alot of the Firecontrol layout, the memorizing exactly where you were at when program closes, Love the joggin features, the viewer is pretty nice, the color changing on viewer when parts are cut, and most of all I love how you can change the pierce delay, for me that is a big deal bc I deal with all diff thickness metals and that really saves time on going back and editing a bunch of files bc the PD needs adjusted.

My Cons would be the inconsistency in the program aka the freezing. I have windows ten and my HP laptop is about 3-4 yrs old. Never have a problem with sheetcam. I really do not like not being able to load a program when the control box isn’t plugged in. Also I accidentally unplugged the cord today and it shuts the whole file down. I don’t like not seeing the speed for me that is huge, I can see it when THC tab is open but not when its off. It seems a bit harder to locate the last cut and run from here mode vs sheetcam, hopefully it has that feature and I’m just missing it.

The IHC is pretty nice, I can see where it helps with my dross already. Also I was rather impressed with my cut times, I feared having the Z axis would add time to my runs, but it actually seems to have sped up a tiny bit.

For what it’s worth I only have issues with fire control freaking out after my computer goes to the lock screen and I have to unlock it. When that happens I have a similar issue of sporadic jogging problems or it running until it crashed into a gantry.

I just close and reopen fire control when my computer times out. A little frustrating, but at least it’s an easy fix. Once I have a dedicated computer for it I’ll just set it to never lock.

Thanks for the reply. Yeah really hoping I can get some consistency when I finally convert fully over to it. Im still running my XL bc I have no time to waste right now. Plus Im plumbing a whole new air system for the Pro and getting a dedicated mini computer for it. So we’ll see how well it holds up. Im sure at some point they’ll get some patches updated for it to work better. That is one of the biggest reasons I didn’t order this from day one. I just don’t have time to waste material or hours with all the variables. I really like the company and figured I’d give them a shot again, I just personally feel like this whole setup should have been tested for a lot longer with quite a few people. For the price I get it, hard to complain, but I use this machine for my sole living, so its not like I use it once a week. I need consistency. The new windows IMO just suck so I’m sure that isn’t helping. I couldn’t imagine taking on this task they are, all the proprietary things is just amazing, but… still quirks from what Im seeing on here.

I would be suspicious of the USB cable or the USB port. The only time my machine ever freezes is if I have a bad connection on USB, or my work clamp is too close to my computer wiring… I’ve had new USB cables that were bad right out of the package…

1 Like

Well I actually just started ordering all new cables. I’m compiling a list and will post. I just got a 15ft usb cable ordered up too. Im extremely busy with work so I have little time to mess with this. Plus I have to move a bunch of stuff and reorganize or else I have to move my plasma over and hook it all up just to test it, then unhook everything and move it back to my other table. So… I would like to just use my 45 amp plasma on the pro just to test things, but… I have to reprogram everything so Im just gonna wait bc all my new files will be for the 65 amp. I’ll use my 45 amp for my XL table and run two setups. The first day I tried it and the program froze then wouldn’t reopen a file for its life, I gave up. Second day got it to open up the same file, ran two cut runs and on the 3 run it froze on the first cut. My laptop never goes on standby and everything was within a good distance from each other. I also have the L1 connector soldered and I wasn’t running THC. So… I just need some more reps to see what could be the issue. As of right now, I’m leaning on the software or a combo of it and my laptop. I however have zero issues with mach 3 and I run it alot. I will def make sure all my wires are snug next time I’m at it.

If that freezing problem happens again can you try to replicate it and video it? That’s the best way to capture what’s going on. We don’t see the freezing issue any more since introducing the L1 fix so I am curious to know if this is something else. If you are able to get lucky and get it on video please send me a PM and we can go from there.

Just a thought but are you using the USB cable that was supplied with your PRO?

Daniel, yes using supplied cables with the Pro right now. Once I get longer cables and can set up everything up a little better, I’ll start making some more runs with it. I wish I could just convert fully to it right now but time is scarce and I have tons of files to recreate. In the meantime Im getting a dedicated pc and touchscreen for it, running dedicated air line etc. I will film some runs. I did film it during my first successful cut run, without THC though.

Question I tried hooking up the THC cables and unit to my plasma and was hoping it would still be able to fire the torch without THC turned on in FC. That wasn’t the case for me, is that correct? So I had to use my other cable from the CR which hooks into my port on back of plasma.

You can and should definitely be able to fire the torch without the THC toggled on or even installed.

Some positives to post. Ran a few projects saturday. THC worked fine, no program freezes. The only thing Im still getting use to is the Run from Here. In sheetcam its easy. In FC it seems as if you have to click the line you “think” it needs to be at, close program, reopen and then “scroll” all way down to that line and you’ll see the run from here icon. I had to do this quite a few times as I sometimes will have misfires. Now, on this large sheet with all the holes (welding table I’m building). I had 243 holes and no misfires. I also made a lead holder to hold the torch lead as I wanted to make it easier to unhook if I had to move it over to my other machine. I’ll be cutting a full production day Monday, which includes 7 sheets of 3/16 and 5 sheets of 1/8 and some 1/4". So baby steps, but overall positive progress.

1 Like