FireControl Freezing During Cutting & How to Fix it!

I don’t have the ferrite choke yet maybe Monday but if I held the laptop I was fine. If I left the laptop on the stand the USB would disconnect. I finished wiring the plasma cutter and hooking up the thc today. Everything worked awesome with default settings. I tried to make it fail with warped old skeletons. Never missed a beat! Wow!


Still experiencing this problem and I’m completely up to date with every “fix” and software/firmware updates that have been released so far. FireControl randomly freezes and torch relay gets stuck mid-cut on and I’m forced to pull the plug. I’m getting incredibly frustrated… I don’t even trust this machine enough to start cutting a sheet of parts for fear the software will freeze, which in turn loses my (0,0) settings and I’m screwed. Someone please help! @langmuir-mike @langmuir-daniel

(Current “fixes” I’ve done: Isolated USB Housing from electronics enclosure. Checked for continuity between board and case. Ferrite choke installed on USB cable. Work lead on opposite side of table from laptop/enclosure and laid in a non-coiled manner. Updated FireControl, Sheetcam post, and V1.08 THC firmware. Running Hypertherm 65 with machine torch.)

1 Like

Hi @golferguy17 we are sorry to hear about the freezing issue that you’re experiencing. We’ve only ever seen this happen when EMI causes FireControl to freeze and it’s possible that the one ferrite choke that you have isn’t enough given your setup. I’ve created a new order for you and we’re going to send you another choke to install on the computer side of the USB cable in the same way that you have the choke on the enclosure side.

In addition, just to make sure that it’s not a FireControl issue, we are releasing FireControl Version 20.3 on Monday and I am going to send you the install link hopefully as soon as tomorrow. The reason being is that this version of FireControl has a toggle for the visualizer to turn it off when running a program. This decreases the CPU usage by 70%. We’re not sure if your issue is freezing related or related to a program crashing issue so we want to attack the problem with the kitchen sink method so it doesn’t keep happening to you! My money is still on the ferrite chokes fixing your issue, however. We had a very noisy plasma cutter (AHP with some high frequency electronics) that would freeze even with one choke installed but after installing 3 chokes we were able to get it to cut so that is good news!

When you run FireContol and open task manager, what do you see for CPU usage?

Mine keeps freezing mine up as well. Won’t even let me close my computer. Had to turn it off and start up again.

1 Like

I’m running into this issue with a Hypertherm Powermax 600. I have the USB cable with the supplied choke, with two loops through it, installed. As soon as the torch fires the USB connection is lost. This happens if trying to use Firecontrol or the torch trigger. Using the manual torch fire in FireControl I had the torch stay stuck on, almost put a hole in the water table… anyway…
I have another CNC machine which uses USB, from day one I’ve always used a USB isolator between it and the PC. Mounted right next to the machine are two VFDs, which are known to be noisy. I’ve never had a problem, my machining runs are measured in hours (8 hours is typical).

All that to say I grabbed the USB isolator and used it and the problem was solved. Here is a short video showing the problem and the solution with the isolator. You can find the isolators on ebay/amazon for relatively cheap. Although the exact model I use no longer seems to be sold.

FWIW I measured the USB to table for continuity and found none, I also disconnected the VIM from the electronics enclosure, and the problem persisted.

On edit - Perhaps one reason this is showing up on the Hypertherm is that I’ve run the torch trigger wires out the same strain relief fitting as the raw arc lines that go to the VIM. Perhaps the trigger wires are picking up the noise and propagating it to the enclosure/USB. Might be worth documenting how others with this issue have their lines run/ or if they have factory CNC ports…

Here’s a link to one with US Stock, as most of the ones on ebay seem to be shipping from China, although it lacks a nice case
Manufacturer link
Another one with a case but more $$
Mouser has other options too, by most are around $100 and up.


@Greg9504 Thank you for this post it is super helpful! We are going to look into these USB isolators as a potential fix for customers where the issue persists even with the ferrite choke. Thanks again!


Great stuff. Thanks for sharing.

Does the isolator eliminate the need for the choke then?

They perform different tasks. To keep it simple, the isolator eliminates the path (ground loop) for the interference to travel on, the chokes reduce the amplitude of the interference. While you may have eliminated the path of one source, you can still have other sources, so it’s probably best to have them both. At least that’s my understanding, I’m not claiming to be an expert.

1 Like

Very cool.
I upgraded to a 16 foot USB and must have 4 ferrite chokes on each end. So far, so good!

I am still having this problem after installing a longer USB and ferrite choke. I thought I was past this as I have successfully cut several smaller 1’x2’ projects. Of course it freezes in the middle of a full sheet piece… here is the screen shot message that popped up.
The only way to get table to respond is to unplug isb to get torch to stop, then use task manager to shut down firecontrol so I can restart and try really hard to align up original zero axis point. GRRRRR!

We definetely don’t recommend using a longer USB cable. And be sure to have the Ferrite choke as close to the electronics side as possible with as many loops as possible.

i guess i was hoping you guys saw this thread…

I had an issue today were the machine froze in the beginning of a cut with the torch still on. I turned off the plasma, let it sit for about 30 secs, flipped it back on and the plasma immediately turned on. The machine did not move from the original spot it froze in. I thought it was gonna cut a hole in my water table.

I had to turn the plasma off, then turn off the eltronics on the table.

I will do some more investigating tomorrow when I have more time.

You can also yank the USB cable. I had that same problem and was able to stop torch firing.

What was your solution to fix?

I moved table a little farther from cutter and it has not recurred, but I’m waiting on new chokes. Apparently the Cut 60 is a known noisemaker.

i have my CUT60 on a welding cart next to the table. at first i had it right next to the control panel on the table and i was getting interference. all i had to do was move the cutter to the opposite side of the table and problems went away. using the choke as well.

I have seen a few videos where other people had problems and use the chokes some somehow they put three on one guy said he had to put three on to make it work three they were not
your sys ( other systems ) and had pictures I don’t know where I seen it if I see it again I’ll send you a picture or a video