FireControl 20.5 Now Available for Download!

Now my SheetCam license is screwed up because I changed computers and it wont post process. I have an email into Les for help and then I can send you the G code I have been getting. Thank you.

Holiday Truck Multi Piece V2.tap (248.2 KB)
Got the SheetCam working. I think this is how to send you the G code. Please let me know. Thank you.

So we don’t have internet out in the shop were the table is. I’ve updated to 20.5 but I don’t see a manual download for the 1.2ls for the motion control. Did I miss a message somewhere with the download info. I don’t want to update the post processor till motion is updated. Thanks

I clicked on about and this message box came up indicating a crash.
{“os”:“Microsoft Windows 10 build 19041”,“cpu”:“Intel® Core™2 Duo CPU E8400 @ 3.00GHz”,“pCpu”:“1”,“pCores”:“2”,“lCores”:“2”,“id”:“Intel64 Family 6 Model 23 Stepping 10”,“mArch”:“Penryn (Client) / Penryn (Server)”,“arch”:“64-bit”,“memAv”:“4.7 GiB”,“memT”:“7.8 GiB”,“disk”:“C:\”,“spaceAv”:“99.4 GiB”,“spaceT”:“148.0 GiB”,“javaVer”:“13.0.1-BellSoft+9”,“javaVend”:“BellSoft”,“stack”:“eNrNlU1z2jAQhs/tr/BkOJCLio0hQ24BAiFDJrRJeu0IebEV5JVHkk3or68tiGkSSHChnV48llbvs3pXX0zG5FGGNE6ITABDQYbjyycGieESz50bMJEMnJNQdDkG3XQ2A3XioDQOzSgXdCrg8ydqnJeIUPg5xp+yUZwUrY22vul+zAnnbsNzG6cWwfKZCIphnHJFGDISgJ4bmZCM65QK/hMU+V7+9ihmVJM0CaiBoehJIdWFUnRZfzPGJvI77QPSBFwnYifbbTZPt1RhOO4ruihKdAUiybFrSuG+/iZoSe2OV4W0i3Lmb7y+JNGFyWnXE4ogag+2eL/TVoG1K99v74VxG0Sl+Frd8ty9rHDM5ByG43eq4nqdZiXWLo7rn+3l6HY200wBYJeyOWBAAjmhHE1PxolEQPPKrNfotPYBk+Q9SqvdWbvMW8/b8kvReCJ6wTEk16V0Rao/4BzlAp07mSoGFdW9iItAAR5G+VitU3zWjnkYmQUU34GiMdSaxzByL8sFqwb6BlZ/Q5GG+SY5bCo/rHwUxxDw/FiJ5WGm/hnoo9PtbT3dzdaOaVg1ZEX6UX4cGS0ekkvbLu4Zali0nx8LssKvKaRQqm2XvS3+BFPzrZ2/IZ1SDSudBpYqbpbkgjHQuifRKClEcdXKieIZFxBCUIk0UdIAK2rZl3G+rLXrPHy3jq7S2Fc1kCPM73S9GlsmO0LJqyL6a/F9pIAGJEnj5BbBhgZSDbgopnkEqO3XJfKYxCsOiioWLY8G/V9A2zbyL9r0oyE\u003d”}

Please advise, thank you

We link the machine firmware update instructions here but hope that most people use the Firmware flashing within FireControl as there will be less human error due to mismatched ports.

Old files will still work with the new v1.2ls Machine Firmware as long as you are using FC20.5. FC will convert and save programs from Post Versions 1.5 to 1.6

2 Likes

Hi Joe,

Your program looks just fine and loads on our test computers here without any issue showing all lines in the visualizer.

Is this the only program that doesn’t load the visualizer? What OpenGL version is your computer running?

Thanks for checking it out, I swapped out computers and I think the desk top I tried to use was the problem. As for the misfires I just reread the tech bulletin about the capacitors, gonna have a tech buddy do the fix and see if that makes a difference, I have a strange feeling it will fix the problem.

1 Like

Maybe it has been discussed, but…
When doing a dry run in FC 20.5, should the IHS be functioning as if cutting? When I did a dry run, it stayed at whatever z position it was last at, and did not move up or down during the test run. (In which case, one should park the Z an inch above material, or it might drag).
When I ran the cut sequence, it operated as it should. I like the new features, and still has a little room for improvement… But, AWESOME JOB GUYS!

No IHS does not function during dry run. The reason is because you may want to dry run without having a sheet on the table. Or similarly if you do have a sheet on the table but want to make sure that the torch won’t run off the edges.

1 Like

would love to have the option for THC to be toggled on or off during dry run…this way dry run can be used to use a marker and pre-draw some of the patterns to be able to show clients the actual aize of stuff and to see for ourselves.

but again…love this table and the system for personal hobby use.

Dry run means that the plasma cutter is off which also means that the THC can’t function without an arc to measure. We’re you referring to IHS? If so, you can toggle off THC commands for any program so that you can do exactly what you are saying with a sharpie.

3 Likes

thanks…this old noob will give it a try.

PS. I truly do appreciate all the support your team provides and am having a great time with this new venture in life…keep up the good work

2 Likes

@langmuirsystems Is it possible to enable THC during straight cut code generated by Firecontrol? Maybe this should happen but I have it enabled in adiition to IHC but it does not work.

Your question about straight cut code seemed interesting so I tried it. I just recently setup my Pro table so the feature could have some use.
At 300 ipm for 2" the cut went too fast to see.
At 300 ipm for 4" I tried to watch the Active Light. I notice Torch Speed seemed off Program Speed.
At 100 ipm for 4" Torch Speed seemed close to 100 and the Active light for THC (Torch Hieght Control) definitely turned on for me.

I wonder if your cut is too short or too fast and Torch Speed does not meet the 85% of program value for THC to activate. I am just guessing but THC did work for me.

Great thanks for that, I will run another test, i was simply watching the z axis during the cut which was 1 meter long and it didn’t budge, normally it’s doing something. It was getting to the end of the cut and moving the steel slightly. I’ll run another test.

Ran my first part with the new update. Saved my butt. Was cutting out my first goblet firepit in 3/16. The total file was about 20 minutes of cutting… at the 15-minute mark my everlast 50s maxed out on duty cycle… So I gave it a few minutes to cool down backed up a few lines on the G code and it was within a couple of inches of where it cut off.

2 Likes

Anyone else having random complete freezing of FC? Second day in a row, today it was within less than an hour of having FC opened and running. Never had the issue with 20.4 and or on mach 3 even. I have had atleast 3 of these instances where the program freezes during a cut and I have to run off plasma, then force shutdown FC. Upon reopen it doesn’t save the zero coordinates.

Iv been using same laptop for almost 2 years. I do have laptop and the table plugged into the same power strip. I really don’t think its anything but the 20.5 update to be honest. I cut a ton of parts each week so not much changes on my end.

Just a heads up to the LS crew, Firecontrol does not launch under the new macOS 11 Big Sur release.

It does still function properly in Parallels (after updating Parallels for Big Sur).

1 Like

directioneast Yes, I have been having a terrible time with this version crashing. It will sometimes stall out in the middle of a cut and completely hang. I have also had hangs/crashes while validating a program and sometimes the torch wont fire when using the THC. Not impressed with this version at all. With as much sheet as I have wasted, I can’t afford to keep being a lab rat…

Yah I figured it was just the new version. Im running windows 10 but didn’t really have the problem with 20.4. Its definitely frustrating, that is why I started a thread on any professionals using the PRO. I make my living cutting and fabbing, so its definitely tuff dealing with. I waited a good six months or more bf getting the PRO bc I figured there would be some issues. Mine froze within 30 min of cutting last time. I normally shut FC down after about an hour just to be safe.