Everlast Raw Voltage Wiring- Still Not Working!

Mechanic is bang on

I have my 62i wired through the CNC port (pins 5 and 7). It seems to work fine, but I have not cut very much yet. My voltage on FireControl is in the close to 54 while cutting. I am hoping it keeps working.

it is not true divided voltage at 50:1…look for my posts for where I connected to get the true live voltage if you have problems…
but I wish you luck.

Mine seems to be working fine. I thought I have connected to line voltage (pins 5 and 7). I was just wondering if it is OK to have only 54 volts show up on fire control. Mechanic had said it should be over 100 volts. Is it a problem or should I just keep using it as it is at 54 volts?
Thanks for the help

I connect the pigtail cable to the pin 5 and 7 and and i fire up the plasma and have 147.5 volts after I connect the the bananas connector to the small electronic box and use and other pigtail and plug to the PV out plug and I juste have 1.2 volt less than 1.7 to 2.2 volts after I connect this wire to THC plug on
the table electronic unit .when I open Fire cut I do not see anything on the thc control like if nothing is connect . Beside that I connect the ou/off wire and the torch work . thanks for help !

I had a very similar issue and what I found is that you cannot count on pins 5 and 7 on the back of the cutter. I was taking voltage readings at those pins and would get incorrect readings. I talked with Everlast’s tech support and they thought it might be bad CNC board, but I replaced it and nothing changed. I eventually tapped into the red and black wires shown below. When I checked the voltage at these wires I had the proper voltage (around 110v). Since I tapped in to those wires everything has been working great.


I’m starting to get some wonky things happen with my THC and I am relatively sure it is related to going through the CNC port on my 52i. Any chance you could post some pics of how and where you tied in for your raw voltage?

1 Like

I went right to the torch terminals inside the machine…


Thanks. I was 99% sure; however, I did not want to put myself in a situation where I had to go to my Chief Financial Officer (read: Wife) and explain why I need a new plasma cutter.

1 Like

dude…I understand that completely…I did have to do that when I bought my “LAST” plasma machine for the new table…only to have this “deal” breakdown on me…and have to buy a new plasma unit…trying to persuade the CFO of another purchase is soooooooo not fun

Ahhh, just buy it, you know you want it, you can do it, just add to cart! :japanese_ogre:

Tnspeed, Just confirming your picture. I take the banana plugs provided from Langmuir and connect the red banana plug to the black wire on the control board and the black banana plug supplied by
Langmuir, and connect it to the red wire on the control board correct?

yes…pictures are accurate…

Yah, oh, no. I don’t think I will. You’ve never met my wife. Sorry, CFO.

1 Like

Finally after what seemed like taking the friggin plasma cutter apart 52 times I made some progress. First pic was attempt to tap into divided voltage wires before the Cnc connector and board. That didn’t work worth a damn. Followed Toolboy’s advice and went directly to torch lead and ground clamp connections. Voltage is reading 133volts during the test in fire control. Says “it passed”. I hope this is the last time I have to take this thing apart. I’d really love to finally cut something. image image image


Please clarify positive/red hook up to " work stud" ? Is that the work ground cable connection?

Yes it is.

I had to see for myself if I could get the THC working on my new crossfire gen 2 set- up with my Everlast 52i, with CNC port , tried the voltage divider thingy, no luck, then I tried the raw voltage pins with box, no luck so basically I wasted a good part of my day and since I sometimes a habit of working backwards I read the thread about the Everlast voltage problems, even called my Canadian supplier where they told me to use the pins 5 & 7 for raw voltage which was useless as it showed no voltage,
After reading Toolboys procedure I will spend some time tomorrow looking into that procedure.

However, I might prefer to tap in the raw voltage in the location Toolboy used while adding a current limiting fuse to prevent exposure of a possible high amperage voltage situation. I’ll start with a 10 amp fuse accessible on the outside of the case. Would anyone know from experience what the amperage draw might be in order to trigger the TSC ?

Tom - Model A ford guy

31fordguy…where in the great white north are you?

like I have said…the best place for raw voltage is right off the terminals inside the case…easy to do…
the langmuir thc box is designed to handle the full raw voltage…adding a fuse is just complicating the design and asking for problems.
myself and a friend are both running 62i machines tapped into the lugs for raw voltage…we are not having any problems…other than user error…hehehehe

1 Like

I’m in Cumberland where men are men and women are awfully glad of it !!!

I’ll wire it up tomorrow morning without the fuses, really anxious to get the THC working. had my torch working last week on just straight cuts using the gen 2 software, such nice cuts compared to freehand cuts I’ve been doing over the years with all the dross.

1 Like