Cuts not going through... grounding issue?

I am running an everlast 52i plasma cutter with their machine torch. I successfully cutter all morning and now loading up a new rusty sheet am having major grounding issues. It looks like when you forget to attach the ground clamp but isn’t shutting off like when you forget to attach the ground clamp.


  • wire brushed where it’s cutting
  • grinded top and bottom of where my clamp attaches to the sheet
  • attached new consumables.

I have no idea what’s the issues. I’m cutting 14 gauge with 37 amps and it isn’t going through. Literally an hour before hand it was working flawlessly so it has to be the rust no?

Any advice is greatly appreciated.


My original crossfire does this when the metal is warped or something is under it holding it up.I literally have to press down on the plate as it cuts sometimes.

Two thoughts:

  1. Air Supply - is it good or constricted in some way?
  2. Work Clamp wire corroded.

Plasma will cut through rust as long as the metal is well connected to the work clamp.


Do you have a torch height controller that is passed the initial setup testing?
What voltage are you running?
Are you manually entering a nominal voltage or using your smart voltage function?
Are you running the razor weld cut 45?

1 Like

Did you plug your laptop charger in to your laptop?

1 Like

Direct voltage on my thc and yes it passed setup just fine. Even a week or two ago I re-tested it just fine. 45 amps 120 ipm. I’ve tried messing with those settings. Running an everlast 52i.

I read somewhere that was a fix to unplug it. It was charging but even after I unplugged it little success

Ground clamp seems fine and I’m wondering if the air supply is somehow messed up coming through my machine torch… I had better success with my hand torch but still not good.

What are you running for dry air

Are you using smart voltage or are you writing in your own nominal voltage?

Smart voltage is not really designed to run at 14 gauge or lighter materials.

That is the reason I’m asking is cuz it can produce results like what you’re seeing.

What do you have written into your nominal voltage box?

Is it zero?which redirects to Smart voltage?

If your voltage is set incorrectly your torch height controller is going to try to do that which may result in it rising indefinitely off the material or rising to an odd height.

In your CAM post what have you set your torch height to?

Using the incorrect consumables for the application could also have a similar effect.

1 Like

I’m using direct voltage. It’s hooked right up to my terminals. I’ve only really cut 16 gauge with no issues. Now at 14 gauge crazy issues. I set my cut height to .05 in sheet cam.

I just tried 16 gauge and it worked fine… out the 14 on and it’s the same issue… it’s almost like a perfect tiny little weld bead underneath re-fusing together.

I’m so lost.

I use an Everlast 82i
14 ga at 45amp is way to fast. Don’t care what the chart says. Slowing it down to about 80 to 85 will work. Pierce delay @ .7
This works for me.


I agree it is very high! I’ve tried slowing it right down and it never seems to go through on this specific 14 gauge sheet.

It’s almost like it re-fuses underneath the steel… what ampredge do you use for 80-85 ipm.

45 amps at 120 ipm and 65 psi should work on 14 gauge, even if you were using a 1.1mm/60 amp tip. My guess it the torch is why to high off the metal. If you manually run the torch down does it touch the metal?

1 Like

Yes I can manually move it down, and ive had that idea too, I got my cut height set to .05 though.

Maybe my THC is acting up? I’ve tried to re-test it and it passes no problem.

Very lost at this point

I still think the torch is to far away from the metal.

Hey Tin I’m running the RW45 on 14G using smart voltage and having some random issues which I think are torch height related. Any clue on what voltage I should set it at instead of using smart voltage? Or how to determine the voltage I should be using?

Doing some straight line cuts and observing your live voltage during it is a good way to get an idea.

Or you could set your nominal voltage 20 to let the smart voltage take over and observe it while running the program and take some notes for later.

I know a lot of people have success with smart voltage on 14 gauge. In the torch height manual they used to have a asterisk that talked about not using smart voltage for less than 14 gauge.

I would guess your voltage will be 127? Ish there’s a lot of different variables that affect this.

The more information you can provide about this situation would be helpful.
I’m sure someone on here will be able to direct you to an answer.

What is the symptom of this random issue?

Any pictures of what the failed cuts look like?


Alright thanks for the voltage tips, I’ll run some tests.

As for the info on the situation I was going to toss together a full post this week with pics and stuff. But it’s basically just a random jaggedness (can run same program from same zero point and get jagged parts of cuts at different parts of the cut, it’s unpredictable and hard to purposely repeat), then I got an IHS alarm today in a cut, and last at random times in cuts the pierces wont fully go through until past the lead-in a bit almost like a pierce delay issue but the pierce delay works perfect on the majority of the piece I’m leaning towards the cut starting too high randomly.

Everything leads me to believe it’s a torch height/Z axis issue