CutControl Version 23.1.1 Beta Release! Includes RUN FROM LINE and MULTIPLE PROGRAM LOADING

Hi Everyone,

Thank you again for your patience as we’ve been developing the latest release of CutControl! While this version introduces numerous enhancements to the core software, we’re particularly thrilled about the integration of two new features: RUN FROM LINE and MULTIPLE PROGRAM LOADING. Below are brief descriptions of how these features can be utilized. In the upcoming days our support engineer, @langmuir-jake, will post tutorial videos explaining how to work with these new features. We are making this CutControl Version 23.1.1(beta-release) available for download here on the forum as a beta-release.

RUN FROM LINE Feature: This now enables users to select any line of g-code (or click on any line or arc in the program visualizer) and initiate the program from that specific line. When the start button is clicked on a truncated program, the software guides the user through a step-by-step wizard, handling the necessary actions and movements to activate the spindle and reposition it accurately for the cut to commence. This feature proves immensely useful for restarting a program from any point, especially useful in situations where complications, such as tool breakage, arise during a lengthy program.

MULTIPLE PROGRAM LOADING Feature: This allows users to load several programs into CutControl for execution. Programs can be rearranged in any desired order via drag and drop and are run sequentially. In this release, users will be prompted to manually initiate the next program, ensuring that any required manual tool changes can be accommodated between programs. Each program allows the user to individually toggle the visualizer on and off, displaying the tool path of each program. Moreover, once a program is completed, its tool path remains grayed out, making it straightforward to identify which programs have been run and which lines remain to be executed. The RUN FROM LINE feature is also supported within any loaded program of the multiple program loading interface.

While these new features might not seem super useful at face value, what we’ve really accomplished is laying the foundation for the upcoming release of CutControl (coming in weeks this time, not months!). This future version will feature a program auto-splitting feature, which will support multiple tools within a given setup. For instance, you can post various cutting operations for a given setup from your CAM software (even those involving multiple tool changes), and then upload them into CutControl. The software will automatically segment them into individual programs within the MULTIPLE PROGRAM LOADING feature. Users can then execute the entire program sequence in two modes: manual tool change or automatic tool change. In the manual tool change mode, the program will pause whenever a new tool number is detected, allowing the user to jog the machine, replace the tool, and set the tool length offset before proceeding to the next program. Conversely, in automatic mode, if users have one of our Automatic Tool Setters, the system, upon detecting a new tool number, will rapidly move to the SEND TO FRONT position and pause. Once the tool is replaced by the user, the software will perform an automatic tool setter operation and resume machining to the next program(s).

14 Likes

Looking forward to testing out this version and definitely the future build with auto tool touch off.

Working perfectly so far. No problems at all. Getting the b*#$s up to stop and start on a g code line tomorrow :tired_face:

2 Likes

Hi Jake-

Super excited about the beta release! I’m curious, did your team have any luck finding the source of the bug that causes the Z axis issues? What I’ve noticed is that sometimes, after probing z with the work probe and then calibrating the work probe to the tool setter (in this order, I’ve learned that’s critical), the Z-offset for the probe tip isn’t stored correctly resulting in a Z issue. Z can be higher or lower in this case. Hoping this bug is resolved because it can ruin the part.

1 Like

I am glad I am not the only one.

2 Likes

It’s worked perfectly so far. I must be lucky. Even with the 22.1 version, I never had a problem. I am waiting for the instruction video to get a handle on the new features. The run-from-line feature brings up a myriad of new screens to figure out. But it does work.

2 Likes

New version is fantastic. Everything seems to be working great besides one thing… My soft limits are triggering extra early. I’ve hit soft limits being a few times being .75 away from the limit switch. I reset all the soft limit distances and still having the same issue. I’ve had to turn them off running bigger parts as a work around for the time being.

Update… Trying to use the Run From Line feature and i get this error message every time i go through the prompts. I wonder if this has anything to do with my last post with the soft limits.

@FastFabPerformance Can you please PM your program and let me know the general Machine Coordinates for your XY zero position, as well as which line you are trying to perform the RUN FROM LINE operation (it looks like 20515 but just want to confirm).

And noted about the soft limits, we can try playing with this a little. The goal would be to have the machine stop such that given it’s current speed and distanced needed to decel it wouldn’t exceed the soft limit distance. But if this is trigger too soon that could be annoying as well. Thanks for feedback!

1 Like

Thanks, @langmuir-jake is going to work on reproducing this one. If you can PM him more specific instructions for how to replicate that would be great!

Same here, zero issues with the probe.

Thanks for the reply. I got it to work. I had to go back a little further. 20515 was mid plunge and the other ones that i tried were all contact points. I found a line that was a retraction and it worked perfectly. Soft limits are still bugging though.

1 Like

Which bug do you want more info on? The forum cant quote a post easily so not sure…

Hey I just finished running a bunch of test probe cycles using 23.1 and 22.1.1 and I wasn’t able to find the Z height bug. I have also heard from some owners that they have had the same issue on older versions. So the good news is that it hasn’t come up at all using 23.1 and if you’re still seeing the issue after the update, then it might be the probe itself. Feel free to PM me if you’re ever looking to do some more troubleshooting.

1 Like

I down loaded the Beta release, Do I need to update post processor? Multiple tool path still not working for me. Every op after the first one the visualizer shows it running the tool path but, coolant and spindle start up and the machine isn’t doing anything.

Thanks

this was my question too but wasnt sure where to go from here. does CC or the PP call for a tool change and put it up front to allow for it then cycle start?

I will try to reproduce it with the new version, but i just had it happen the other day. after using the probe and setting height, i put in the tool and use the auto tool setter, it seems that it doesnt save the new z offset. So the tool ends up being around an inch above the work. Doesnt always happen, but does mean i double check before doing any cutting.

You’ll still be able to use the same post processor with this latest CutControl update. This update adds a program running list rather than multiple tool programming so that might be why the visualizer is acting strangely. Feel free to DM me any more information you have or even a copy of your program and we can troubleshoot further.

To answer Animal’s question, this update puts multiple programs into a list so the first program would end as normal, then the next time you press start, the next program in the list would run. But the visualizer will update to show what all of the different programs will do to the part. So for now, you’ll still have to break up your programs into single tools. We’ll create some tutorial videos soon that show this process in detail.

Thanks guys.

2 Likes

@langmuir-jake

Last night I attempted to decrease the spindle rpm by depressing the -10% button and it decreased the feed rate by 10%, and I double-checked to make sure I wasn’t fat-fingering it. I then tried decreasing the spindle rpm by 1%, which worked as expected. Everything else, using v23.1, has worked as expected.

1 Like

I can confirm this behavior. I thought it was just me, happy it wasn’t. lol

1 Like