CutControl Feature Request Thread

Ahhh… okay… uploading to google drive then downloading it back to the mini pc via the internet. Got it… Thank you!

1 Like

Has anyone upgraded the mini pc on the MR-1 to Windows 11? I ask because I see that the upgrade is available on the windows update for the mini pc. I also ask, because it seems that the mini pc is missing a bunch of drivers which may have something to do with why I can’t connect/share with it on my network. Also, I just tried to use the SD card slot on the mini PC and nothing happens… :frowning: I haven’t installed chrome yet so I can’t access my google account. I’m going to try to email the file to myself and download it that way. #headache:frowning:

1 Like

CutControl works perfectly on windows 11. Sorry, I didn’t use the mini computer from Langmuir. The non upgradeable 4 mb ram and 64 hard drive was a major factor. I used a Beelink mini computer with 16 mb ram / 1tb
Hard drive. I know its overkill but it runs multiple programs without having a problem.


Didn’t buy the Langmuir PC but did that same as Bigdaddy and running CutControl on a mini PC with Windows 11 Pro. No issues with Windows.

1 Like

I assume you are talking about a routine to run a standard twist drill which would be awesome.

I’d also request to go a step further and have a widget to to do a hole feature via helical interpolation with an end mill.

Yes, twist drill. Thought about a boring operation as well but typically that’s getting a bit more involved.

1 Like

Pretty sure I discovered a couple more bugs in Cut Control V22.1.0 yesterday.

When switching programs due to a tool change. I ran auto toolset in both g54 and g55 because I was running two parts at once. One pressing the Alt R shortcut to start the program cut control would alarm out indication the program would exceed the travel limits of the machine even though I have ran this program 12 previous times and it is nowhere near the travel limit of the machine.

When I cleared this alarm the machine would then not respond to any jog moves or other commands and I would have to disconnect/reconnect my computer, rehome the machine, and then run the program without issue. This last part with clearing alarms is a bug thats already been mentioned prior.

While running this same program, on the second thread milling operation spring pass, halfway through the toolpath cut control shut the machine down indicating “hard limit triggered, machine position likely lost.” Again the machine was nowhere near the hard limits of the machine. I checked all my limit switch connections and they all checked out fine, no visible coolant in the connectors that could have caused a short or anything.
I reset the alarm and attempted to manually jog the machine out of the cut but despite being as careful as I could this ended up breaking one of the cutting flutes off my thread mill which was a bit annoying. 85$ tool rendered useless by a software bug. I get broken tools will happen but still irritating.

I just wanted to throw these out here so if anyone else has experienced a similar issue @langmuirsystems can be made aware of it and hopefully have it fixed in the next cut control version. Im also curious if there is an expected release date of a new version of cut control yet?


Also ran into some bugs over the weekend. The machine ran great on the top side of the part I was making and then when I flipped it over I started running into problems after trying to do a bore probing routine.

I kept getting the “travel limit will be exceeded” error which would then freeze everything. I got around this by turning off my limits for the bore probing. That worked but then when I went to turn on my limit switches, despite pressing “save” it wouldn’t save the settings and would just keep them off. I got around this by turning on the limits, turning off the soft limits, saving, then re-opening the settings and enabling soft limits.

After finally getting the “right combo of clicks” figured out, I calibrated the tool height, loaded up a tool, hit auto toolset aaaaand it was at the wrong height. Thankfully I checked before running the toolpath because it would have crashed into the vice since z was about a 1/8" too low. I tried re-calibrating a number of times and after calibration, it would still be correct, but as soon as I would load up a tool, it would be wrong. I never did get that one figure out this weekend. After trying for a few hours I called it a night and went inside before I got too frustrated lol.

Not trying to be all complaints here though. Running the machine on the top side of the part was very cool and I can’t wait to run it more, machine seems to be pretty killer


Tool Setter routines: I’d LOVE to see a Z+ move first before making X/Y moves. Always gives me pause when I launch the routine and the Z doesn’t move upward first.


We will look into this. It’s possible the bore probing routines are exceeding the soft limit settings.

Easiest work-around for this for now is to keep limit switches enabled but disable just soft limits. Should work fine after doing that.


This is more advanced but screw pitch compensation as a Grid for compensation by say 3" section rather than by axis would be something cool to see. Would be awesome to do this with the probe but maybe not enough accuracy there.

Also does cut control zero/ home from limit switching on or switching on then backing off the limit?

What about adding a backlash compensation for the 3 axis? I used to be able to adjust that in Mach3 and was very useful when you could not dial the backlash to zero via hardware.

1 Like

What about program ability right on the cut contol software without a program written from Fusion 360? We have that on Trak mills where I work

1 Like

I use onedrive. Automatic syncing of the folders I’m using for cnc programs.

Is there a way to run single line code?

Go to this position, etc.

1 Like

HAAS probing system allows for CMM style post machining inspection for verifying the diameters of bores, locations of features, etc. Is this something that is or could be supported by CutControl?


Request for Tool Setter Option to go to Max Z+ Retract

Hi guys,

Ran into an issue today where my Tool Setter settings of Retract distance (~4 inches) using a long drill bit caused the machine to error out due to GCode exceeding max Z travel. Instead of specifying an absolute retract distance, can we just have the machine go to max Z+ instead? Or at least have this as an option, that way [long] tool length doesn’t cause an error?


I would like software based “spindle lockout” and “XYZ motion lockout” functions to provide a second layer of defense against unintentional spindle starts or gantry motion.

When clicking these functions, one could enter a 4 digit code for the lockout and the unit will refuse to spin or to move until that code is provided again. This would avoid any risk of accidental starts on the spindle or accidental motion, even in the event of an operating system glitch. Cut Control is after all just an application running on a Windows PC.

One could make a similar argument for the on board MCU, but those tend to be more stable and if the drive could be disabled, that would seem to be sufficient (you’d have to have a rogue MCU enable the drive and instantiate motion).

Unfortunately, the e-stop button is an all or nothing thing… and it’s very inconvenient to reach at the back of the machine.

1 Like

Just a thought, it would be very easy to wire a hardware switch inline for the spindle and the motors, with a separate little panel at the front of your machine.

Much faster than waiting for a software feature, and even more reliable.


Yeah, that’s what I think I’ll do. I shouldn’t need to hack on basic safety features like a spindle or motion interlock though… I think easily usable/accessible safety interlocks and not being able to do a manual tool change in a single job are the two biggest misses on this machine.

It’s kind of funny really considering how fully featured the machine is (flood coolant w/relay, enclosure, high power spindle, etc.). To be missing accessible safety interlocks is like missing seatbelts. I didn’t even think to research if these were on the machine, like seatbelts, we just assume they are on board.

1 Like