Crossfire Pro stops moving but remains firing (Solved)

So I have a crossfire pro with a prime welds cut60 and when I run my sample cut, it will cut the first hole (sometimes) and then it will move and start another cut, just to fire and sit still until I manually kill power to the machine. I also cannot pause or stop the cut from the software. Is this an issue that anyone else has had? any tips? my settings are correct as far as I can tell.

Thank You!

sounds like you’re getting electrical interference. How close is the cutter to the control box? you want it as far from each other as possible. i have mine on a HF welding car on the opposite side from the control box.

The machine is touching the Control Box… I will move it now and report. Thank you

So, we moved the machine as far as the provided cables will allow (about 3ft from the box) and still the same issue. I also am noticing that it is not recognizing the THC and simply says " No Connection". It was making these holes, now it starts and only makes this shape while firing but not moving.

I use extension cables to extend my torch on/off and thc cables and allows me to move the cutter farther away from the control box. 3 feet still might be to close.

As far as the thc not connecting. was it lit green before or was it never on? If never on then you might need to manually install the thc drivers from the downloads section .

So the driver did fix that THC issue, I didn’t think about that because I was trying a different computer. however, still no change even after trying to use a sheet of steel between the two to block some EMI. I guess I will try to find extension cables for the barrel connecters.

i used these. bought 2. I also added ferrite chokes to all my cables.

@TAS_Performance I had two Cut 60s and wasted a lot of time, money and energy trying to get them to work with my Pro. Some of those machines just crank out the EMI, while others work great. Customer service is Primeweld’s strong suit, so reach out and see if they’ll take the noisemaker back. Life is too short to spend it fighting those gremlins.


I ordered the extensions as well as the ferrite chokes, great idea!

I second that! they agreed to send me a new unit and offered to return mine before I even asked. I will definitely be doing business with them again. It is a quality product, It cut well when I tested it freehand.


I had this same issue today. I got the pro out for the first time since last October. When i put it away it worked perfectly. So this morning i get it out clean and oil it all that. To start with my plasma wouldnt fire. after this a few times restarting Firecontrol each time it got to where it would fire make a cut or 2 then just sit with plasma cutter still going. Firecontrol was froze nothing as far as controls worked. Have to manually pull the plug on it. After an hour i decided to up date Firecontrol and THC. I dont know why it worked last year and this year it did this but updating solved all the problems. Worked perfect every time after update. Maybe if you havnt updated you might. And your issue may be something else totally different but same symptoms.

1 Like

Well it definitely sounds like my situation and at this point I’ll try anything.

What version of the software do you have now? I have 20.6.2 and I still have this issue after uninstalling and reinstalling. I also tried to take care of any EMI with no luck so I feel like its software related but it is across all of my computers mac and PC…

1 Like

I have never seen that before…not sure if I want to ever again…

you are going to overheat your plasma cutter…no ventilation

It was literally for one test cut for diagnostic purposes…

just out of curiosity have you tested the power in your house for faulty neutral hot connections?
get one of these and check outlets in your house and workshop…

Yes, the electrician ran this outlet a week ago along with others and I was overseeing the whole thing

yeah the cutter is a lil too close for comfort to the control box… have you tried the extension cables yet?

I originally had the Razorweld and had a lot of problems initially. Moved things around and found the “sweet spot” by trial and error. I have cheap LED lights in my shop, and a cheap Bluetooth amplifier to a couple of speakers near where my laptop sets. Both cause interference, and I found that exactly where I set my laptop was also causing issues. Once I realized that, didn’t have a problem for 9 months. (I was having FIrecintrol freeze with the torch on). I then got a Primecut 60 and started having THC issues immediately - same placement, cable routing, setup as before. Finally found that all my issues went away when I unplugged the power from the laptop. Now I’m back to prefect, non-lockup cuts. (Fire control wasn’t freezing, just no THC / voltage read back).

1 Like

Nice Faraday cage.