CrossFire Gen2 Firmware Update 1.3ls & Limit Switch Kits

CrossFire and CrossFire PRO Owners,

As we ship the first batch of Limit Switch Kits, we are releasing a minor update to the 1.2LS Machine Control Firmware with settings required for Limits and Homing. This update (1.3LS) contains the minimal set of changes required for this functionality and none others.

If you have not purchased a Limit Switch Kit (we encourage you to do so) this update should cause no changes to your system. We have been running this version in our shop for the last few weeks without issue.

If you purchased a Limit Switch Kit, you will be required to update to the latest version using the orange ‘Update Machine’ button in the version bar (upper right) of FireControl.

Screen Shot 2022-11-30 at 4.17.17 PM

Use of the Limit Switch Kit requires a version of FireControl that contains homing functionality. Users currently running a 20.X version will need to update to a 21.X version.

Once the firmware is installed, Limit Switch Kit users will have to use the Machine Settings menu to Reset their machine defaults to apply the settings changes.

Full instructions on installing and configuring your Limit Switch Kits are available in the CrossFire and CrossFire PRO Assembly manuals.

If there are any issues with this update, please post them here and we will address them.

5 Likes

Would add for FIRECOTNROL version I was already at V21.1.4 and the “Reset default” option is machine settings was not present. Had to delete firecontrol and download V21.1.5!

It seems that the machine limit origin (Y axis, based on the new limit switches) and the work origin are at different corners. After homing if I import a drawing, by default it imports to a space that is unavailable to cut. Many people (including myself) use brackets to square up sheet stock at work and (former) machine zero. But now, those people have to rely on soft limits instead of hard limits for the actual work zero. To me, it makes far more sense to have the machine and work origins in the same location.

Currently the work origin is at +33 inches on the Y axis after homing, while the machine origin is at 0 inches, which is very confusing. Why does the X axis increment while the Y axis decrements, but only for the machine coordinates. The limit switch kit has plenty of room to mount on either side of the Y axis. Is it possible to have a setting where the user can configure which side the limit switch is mounted so that (0,0) is the same for both machine and work axes? Or can we enter negative values for the Y axis soft limit?

This new split origin system is very confusing.

2 Likes

Can u make the update available w/o being connected to machine. I have no internet in garage and hot spot is not working either

How do i update machine with a mac?

Looks like it can only be updated with a PC at this time. I checked with my Mac which I use as a backup to my PC that runs Firecontrol normally. I’d already done the firmware update with the PC so the limit switches work fine with Firecontrol on the Mac, but yeah looks like the PC is the only way to update the firmware for limit switches for now.

You’d have to connect the machine to a Windows device via USB to install the firmware update. Once the firmware is updated, you can reconnect to your Mac with no issues. Apologies for any inconvenience!

1 Like

Finally got around to installing and setting up the switches. The installation manuals should be updated to include that a Windows device is required. Luckily I have Windows on BootCamp on my Mac.

They should also be updated to note that you have to Home the machine before enabling soft limits as the soft limits (when turned on) presume that you are at (0,0) and won’t let you move back. Maybe that’s just a bug though?

Also as noted that the work area is now different from machine area and it being generally confusing, technically the Y soft limit should be negative, and not positive. A positive Soft Limit for Y would be off the table.

I am settting up my Crossfire Pro. I purchased the limit switch kit and working to install it. The issue I am having is the update firmware button is not there. I have the latest version of FireControl. I use the dropdown menu and the option for a Fireware update is to 1.2ls but that is what is running now. I am unable to move forward without the update. Please help. Thank you.

Do you happen to be using a MAC OS machine? I don’t believe you can do the firmware upgrade from a MAC.

No. I am not using a Mac. I am running Windows 7.

I’ve just fitted my Limit Switch kit (at the same time as the Gen 1 to Gen 2 Crossfire THC upgrade) and the setup doesn’t appear to be working correctly?

I have updated the Firmware and running the latest Fire Control software (V21.1.5). I reset default values and then enabled Limit Switches. I then clicked on the home button and X moves in the negative direction towards the limit switch but, Y moves in the positive direction towards the Y stepper motor (away from the limit switch). If I don’t cancel the home Y axis crashes?

What should happen when I hit the home button and do I need to zero anything before hand?

Woz

Woznaldo,

Have you watched the youtube video that Designs By Todd put together? Was a great step through of a total limit switch install and software upgrade. Here is the link https://www.youtube.com/watch?v=r_j5JFEFijo. As a side note, once everything is done, make sure you hit the correct home button and know where home is. There is a home (machine) on the right side of Fire Control and then a home (work) on the left hand side which you can set by zeroing the x and y axis. Took me a few minutes to figure that one out. Good luck.

2 Likes

From the looks of the video, I have the Y limit switch in the wrong position. I think this is because the instructions are Crossfire Pro based and I have the base model.

This makes sense and would mean all is well. I will change position and re run the home test and soft limit setup.

Thanks Smiley

1 Like

@Smiley repositioning the Y limit switch to the other end of the Y-Axis worked. Limit switches all setup now.

Thanks for your help.

3 Likes

Glad it worked. I have enjoyed my limit switches on my CFPro.

1 Like