Correct G-code for drilling

Possibly a post processor issue, but I’m getting an error when attempting to drill. First was a peck drill and that failed so I tried standard and that failed too. Using mastercam 2021.

so for help we need to know a few things…

  • what table are you on a 2x2 OG running mach3…a 2x2 Crossfire Running Firecontrol…or a Pro table?
  • what software are you using for design?
  • are you post processing with Fusion360 or Sheetcam?

Probably MR-1 would be my guess…


well that explains it…
what thread am I in…???

LOL, it’s unspecified, but, in your case, it’s anybody’s guess!

1 Like

I was wondering why I didn’t see my thread show up on the mr1 section lol

Use these drill parameters furnished by Langmuir. They work perfectly.
Cutting Parameters - Getting Started Reference Guide - Rev. 11_30_2022.pdf (71.7 KB)
The drill section is towards the end.
Let me know if I can help you get this working. Follow the inputs into Mastercam exactly like are on the page. I’m not fluent in MasterCam but I’m sure the settings can be entered without a problem.

1 Like

if I remember correctly G81 is a Fanuc drilling cycle, so it sounds like a PP issue

1 Like

I thought he was using an MR1. Yes, it does sound like a post processor issue.

Yeah this is what mastercam spits out with the post processor for the mr1. Looks similar to what mastercam creates with the default 3axis mill post. I only needed two holes so I just jogged to the x,y and drilled it using .01 -z jog steps. I’m curious what the g code looks like for the people using fusion 360?

Sounds like we need to work on the mastercam post a bit- is there an option in mastercam to output g code directly as opposed to drilling canned cycle codes?

I’ve never had to look into it so not sure. It might be burried in a config screen somewhere though.

I ran into the exact same problem using the solidworks post processor this morning.

I know for sure solidworks allows the user to post drilling cycles as regular G code- as opposed to canned cycles.

Daniel, has the solidworks post processor been updated since it was first released? I downloaded it when it first got put on the site but I do not have an option to use the long code format as opposed to the canned cycles. Per the solidworks help menu there is a header that needs added to the post processor to have that option, but I don’t have a way to add that line to the post as I cannot edit the .ctl file. I am far from an expert on this so maybe I am missing something.


I did do some additional searching through Solidworks resources last night and from everything I found the post processor would need to have that line added by the supplier to enable that selection. Is this something we can get updated on the Solidworks post?

Daniel, I am wondering if you were able to figure out anything on this? Right now whenever I perform drilling operations I am having to manually change the G-code to the long format. It should be a pretty simple update to the post processor to enable that checkbox in solidworks.

Sorry to bump an old post, but Im having a heck of a time trying to drill a bolt hole pattern with the solidworks post processer.

Can you give me a break down of how you changed this manually? I just need to drill some holes and have no way to do so right now.

Not a solidworks guy. But can’t you set up hole clearing and peck depth with solidworks. I drill holes every day up to 1/2 without problems. Langmuir has a drill guide for the setting. Again this is for fusion.
Cutting Parameters - Getting Started Reference Guide - Rev. 11_30_2022.pdf (71.7 KB)

1 Like

I ended up emailing Langmuir. Their post processor for SW doesnt have a button to not use “canned” cycles, which is ridiculous as they cant take them in.

They told me to use a basic SW processer and then uncheck the box, then go back and use theirs. Hopefully they fix it in the next release of cut control as thats a very major functionality issue.