Constant misfiring, THC rising during cut, misfiring during cut

I have a vipercut 30 with the raw voltage wired and THC with a X45 machine torch. Right now I cant do more than 15 or so pierces once if gets started before I get some kind of error. Sometimes it will pierce and run perfect and then in the middle of the cut, it will turn off. Sometimes it will turn back on if i dont have THC turned on. when it misfires, sometimes it will only be air pressure. Sometimes it will be nothing at all. Sometimes it will get going fine and then THC will begin to lift 5/8-3/4" from the base metal before I shut it down manually. While it does that, I’ve watched in FireControl the THC says its Good and Active so I dont know whats going on there. I’ve tried all the various ranges of air pressure. I’ve tried new consumables (i only get about 200 pierces from consumables). I use the Plasmadyne consumables. I’ve tried playing with the THC settings. And although i found I’ve been cutting .049" taller than what is commanded, I made the adjustments in sheetcam and it still does the same thing with or without THC turned on. I’ve tried moving things around thinking maybe its interference but nothing makes a difference. I will say, today, I’ve been messing with it and its getting worse and worse. To the point I cant even use it.

I cant tell if its my plasma cutter or the table or something in the electronics doing it. The cutter works great when it works so i dont think its that. From my understanding, its the Langmuir electronics that control the plasma firing so I’m thinking I can rule out the cutter.

It’s taken me 4 hours just to cut 50 of these little 3/16" flanges and I have 150 more to cut.

I would imagen the viper cut 30 would be at it duty cycle limit at about this point.

I am going to look through a manual … brb

1 Like

its 35% at 30amps.


what inches per minute are you running?

1 Like

47 IPM for 3/16 steel

The cut quality itself is really good considering I dont have any kind of drying setup yet.

10 +/-inches of cut per flange x 15 flanges = 150 inches / 50(47)ipm = 3 minutes +/-

the unit has a duty cycle on 3.5min in 10 minutes

it may be the limit of the machine.

cut 10 or 15 flanges then wait 6 + minutes and cut again

1 Like

Also, previous to this round of flanges, I was able to cut 20 or so of these without getting any errors. Its just gotten worse over time.

it looks great but…

running a machine at maximum capacity can have that effect.

1 Like

I’ve been looking at the primeweld cut60 but I’m really concerned about spending $1000 with the machine torch and having the same exact problem.

so i just tried running it at 25amps at 23IPM just to see if it would give me the same problems and it does.

If it was going into some kind of protection mode, I would expect it to quit altogether. But it doesnt. After I did that test, i ran it again with the normal program. Pierced perfectly and started. Well it quit cutting within a couple inches. Machine kept running and then about an inch later it kicked back on again.

does the overload light come on the plasma?

no. I just checked that. Cutting active light comes on and goes off when it decides to quit. It will come back on when the torch is triggered to cut again.

for shits and giggles, move the torch holder up in the mount then move the torch itself lower on the holder so the torch is clamped more on the body. could be pinching something inside on the bottom clamp. Also, don’t tighten the bottom clamp too much.


it wont let me cut more than one flange now without throwing an error.

Torch mount is low.

I moved the torch mount. On the first cut after you can see where it skipped for a second. Then continued on to do the next 2 flanges perfect and then it quit at the end of the last one.

I’m really at a loss at this point. It’s not a duty cycle issue when it cant run longer than a minute without throwing an error. I just tried moving the torch yet again. The top of the machine mount is at the top of the torch where the plastic is. Still same issue.

try clamping on metal body of the torch only and check the consumables.

Tried it. No difference. Buffed the contacts on the ground and ground the area where the clamp is. Nothing. Doesnt matter if its with or without THC. Same crap. Worked long enough to be outside the return policy and now its not even useable with a big job due Wednesday and their support is super slow (aside from yall and the FB user group). I have no way to determine if its the cutter or the table electronics or if there is something wrong with the X45 torch they sent me.

Do you by chance have a hand torch?