Cannot get arc to fire

Hi all, we are new to this exciting world. We bought an Everlast 62i machine and have the Crossfire pro table. We cannot seem to figure out the wiring. When we first tried it, we heard the air but had no spark to light it, now we have no air and still no spark.

I’m sure it’s how we have it wired. Can anyone give us clear instructions on how to do the wiring? We are so close but yet so far.

We would appreciate any help you can give us.

Pins #1 and #2 on the CNC plug is were the trigger wires go.

1 Like

as much as I respect and trust mechanic416…I have the exact same set-up as you…and I did not use the back pins…
here is a thread on exactly that reason

I have had zero problems with this connection.

feel free to reach out if you need any help…I am always looking for people with the 62i and pro table to share information with…

1 Like

Thank you for you input, we are currently on the phone with a technician. I will keep you posted.

Just have to say as a new user how impressed I am with this forum and the instant replies I have received.

You guys are the best.

ok…no problem…but it is real easy and safe to connect the Langmuir box for divided power to the plasma unit…

He was not asking about THC. He was asking about torch firing.


sometimes I get to excited and miss the main point of the topic…like I said…fully respect you man.

1 Like

Hi we still can’t get the arc to fire. We have the wiring correct but it still won’t fire. Do you think it could be a fire control issue?

does it fire when you pull the trigger on the torch handle?

Do you have the hand torch or only machine torch?
If you have the hand torch disconnect all electrical control connections from crossfire…turn on the plasma and see if you can fire it from the trigger on the torch.
Also check the fuses on the plasma.
With plasma turned on push the air check…do you get air and at what pressure on the front panel?
Check the other button for setting to lock on/off or cnc.
Lock off for freehand cutting and cnc for cnc cutting

1 Like

We don’t have a trigger on the arm but it fired when didn’t the computer hooked up

Do you know if the positive and negative wiring from the plasma book to the torch on off plug on the table?

there is no polarity for the torch on/off…it just acts like a switch.

1 Like

That is NOT how you mount a machine torch!

first off, you’re gonna need a machine torch holder… that one is for a hand torch. you can try to flip it around so it’ll grip the shaft of the torch instead of the cup.

when you try to fire it from firecontrol, do you hear the relay click in the control box?

What did we do wrong?

No we don’t

If you don’t hear the relay make a “click” noise when you use the manual torch fire feature in FireControl, reach out to for further troubleshooting. Make sure to specify that the relay does not make any noise when you use the torch firing feature.

along with what Aksel stated, you can check to see if the relay fell out of its socket by taking off the cover on the control box and see that the relay is in fact in place.