Any hotkeys in firecontrol

So it doesn’t switch between continuous and incremental when you hit the tab key?

Nope no effect at all

I’m tryna wrap my head around how one would do that. you just zing over at 300ips and stop, " meh, close enough"? Or does the TW magic stop on exactly the right spot? ( I’m ready to go with the latter) :grin:

Ok. I was just curious, because I don’t use a keyboard. I use a touchscreen to control the table.

Ya know, I still have no answer. Does it work or not?

I tried it yesterday and it works.

That’s the first step while I’m standing at the computer.

Then I manually set the continuous speed to 50 ipm. Grab my wireless SNES controller walk over to the corner I’m registering off of and dial it in and zero it out.

Having a hotkey that can scroll through the IPM speeds would sure be a welcome addition to fire control.


@keith1 Apologies for the delayed response! I focus on technical support tickets, and keep an eye on the forum when I have a break from those. If you’re seeking a more expeditious answer, reaching out to us at is the best way to go!

That’s very odd, firmware & FireControl updates should not have affected the hot keys. Try uninstalling/reinstalling FireControl, but be sure to delete the .FireControl folder before reinstalling. This folder stays on your C: drive even when FireControl is uninstalled, so if any bugs stem from an issue in that folder, it would persist between installations. The .FireControl folder is usually found via this filepath:

C:/Users/[YOUR USERNAME]/.FireControl

No worries Reilly. It’s not that upgrades STOPPED the TAB/JOG. It’s never done anything and I noticed it listed as a hotkey. So I was asking if it worked for anybody.

EDIT: OK, did the uninstall, deleted the folder, downloaded latest and greatest ( compatibility version) installed. No difference. To be truthful, it would be nice to have but I have never had it so I don’t miss it. Everything else is fine so, I will probably sleep ok tonight. :grin:

@keith1 That’s very odd that it’s not working for you…a personal aside, I quality-control tested the outgoing Electronics Enclosures from 2019 to 2021, back then I used the Tab hotkey constantly.

I’ll let you know if I think of any solutions!


Is your Scroll lock engaged? with some programs that can make the tab key act weird.

Does your tab key work in other programs?

Scroll lock not on, ( multiple reboots would have taken care of that anyway. Tab key on laptop works fine in notepad. Plugged in a USB keyboard, no difference.
Not a huge deal and, as TinWhisperer notes, it works for others. I’ll worry about it in a couple of years when this laptop bites the dust. :grin:


I have just also programmed the logitech gamepad f310, and for me all the quick keys work as described but the tab key does nothing. I would really like to jog be able to have a control key to change the jog speeds remotely.
Is there any new update for the keyboard keys to allow to do this? Does each Jog speed key have a keyboard shortkey assigned to it now??

It does make a world of difference to zero the table with a gamecontroller! But could be better if every function has a keyboard key or keyboard command assigned to it.

Thanks in advance for any update on this matter,

Peter Jan Kwakernaak

Here is an interesting read using a smart phone app:

And here is a program I am currently using with re-assigning mouse buttons. This program is quite complex (in my mind) but is free. Not sure if they have something for a gamepad:

1 Like

I think this is the thread that I read…


There is an issue where the Tab key does not toggle the continuous jog and 1/16 step.

I can duplicate that condition at will when the Fire Control straight cut window/switch/drop down is open.

Tab keeps moving the cursor through the cut parameters (length of cut, IPM, speed…) Regardless of clicking anywhere else in iIre Control, as long as the straight cut option is open, it negates the Tab option for jogging. Close that feature and the Tab key works as normal.


Also want to report that my tab button doesn’t do anything. It used it, but awhile back it stopped doing anything after an update.

  • Edit, just discovered if I turn the visualizer off, the tab function works. Doesn’t matter if I click anywhere else to click out of the visualizer. if the visualizer is present, the tab function does not work.

What does [tab] do?

Tab was the toggle between jog and continuous.

Snapshot of the keyboard shortcut list under help menu in fire control.

:grimacing: Ooops! I guess one would need to read that, to find out. :man_facepalming:

Hey there,

Apologies for the delayed response, we were quite busy over the Holidays and New Year, so I wasn’t as active in the Forum as I like to be.

That’s an odd issue, I’ll definitely be sure to bring it up with the dev team. In the meantime, try a fresh FireControl installation and see if the bug is squashed. FireControl needs to be uninstalled in a specific way for a completely fresh installation:

  1. Uninstall FireControl from your computer via the Control Panel.
  2. Delete the “.FireControl” folder, which is typically located at C:\Users\[USERNAME]\.FireControl
  3. Restart your computer.
  4. Reinstall FireControl.

Have not heard that one!!! :smile: :cockroach: :spider: :scorpion: :mosquito: :fly:

1 Like