Z Height loss AGAIN?

Can someone tell me what in the heck I am doing wrong??

  1. I have set x,y,z 0 with the tool probe work zero
  2. I calibrated with the probe in
  3. I ran 2 tool paths with 2 different tools which included setting the tool zero no issue
  4. Set the 3rd tool to run the 3rd tool path in the setter

Now the work ZERO is 2" above the work piece?? What the heck is this??
No change in work coordinates in Fusion just a tool change

If you could post maybe the first 30 lines of g-code from tool 1 and same for tool 3, someone that is experienced in reading g-code will be able to tell you if something strange happened when the post processer created the file. I only know enough about g-code to be dangerous.

Thank you for the reply. Should probably add that I only changed the tool for the 3rd tool path I never loaded the path itself it still had the last run loaded.

Is tool 3 shorter than tool 2? If so, maybe cut control defaulted to the previous tool height because you ran the same file.

Yes it is shorter. I did not run anything I simply changed the tool after the 2nd tool path had finished, then set the tool and went back to work zero. After that I go back to work zero then I load the next tool path to run. In my mind it has just lost z zero or there is a huge glitch in cutcontrol that keeps showing itself.
Maybe you have a point? Can you not change a tool with a tool path loaded?

I don’t set a new tool till after the next program is loaded. That just the way I have always done it. Is it possible your tool setter is not working correctly ?

How much material did you take off for the first two ops? Which cam software are you using?

For fusion 360 there is an option for original work piece size or to account for material removed.

I see now you changed the tool and use the tool setter to set the tool length and then move the tool to zero before you load the next path. That should not cause any issues as I change the tool and use the tool setter to set the tool length before I load the next tool path. I haven’t experienced any issues. I agree with John that your tool setter is probably malfunctioning or the software has a glitch.

1 Like

That is correct motoracer I load before installing the next path.
I have had this issue for a long time. Could it be the tool setter??? possibly but in my head it is not happening all the time so I would think I could eliminate that. We are talking 2" off. Sometimes I can go days or maybe longer before this will happen and I can not help but to think this is a glitch in the programming of Cut?? Even if it was the tool setter I would think it would not even indicate. Unless I am wrong the tool setter is just an open/closed switch??

1 Like

I am not a machinist, but I did some some repair on a large CNC wood router for a few years.
Is it possible the tool setter may only act up when using a certain length tool? do you see any pattern as to that?

You know Knick that is not out of the question. I cannot be 100% certain on this BUT this particular bit is a .060" drill bit. I do not remember what the rest of the fault tools were. This Cut Control is so under par that I am just wondering if it is not coming close to the soft limit on the tool setter and spazzing out the program internally??
Here is a question, if you have a small bit in the collet and it a little high in the collet does anyone ever set off the soft limit warning? Has anyone made a base for the tool setter to raise it??

Somebody on he Facebook MR1 group posted a Fusion 360 file for a 1" riser for the tool setter. I downloaded it but haven’t made it yet.

Thanks. I don’t do facebook but will see if I can hunt it.
Either I am the only one doing small stuff or others just ignore these issues. I struggle to think I am the only person with these issues.

Anyone have a thought? I am convinced this is and has always been a glitch in the program. Look at the end of this vid (0.24sec). It is calculating after the lift from the tool setter. It has to be missing that calculation or at minimum grabbing the wrong numbers.
I am not 100% but I have never seen this at the end of the transition??

https://1drv.ms/v/s!Aqp7793OxWZAg_1bjkBvfNPN3ZgyYQ?e=k1PGR6

Here is the fusion file for the tool setter riser.
MR1 Tool Setter Extension v2.f3d (172.0 KB)

OH WOW Thanks motoracer. I will definitely make that.

I haven’t used CutControl for a while, but I seem to remember it working that way. It retracts to safe Z, then calculates the offset from toolsetter to your work surface. I agree that they could do the calculation before the retract, but the order shouldn’t matter too much.

I liked their approach for using the tool setter and probe and copied it in my LinuxCNC setup.

I don’t recall what the searching distance is but I’m certain it can “timeout” so to speak. I jog short tools to a height an inch or two from the platter. I just assumed it would error out, never actually tried to see how far it would go.

I have run into this issue a few times. The first time it tried to drive a 1/2" endmill through my part (Hey Langmuir, add DTG to the DRO!). After that I always check to make sure the offset has actually updated. I’m super cautious now, two other occasions the cycle executed normally but it failed to actually update the offset. Had to run the probe cycle again.

My opinion here is the CC software is too young to be explicitly trusted. I’ve developed a habit of double-checking as much as I can. I’ve found errors in my post processor that also required tweaking but those were somewhat easy to identify before even turning the machine on. I keep trying to break it.

I cannot identify any particular set of circumstances that leads to the offset not being updated and it appears to be completely random so keep an eye on it.

1 Like