Z axis raising randomly (solved)

My z axis seems to raise randomly.

When cutting the torch is tracking along like it should and sometimes the z axis will just start raising. I stop the program, and re run from that loop and it works fine.

Have had this happen many times already and it’s easier to just disable thc

I’ve isolated the ground to the laptop, made sure I had the latest software for fire control.

Made sure my tip/nozzle is clean.

Any suggestions?

Are you still running an Everlast 50s?

How do you have the THC voltage measurement hooked up to that machine?

Does your z axis move up and down freely with no chatter or sticking?

Is your torch installed in the z-axis with enough room to bottom out fully?

Are your consumables in good condition? Are they of good quality?
I see you said your nozzles clean what is the electrode look like?

How do you deal with drying the air before using it in your plasma?

Are you fixing your work clamp to the material?

Are you using a USB extension or a different USB cable then what came with your langmuir?

strong text

Are you using raw voltage right from the lugs inside your Everlast machine?

I had rising issues when using the CPC port on my Everlast 60 s.

Raw voltage from the cpc port.no issues for the longest time then the past month or so these start showing up

started doing this on one particular cut, then i changed the program and wouldnt do it

Your torch is mounted very low on the Z axis. Rise it up so the slide is not almost bottoming out on the Z axis frame when trying to touch off.

I hear that the CPC port has historical worked for you and I still would switch to internal raw voltage from the lugs with the thicker banana clip wires.

Understood about the torch height and wiring to the lugs and will try

But Would it explain why it doesn’t do it when I change the program?

do you mean change ;

to a new program entirely


reloading the same program.


can you post the code for the cut in the video?

Yes different program runs good, kinda why I was thinking it may be on the gcode side. All the old programs I’ve tried seem to work like normal.
M.nc (726 Bytes)

Your cut height is set too high. it more than 1/2 a inch.

reduce it to .055

1 Like

After looking at the code and rewatching your 11sec video I can see the torch fire at the pierce height and then rise UP to the cut height.

1 Like

Thanks!! Really much appreciated,
Think I must’ve hit .55 instead of .055

Was just about to report back that I uninstalled and reinstalled fusion and it cleared it up, but your fix is more scientific… lol

Gets me through this job and will tinker more with connecting to the lugs than the pin out on the back and will report back

you are welcome.

Over one hurtle and on to the next.

also adjust the position of your torch in the holder

Already did, thank you friend for taking the time to help me

1 Like