Z-Axis Not Moving on "New" Table ( Solved )

Hi All,

I bought a table a couple months ago. I performed a single cut, then long story short, I drained the table and unplugged it from power and it sat until this weekend. I was getting everything ready to go and refreshing my memory on how it works, but unfortunately I went to make the machine’s second cut and I cannot get the z-axis to move.

If I swap the Z-axis and X-axis d-sub cables, the Z works fine, but the x-does not, so there seems to be no problem with the motor itself. There is no green light from what I assume is the Z-axis driver box (only blue), but it does seem to come on briefly when the machine is powered on. All cables have been reseated.

Any suggestions?

Does your computer have a the driver installed? Click on the top left corner of FireControl and download the latest version of the driver.

1 Like

Sounds like a bad stepper motor driver. You should submit a support request.

1 Like

Yes the driver was present and also reinstalled as an attempt to troubleshoot. I will reach out to support, but just wanted to make sure I wasn’t missing anything.

Support seems to agree that it is the z-axis driver board. I’ll update this thread with a resolution when the part comes in.

1 Like

Solved: the new z-axis driver board fixed the issue. I had a lot of connection issues after installing the board, but a few reboots fixed the problem.