Y Axis Leadscrew Issue/Binding Near Max Travel - SOLVED

Got the machine together and started the break in program. The machine would stall about 2 inches away from max travel on the y axis towards the y axis motor end then bang off the bolts at the bearing block end. I stopped the program and jog the machine back and forth. The y leadscrew seemed bent so I disassembled and rolled the leadscrew on a flat surface. Sure enough it was. So I carefully straightened it out and reinstalled it. Ran the program again and same issue. I then reset the y leadnut closer to the y axis motor. This with a little oil seemed to help. Ran the break in program a few times with with little to no issues. Some bearings on x axis rail were not in contact with the rail. Adjusted those and continued the program. Did some test cuts and line test for the material I had on the machine. Got the speed and amperage disabled in. Good to go!

Did several small cuts at machine coordinates less then y 12. Everything ran great! First cut that ran about 2-3 inches from max y travel seemed to skip steps. Reinspected the y lead screw and the lead screw seems to run eccentric to the motor coupling. @langmuir-daniel here comes the questions.

Would rotating the leadscrew some amount of degrees to the coupling then retighing the set screws solve this?

Or is it possible for the coupling bore is slightly bigger then the leadscrew diameter and the set screws push the leadscrew to one side of the coupling?

Would the leadscrew being slightly eccentric cause that much bind to stall the motor?

I remember reading a post about the leadnut mount being slightly tilted on a few machines. Has that issue been eliminated?

Looking for a little direction on diagnosing the issue. Thanks in advance.

The lead screws we get from a roll threading manufacturer are only guaranteed within 1/8” runout. Since the Length to Diameter ratio is so large, the lead screws are able to conform and flex. Typically lead screw runout is not what causes the binding issue to occur.

I would try the following:

  1. Put more oil on the lead screw. Grease actually works better in this application.
  2. Break loose the lead nut screws, but do not remove them. Just loosen them to the point that the lead nut can float a little bit.
  3. Run the break in program all the way through a few times.
  4. Jog the Y axis all the way to the +Y limit. Tighten one of the four lead screw mounts.
  5. Jog the Y axis and check for binding. Tighten a second screw.
  6. Repeat steps 4-5 until all four screws are tight.

So after trying everything you suggested the problem still existed (probably should knock on wood at this point, lol).

Took the gantry to max +y travel and loosened then tighten y axis aluminum mount bolts that secures it to the tube. Nothing. Loosened the motor coupler setscrew and turned the leadscrew 90 degrees and tightened it back up. Nada.

Maybe I tightened the stanchion plate bolts too tight and the tube is out of square. Out comes the calibers. Measures within a few thousandths from side to side, top to bottom, both front and back. Kudos on getting the tube to such tight tolerances! That ain’t it. Well maybe there is a high spot on the tube. Loosened the y axis bearing blocks so they had slop in them and could float over any rough spots. Still did the same thing.

Took the gantry to max -y travel and took off the y axis leadnut. Gantry moves just fine front to rear along the y axis. Wtf?

Maybe the y axis motor driver amperage is set wrong and it’s stalling the motor on long runs as I had always started from max -y and moved to max +y. Nope.

Let’s check the leadnut. Y axis leadnut still disconnected I moved the gantry to max +y then put a death grip on the lead nut at max -y and jogged to max +y. Didn’t realize how strong those stepper motors are. Motor stalled as the leadnut approached max +y travel right about where it stalled before. Hummmmm… hooked gantry back up to the leadnut and checked again. Sure enough same spot where it has been stalling. Ran leadnut and gantry to max -y and disconnected the leadnut again. Inspected the leadscrew where the nut had been stalling as I jogged the y axis. Didn’t really see anything but ran a wire brush in a drill against the leadscrew as it was turning to clean the threads. Took the bearing block off and took the leadnut off. There were a few stringy pieces of plastic inside the nut but in the open spaces where the relief cuts are. Removed them and started putting everything back together and used water resistant silicone spray to lube everything.

Wouldn’t you know it. Crashed the machine at max +y travel first attempt to move it. Ran the break in program 4 or 5 times to make sure it wasn’t a fluke.

I’m not sure what it was but here’s what I think was happening. There was a burr or imperfection in the leadscrew and as the leadnut made it’s way over it the stringy plastic in the leadnut would catch whatever it was and bind the leadscrew against the leadnut.

Only time will tell if this is a permanent fix or not but I’m slowly regaining confidence to cut near max +y travel.

Thanks @langmuir-daniel for the suggestions. Keep up the good work and I am really enjoying the machine! At some point in the future I would like to pick your brain on a few things.

1 Like

@langmuir-daniel happened again tonight. What can it be? I’ll try to get a video tomorrow…

Hi there, thanks for all of the detailed information. When you had the lead nut disconnected and holding it in your hand, you were able to stall the motor? Was the lead nut difficult to turn in that area?

Sounds like its either a bad lead nut or lead screw! We can send you both of those if nothing else you try fixes it.

Does the white part of the lead nut slip over and cover the black rounded end facing away from the motor?

That will bind the screw and it won’t turn without a wrench on the nut and something keeping the screw from turning.

After a bit of troubleshooting the problem is definitely with the leadscrew and leadnut. First I swapped the x and y stepper cables to make sure it wasn’t in the controls. Used the x axis keys to move the y axis and the binding happened in the same spot. After swapping things back I flipped the leadscrew end for end and the problem followed. It switched from near max +y to near max -y.

If I spin the leadnut against the leadscrew near the problem area I can feel the tension get noticeable stronger.

What do you need from me to get things moving forward with a replacement? @langmuir-daniel @langmuir-megan @langmuir-mike

Excellent troubleshooting skills! You definitely have a bad lead screw, but we will send you a new lead nut for good measure. The good news is that we are making a USPS run here in a few hours so these will go out today.

1 Like

Sweet! Just got the email! Thanks for the help! I’ll report back once the new items are installed.

I am experiencing the same issues and have since day 1. I haven’t had time to to get my crossfire running after spending a week on the high frequency problems. I assumed that my issues were a new machine and that it would break in over time and loosen up. The problem is that I cant successfully run a program to break the machine in. I did manage to get the break in program to run once by liberally applying oil to the lead screw and slowing down the speed to a crawl. I will take my y lead nut off and try to see if I have a bad spot in the lead screw.

1 Like

In reference to Burgs04 problem described, I too tonight experienced this after assembly. I’ll look into this more tomorrow but I’ll definitely be taking a closer look at the lead screws.

Also, my machine adjustment was way off, wound up having to actually level the gantry first in the middle of the table and then I could start as your video suggests.

So similar to @Burgs04, the lead nut hangs up at a specific spot on the lead screw? If you were to flip the lead screw end for end would the issue follow (like it did for @burgs04).

Also, the gantry must always be leveled in the center of the table after initial assembly. Can you explain how the process was different from what’s described in the video?

Hi All,

I spent some time really diving into this issue and started looking more at the lead nuts we have in stock. About 90 percent of them screw onto the lead screws very easily and motion is quite fluidic. The other 10 percent, however, do not screw on easily and actually take quite a bit of hand force to get them to turn. We are now doing 100% QC on those from here forward and discarding the bad ones.

As always, if you encounter an issue (be it this one or something else), we will get you the parts you need ASAP.

4 Likes

@langmuir-daniel,

I didn’t mean to hijack the thread, so apologies. I will first try tonight to re-align the gantry and then I will also try switching lead screw positions. However, before I do any of this, I will try to apply some oil on the lead screws, yeah, missed that part and even questioned that last night, haha.

As far as how my situation differed from the assembly videos, well, it did not matter what position I put the gantry when setting the height to determine float height per the 1/8" spacer. I wound up having to get a level out and “leveling” the gantry’s “welded tube” where the the 8 bolts secure it. Try to imagine, wobbling the whole assembly until it was level in x and y direction. Once I did that I could achieve what was described in your assembly videos.

Thanks,
-Tom

One of the setup videos had that step. It included directions on what bolts to loosen and how to tighten them after getting the X gantry leveled (done in the center of travel or as you noted, the center of the bed).

I think that’s what Daniel is looking for - how did your center leveling differ from the videos description of leveling the X gantry in the center.

@langmuir-daniel and @jamesdhatch,

Sure, let me see if I can explain better. First, yes, I did exactly what was described in the video. The problem was that I could never get the adjustment even close to what was shown in the video.

Summary:
At time marker 2:10 in the assembly video 7, i did as described
At time marker 2:18 (same video), I did as described and proceeded with video
At time marker 2:30, did what was described and loosened cap screws as shown in video (also slightly snug them)
At time marker 3:05, I could achieve what was described and move the gantry up and down (did not have to loosen or adjust cap screws)
At time marker 3:20, I have a water table so I positioned as shown in video with vertex flush with the carriage and tightened only top 4 cap screws.
At time marker 4:30, inserted 1/8 spacer as described, this is where it got interesting
At time marker 4:45, in the video you begin traversing the carriage, yeah I couldn’t even make it past the very next slat without the torch mount hitting the next slat.

Checked each individual slat height and everything was seated and positioned correctly in water table

I tried everything, moving the gantry up or down as shown at time marker 5:00 in video. Nothing I did would allow me to traverse the carriage without it hitting the slats.

This is where it differed for me. I wound up having the pick up on the opposite side of the carriage where the carriage rides the y axis tube. I had to utilize a level to align this side of the carriage first before I could even traverse along the slat bed as shown in the video. It took awhile because when you pick up the opposite side, each bracket that aligns with the the 4 cap screws on each side wants to shift on you. This is what I meant by I had to position the carriage in the middle of the table and basically wobble the entire gantry tube until aligned. I just didn’t see how to adjust it this way in any of the videos or mentioned anywhere else so maybe this could help someone.

Once I was able to align this side of the gantry, I could then begin to traverse the carriage as shown in the video and I was able to fine tune the height as shown after time marker 5:00.

The good news is after an application of light grease on both lead screws, the machine runs beautifully now. I will definitely keep a close eye on the lead screws though. Also, I applied a light application of oil to each of the x and y axis tubes to ensure the bearings where moving freely.

This could just be unique to my situation so I understand that as well.

-Tom

New leadscrew and leadnut are in. With the new parts installed the binding issue at near max +y travel has disappeared. Thanks @langmuir-daniel and everyone at @langmuirsystems for your quick response. Top notch! Mark this down as solved!

4 Likes

Similar problem. Ran the break in program first time. Worked OK. Looked like it was hitting the max stops in X and Z. Stopped and started over. X axis appears to be working as advertised now but y axis “stalls” / stops approximately 2" short of max…then hits the stop at min on subsequent lines of g code. Oiled the lead screw. Same problem. Loosened and retightened set screws on coupler nuts on bearing end and motor end thinking lead screw was bowed/ not properly seated. Same problem. Tried jogging in y axis. Stops at same place, approximately 2 inches short of max. Shaft feels warm to touch on that area, Tried loosening 4 leadnut cap screws/nuts and jogging. Binds in the same spot.

Bent Lead screw? I am out of ideas.

R2

When it binds loosen the lead screw nut attachment nuts. See if the lead screw now touches the side of the lead screw nut attachment plate.

If it does you’ll need to adjust the gantry alignment (Daniel did a video on the Langmuir setup series - either 5 or 7 I don’t recall which).

Also, make sure you do the Y-axis lead nut attachment procedure with the lead nut in the right place on the lead screw - I recall it being toward the limit of travel near the motor. It’s easy to miss that (it’s in the videos) and just do it more near the center of the lead screw because you’re doing the X axis there.

If none of that fixes it, flip the lead screw end over end and see if it now binds at the other end - suggesting a bent lead screw. You can see the bend if you roll it on a flat plate and see light between the lands of the screw and the plate (you should see light at the grooves).

Thanks James,

The lead screw was fairly centered when I loosened the lead screw nut attachment cap screws. I was able to jog it to the end albeit haltingly, stop then start again.

I followed the videos to a tee. Not that smart to figure it out on my own. I’m not a machinists nor do I play one on TV. Maybe I need to check into a Holiday Inn Express =:open_mouth:

I attached the Y axis nut as depicted in the video. Had to rewatch it two or three times because it was, IMO, glossed over for a nuanced detail as you pointed out.

When I removed the lead screw to reverse it. I first rolled it across a flat surface and it is obviously not straight. It appears to be bowed about a 16th of an inch in the same area the lead nut would have been when the binding occurred. Is there any way to accurately straighten the lead screw?

Your help is much appreciated

Randy