X axis won't move

Just got my pro setup yesterday and when on the step of tightening the lead screw nuts I realized that the x axis would no longer jog after that. The motor spins inside the coupling. I have tightened the coupling more than I am comfortable to make sure that wasn’t the issue. I verified the motor mount and bearing mount for the x axis were square and I have tried multiple times loosening and tightening the leadnut and lead nut mount in the sequence described in the instructions. I have verified the tramming per the video and that is nice and smooth. The x axis moves smoothly if I leave the lead nut mount loose but if i snug it down it gets tight and won’t move. The only thing out of ordinary i could see is the bolt holes in the leadnut were extremely tight (thread the bolt through a non threaded hole kinda tight) that being said there is still plenty of tolerance in the leadnut mount (bolt holes for the leadnut) for the leadnut to slide around in to center it up so this shouldn’t be an issue. Am I missing something here?
Side not the y axis moves like butter so I know I did that right. Im open to any and all suggestions. Thanks!!

does it not jog at all or does it stop short of bottoming out on one side? if so, you might have the wrong mount installed. the Y axis mounts are a lil longer than the x axis mounts.

It jogs all the way left and right as long as that leadnut mount is loose. Nope I have the shorter bearing mount on the x axis

I’m trying to get my machine up and running and am having the exact same issue. Has there been any fixes for this issue. I’m pulling my hair out over here!!

Make sure you installed the mounts to the correct axis.


I did that, actually they sent me 3 y axis mounts so I had to have them send me a new x axis bearing mount. I did have one of the y axis mounts installed originally but something didn’t look right and i started measuring stuff that’s how i noticed it

instead of loosening the mounts, loosen the lead nut from the mount itself or the lead nut mount from the carriage a little and run it back and forth a couple of times.

I’ve done all of that, but as soon as i tighten things back up it gets stuck again. This is what the instructions say. 1. Attach the X Axis Lead Nut Mount to the X-Axis Carriage Assembly using Bag 8 Socket Head Cap Screws. These screws should be seated fully, but the mount should be able to float. I don’t know how you can seat the screws and have it still float unless the bolts are shouldered and mine aren’t.

go to step A6 under CONNECTING ELECTRONICS and try re-doing that part.

Yea it was after that step when when i discovered the problem. I can redo it but with all the troubleshooting that I’ve been doing I’m sure I’ve already redone those steps several times

Still no luck after redoing that step. I just don’t understand it.

It is very important that the bracket that holds the lead nut is square(bent at exactly 90degrees) and square to the X-axis rail. Make sure that the bracket itself is square, so that it is not holding the lead nut at an angle when you tighten the bracket to the carriage. Then make sure the bracket is square to the X-axis rail before you tighten the bolts that hold it to the carriage. You will probably have to remove the bolts that hold the lead nut to the bracket, in order to use a square on the bracket. After that bracket is properly squared up, then mount the lead nut. Oil the lead screw and try to run it back and forth.

1 Like

I’ve out of town working for the last couple of months, but when I got home a week or so ago, I was able to get my machine working properly. i just wanted to thank everybody who replied to my plea for help. i actually just restarted from ground zero and went through the assembly instructions again, but i did have to tweak the X-axis bracket a bit. With that adjustment and probably starting over with a fresh mindset I was able to get it working properly.

Thanks again for all of your help