X-axis not moving properly [SOLVED]

Continuing the discussion from X-axis won’t move properly:

I am having a similar issue, Just assembled, when I traverse the X axis it acts like the servo motors do not initiate at the same time the bridge does move but you can visually see one side move before the other. and some times it binds up. any help would be appreciated.

Did you check everything talked about in the above thread?

I’m assuming, from your statement about one side moving before the other, that you have a Crossfire Pro machine. The axis with 2 motors is the Y axis.

The first thing to check is the connectors that go from the stepper motors to the control box. The screws in the connectors are too long and will push the connector out when fully tightened. Loosen the screws and make sure the connector is fully seated. The connector not being fully seated can cause the motor to lag or sometimes move the wrong direction.

The next thing to try is lubricate the lead screws. The recommended lube is 3 in 1 oil, but any light oil will work.

This assumes that you have the bearing blocks adjusted properly and they are not binding anywhere.


Another thing to check is the lead screw couplers. Take a sharpie and mark the motor shaft, coupler and leadscrew with witness marks then run the Y axis back and forth and see if the marks move relative to each other. If there’s slippage then try retightening the coupler. The cap screws in the couplers have been known to strip out before the coupler was tight enough, especially on the aluminum couplers with only two screws. These steel couplers from Amazon are recommended replacements.

Ruland CLX-4-4-F One-Piece Clamping Rigid Coupling, Black Oxide Steel, 1/4" Bore A Diameter, 1/4" Bore B Diameter, 5/8" OD, 1" Length https://a.co/d/e5SQbMx


Thanks I will check those connectors.

Good thinking I will do that, Also will upgrade the couplings. I believe I am square I have checked multiple times. removed the screws and made sure the y axis moves freely the full length. thanks

You never really cleared up which axis you are having trouble with. You say X but as you describe it, it sounds like Y.

Along with all of the other sound advice you got would be to make sure you have the motors wired to the right connector on the control box. Check the assembly instructions on that.

My bad, It is the y axis I am refering to. I will check that also.

I have removed screws and made sure y axis travels freely by hand it does.
I have tried loosening motor brackets with the bridge traveled all the way to motors.
cleaned the rails put some lite oil on the screws.
in the continuoes mode in 10fpm and 50fpm it does not bind. when I put it in 200 if I tap the direction just for a millisecond than hit the gas it goes without binding if I hold right down it binds .once I get going In one direction or the other its fine. only acts up when changing directions.

I believe I got it, it was the connection. they seem to be very sensitive. Thanks a bunch


When you say connection you mean the electrical connection, right?